All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ian Campbell <Ian.Campbell@citrix.com>
To: Mukesh Rathor <mukesh.rathor@oracle.com>
Cc: "Xen-devel@lists.xensource.com" <Xen-devel@lists.xensource.com>,
	Ian Jackson <Ian.Jackson@eu.citrix.com>
Subject: Re: [PATCH 08/18] PVH xen: tools changes to create PVH domain
Date: Mon, 17 Jun 2013 12:11:34 +0100	[thread overview]
Message-ID: <1371467494.23802.49.camel@zakaz.uk.xensource.com> (raw)
In-Reply-To: <20130614171437.49f55cea@mantra.us.oracle.com>

On Fri, 2013-06-14 at 17:14 -0700, Mukesh Rathor wrote:

> > >  10 files changed, 53 insertions(+), 11 deletions(-)
> > 
> > > diff --git a/tools/libxc/xc_dom_x86.c b/tools/libxc/xc_dom_x86.c
> > > index f1be43b..24f6759 100644
> > > --- a/tools/libxc/xc_dom_x86.c
> > > +++ b/tools/libxc/xc_dom_x86.c
> > > @@ -832,7 +833,7 @@ int arch_setup_bootlate(struct xc_dom_image
> > > *dom) }
> > >  
> > >          /* Map grant table frames into guest physmap. */
> > > -        for ( i = 0; ; i++ )
> > > +        for ( i = 0; !dom->pvh_enabled; i++ )
> > 
> > This is a bit of an odd way to do this (unless pvh_enabled somehow
> > changes in this loop, which I doubt). Can we just get a surrounding if
> > please.
> 
> Sure (will indent more tho). Are you ok with a forward goto?

Not madly keen. I'd rather pull that loop out into a function.

> 
> 
> > > diff --git a/tools/libxl/libxl_dom.c b/tools/libxl/libxl_dom.c
> > > index b38d0a7..cefbf76 100644
> > > --- a/tools/libxl/libxl_dom.c
> > > +++ b/tools/libxl/libxl_dom.c
> > > @@ -329,9 +329,23 @@ int libxl__build_pv(libxl__gc *gc, uint32_t
> > > domid, struct xc_dom_image *dom;
> > >      int ret;
> > >      int flags = 0;
> > > +    int is_pvh = libxl_defbool_val(info->pvh);
> > >  
> > >      xc_dom_loginit(ctx->xch);
> > >  
> > > +    if (is_pvh) {
> > > +        char *pv_feats =
> > > "writable_descriptor_tables|auto_translated_physmap"
> > > +
> > > "|supervisor_mode_kernel|hvm_callback_vector"; +
> > > +        if (info->u.pv.features && info->u.pv.features[0] != '\0')
> > > +        {
> > > +            LOG(ERROR, "Didn't expect info->u.pv.features to
> > > contain string\n");
> > > +            LOG(ERROR, "String: %s\n", info->u.pv.features);
> > > +            return ERROR_FAIL;
> > > +        }
> > > +        info->u.pv.features = strdup(pv_feats);
> > 
> > What is this trying to achieve? I think the requirement for certain
> > features to be present if pvh is enabled needs to be handled in the
> > xc_dom library and not here. This field is (I think) for the user to
> > specify other features which they may wish to require.
> 
> I had asked for assitance on this long ago. But anyways, basically here
> I want to make sure the kernel has all those features because the user
> has asked a PVH guest must be created (by pvh=1 in vm.cfg file). Can you 
> kindly advise the best way to do this? 

This should be done in xc_dom build stuff not in libxl. Basically libxl
should call xc_dom_foo with a kernel and pvh=yes (or =ifpossible) and
the builder is then responsible internally for knowing which features
are therefore required from the kernel.

> > > @@ -245,6 +245,7 @@ libxl_domain_create_info =
> > > Struct("domain_create_info",[ ("platformdata",
> > > libxl_key_value_list), ("poolid",       uint32),
> > >      ("run_hotplug_scripts",libxl_defbool),
> > > +    ("pvh",          libxl_defbool),
> > >      ], dir=DIR_IN)
> > >  
> > >  MemKB = UInt(64, init_val = "LIBXL_MEMKB_DEFAULT")
> > > @@ -346,6 +347,7 @@ libxl_domain_build_info =
> > > Struct("domain_build_info",[ ])),
> > >                   ("invalid", Struct(None, [])),
> > >                   ], keyvar_init_val =
> > > "LIBXL_DOMAIN_TYPE_INVALID")),
> > > +    ("pvh",       libxl_defbool),
> > 
> > I'm not quite convinced if the need for both of these bools in both
> > create and build, it's a bit of an odd quirk in our API which I need
> > to consider a bit deeper.
> 
> Ok, please let me know.

Which places need the one in c_info and which the one in b_info?

c_info is presumably for the createdomain domctl call while b_info is
stuff spread around the build process to handle the various differences?

Perhaps libxl__domain_create_state is the right place for the b_info
one, initialised internally to libxl from the c_info one? In that
context it would be a straight bool and not a defbool since we would
know exactly what the domain was by this point.

An alternative would be for the code to query the domain's type (i.e.
from the hypervisor) when it needs to know -- e.g. libxl__domain_type
does this for HVM vs PV.

Ian.

  reply	other threads:[~2013-06-17 11:11 UTC|newest]

Thread overview: 80+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-05-25  1:25 [PATCH 00/18][V6]: PVH xen: version 6 patches Mukesh Rathor
2013-05-25  1:25 ` [PATCH 01/18] PVH xen: turn gdb_frames/gdt_ents into union Mukesh Rathor
2013-05-31  9:13   ` Jan Beulich
2013-05-25  1:25 ` [PATCH 02/18] PVH xen: add XENMEM_add_to_physmap_range Mukesh Rathor
2013-05-31  9:28   ` Jan Beulich
2013-05-31  9:38     ` Ian Campbell
2013-05-31 10:14       ` Jan Beulich
2013-05-31 10:40         ` Ian Campbell
2013-06-05  0:24         ` Mukesh Rathor
2013-06-05  0:31     ` Mukesh Rathor
2013-06-05  7:32       ` Jan Beulich
2013-06-05 20:41         ` Mukesh Rathor
2013-06-06  6:43           ` Jan Beulich
2013-06-06 22:19             ` Mukesh Rathor
2013-06-07  6:13               ` Jan Beulich
2013-06-07 20:46                 ` Mukesh Rathor
2013-06-07 15:08             ` Konrad Rzeszutek Wilk
2013-06-07 15:48               ` Jan Beulich
2013-05-25  1:25 ` [PATCH 03/18] PVH xen: create domctl_memory_mapping() function Mukesh Rathor
2013-05-31  9:46   ` Jan Beulich
2013-06-05  0:47     ` Mukesh Rathor
2013-06-05  7:34       ` Jan Beulich
2013-05-25  1:25 ` [PATCH 04/18] PVH xen: add params to read_segment_register Mukesh Rathor
2013-05-31 10:00   ` Jan Beulich
2013-06-06  1:25     ` Mukesh Rathor
2013-06-06  6:48       ` Jan Beulich
2013-06-07  1:43         ` Mukesh Rathor
2013-06-07  6:29           ` Jan Beulich
2013-06-08  0:45             ` Mukesh Rathor
2013-06-10  8:01               ` Jan Beulich
2013-06-10 23:10                 ` Mukesh Rathor
2013-05-25  1:25 ` [PATCH 05/18] PVH xen: vmx realted preparatory changes for PVH Mukesh Rathor
2013-05-25  1:25 ` [PATCH 06/18] PVH xen: Move e820 fields out of pv_domain struct Mukesh Rathor
2013-06-05 15:33   ` Konrad Rzeszutek Wilk
2013-05-25  1:25 ` [PATCH 07/18] PVH xen: Introduce PVH guest type Mukesh Rathor
2013-05-25  1:25 ` [PATCH 08/18] PVH xen: tools changes to create PVH domain Mukesh Rathor
2013-06-12 14:58   ` Ian Campbell
2013-06-15  0:14     ` Mukesh Rathor
2013-06-17 11:11       ` Ian Campbell [this message]
2013-07-30 23:47         ` Mukesh Rathor
2013-07-31 12:00           ` Ian Campbell
2013-08-01  2:02             ` Mukesh Rathor
2013-08-01  8:01               ` Ian Campbell
2013-08-02  1:12                 ` Mukesh Rathor
2013-08-29  1:51                 ` Mukesh Rathor
2013-08-29  9:01                   ` Ian Campbell
2013-08-30  0:45                     ` Mukesh Rathor
2013-08-30  9:56                       ` Ian Campbell
2013-08-29 11:13               ` George Dunlap
2013-08-29 11:29                 ` Ian Campbell
2013-08-30  1:24                   ` Mukesh Rathor
2013-08-30  9:53                     ` Ian Campbell
2013-08-30 10:22                       ` George Dunlap
2013-08-30 10:27                     ` George Dunlap
2013-08-29  0:14         ` Mukesh Rathor
2013-07-31  1:06     ` Mukesh Rathor
2013-07-31 11:32       ` Ian Campbell
2013-05-25  1:25 ` [PATCH 09/18] PVH xen: domain creation code changes Mukesh Rathor
2013-05-25  1:25 ` [PATCH 10/18] PVH xen: create PVH vmcs, and also initialization Mukesh Rathor
2013-05-25  1:25 ` [PATCH 11/18] PVH xen: create read_descriptor_sel() Mukesh Rathor
2013-05-25  1:25 ` [PATCH 12/18] PVH xen: support hypercalls for PVH Mukesh Rathor
2013-06-05 15:27   ` Konrad Rzeszutek Wilk
2013-05-25  1:25 ` [PATCH 13/18] PVH xen: introduce vmx_pvh.c Mukesh Rathor
2013-05-25  1:25 ` [PATCH 14/18] PVH xen: some misc changes like mtrr, intr, msi Mukesh Rathor
2013-05-25  1:25 ` [PATCH 15/18] PVH xen: hcall page initialize, create PVH guest type, etc Mukesh Rathor
2013-05-25  1:25 ` [PATCH 16/18] PVH xen: Miscellaneous changes Mukesh Rathor
2013-06-05 15:39   ` Konrad Rzeszutek Wilk
2013-05-25  1:25 ` [PATCH 17/18] PVH xen: Introduce p2m_map_foreign Mukesh Rathor
2013-05-25  1:25 ` [PATCH 18/18] PVH xen: Add and remove foreign pages Mukesh Rathor
2013-06-05 15:23 ` [PATCH 00/18][V6]: PVH xen: version 6 patches Konrad Rzeszutek Wilk
2013-06-05 15:25   ` George Dunlap
2013-06-05 15:36   ` Ian Campbell
2013-06-05 18:34     ` Konrad Rzeszutek Wilk
2013-06-05 20:51       ` Ian Campbell
2013-06-05 22:01         ` Mukesh Rathor
2013-06-06  8:46           ` Ian Campbell
2013-06-07 13:56             ` Konrad Rzeszutek Wilk
2013-06-06 10:08     ` George Dunlap
2013-06-05 17:14   ` Tim Deegan
2013-06-06  7:29     ` Jan Beulich

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1371467494.23802.49.camel@zakaz.uk.xensource.com \
    --to=ian.campbell@citrix.com \
    --cc=Ian.Jackson@eu.citrix.com \
    --cc=Xen-devel@lists.xensource.com \
    --cc=mukesh.rathor@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.