All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/10] Refactoring bnep code to reduce redundancy
@ 2013-12-11 10:13 Ravi kumar Veeramally
  2013-12-11 10:13 ` [PATCH 01/10] bnep: Rename bnep_kill_connection to bnep_conndel Ravi kumar Veeramally
                   ` (10 more replies)
  0 siblings, 11 replies; 12+ messages in thread
From: Ravi kumar Veeramally @ 2013-12-11 10:13 UTC (permalink / raw)
  To: linux-bluetooth; +Cc: Ravi kumar Veeramally

This patch set contains refactoring of bnep functionality, minor
fixes in android/pan and adding PAN profile NAP sdp record to
android.

Ravi kumar Veeramally (10):
  bnep: Rename bnep_kill_connection to bnep_conndel
  bnep: Rename send ctrl_rsp and make it global
  bnep: Move bnep related calls to bnep.h|c
  profiles/network/server: Delete function which does nothing
  profiles/network: Move pan sdp record function bnep and make it global
  android/pan: Remove channel unref which causing disconnection
  android/pan: Fix missing cleanup calls
  android/pan: Fix minor white space
  android/pan: Free connected pan devices on profile unregister call
  android/pan: Add PAN NAP sdp record fo server role

 android/pan.c                 |  40 +++++++-
 profiles/network/bnep.c       | 209 ++++++++++++++++++++++++++++++++++++++++-
 profiles/network/bnep.h       |  10 +-
 profiles/network/connection.c |   2 +-
 profiles/network/manager.c    |   2 -
 profiles/network/server.c     | 213 +-----------------------------------------
 profiles/network/server.h     |   1 -
 7 files changed, 256 insertions(+), 221 deletions(-)

-- 
1.8.3.2


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2013-12-11 13:33 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-12-11 10:13 [PATCH 00/10] Refactoring bnep code to reduce redundancy Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 01/10] bnep: Rename bnep_kill_connection to bnep_conndel Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 02/10] bnep: Rename send ctrl_rsp and make it global Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 03/10] bnep: Move bnep related calls to bnep.h|c Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 04/10] profiles/network/server: Delete function which does nothing Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 05/10] profiles/network: Move pan sdp record function bnep and make it global Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 06/10] android/pan: Remove channel unref which causing disconnection Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 07/10] android/pan: Fix missing cleanup calls Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 08/10] android/pan: Fix minor white space Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 09/10] android/pan: Free connected pan devices on profile unregister call Ravi kumar Veeramally
2013-12-11 10:13 ` [PATCH 10/10] android/pan: Add PAN NAP sdp record fo server role Ravi kumar Veeramally
2013-12-11 13:33 ` [PATCH 00/10] Refactoring bnep code to reduce redundancy Johan Hedberg

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.