All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2] microblaze: Rename global function heartbeat()
@ 2014-02-18  6:46 Guenter Roeck
  2014-02-18 16:10 ` Michal Simek
  0 siblings, 1 reply; 2+ messages in thread
From: Guenter Roeck @ 2014-02-18  6:46 UTC (permalink / raw)
  To: Michal Simek; +Cc: microblaze-uclinux, linux-kernel, achew, Guenter Roeck

microblaze:allmodconfig complains for some configurations that 'heartbeat'
is redefined as different kind of symbol. This is seen in test compiles
of watchdog drivers, which often use 'heartbeat' as ststic variable.

Since 'heartbeat' is an unfortunate name for a global function,
rename it to microblaze_heartbeat. Also rename the setup function
to microblaze_setup_heartbeat.

Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
v2: Use microblaze_ instead of xilinx_ as function prefix.

 arch/microblaze/include/asm/setup.h |    4 ++--
 arch/microblaze/kernel/heartbeat.c  |    4 ++--
 arch/microblaze/kernel/timer.c      |    4 ++--
 3 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/arch/microblaze/include/asm/setup.h b/arch/microblaze/include/asm/setup.h
index b2c08ce..be84a4d 100644
--- a/arch/microblaze/include/asm/setup.h
+++ b/arch/microblaze/include/asm/setup.h
@@ -23,8 +23,8 @@ int setup_early_printk(char *opt);
 void remap_early_printk(void);
 void disable_early_printk(void);
 
-void heartbeat(void);
-void setup_heartbeat(void);
+void microblaze_heartbeat(void);
+void microblaze_setup_heartbeat(void);
 
 #   ifdef CONFIG_MMU
 extern void mmu_reset(void);
diff --git a/arch/microblaze/kernel/heartbeat.c b/arch/microblaze/kernel/heartbeat.c
index 1879a05..4643e3a 100644
--- a/arch/microblaze/kernel/heartbeat.c
+++ b/arch/microblaze/kernel/heartbeat.c
@@ -17,7 +17,7 @@
 
 static unsigned int base_addr;
 
-void heartbeat(void)
+void microblaze_heartbeat(void)
 {
 	static unsigned int cnt, period, dist;
 
@@ -42,7 +42,7 @@ void heartbeat(void)
 	}
 }
 
-void setup_heartbeat(void)
+void microblaze_setup_heartbeat(void)
 {
 	struct device_node *gpio = NULL;
 	int *prop;
diff --git a/arch/microblaze/kernel/timer.c b/arch/microblaze/kernel/timer.c
index fb0c6144..717a3d9 100644
--- a/arch/microblaze/kernel/timer.c
+++ b/arch/microblaze/kernel/timer.c
@@ -140,7 +140,7 @@ static irqreturn_t timer_interrupt(int irq, void *dev_id)
 {
 	struct clock_event_device *evt = &clockevent_xilinx_timer;
 #ifdef CONFIG_HEART_BEAT
-	heartbeat();
+	microblaze_heartbeat();
 #endif
 	timer_ack();
 	evt->event_handler(evt);
@@ -274,7 +274,7 @@ static void __init xilinx_timer_init(struct device_node *timer)
 
 	setup_irq(irq, &timer_irqaction);
 #ifdef CONFIG_HEART_BEAT
-	setup_heartbeat();
+	microblaze_setup_heartbeat();
 #endif
 	xilinx_clocksource_init();
 	xilinx_clockevent_init();
-- 
1.7.9.7


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH v2] microblaze: Rename global function heartbeat()
  2014-02-18  6:46 [PATCH v2] microblaze: Rename global function heartbeat() Guenter Roeck
@ 2014-02-18 16:10 ` Michal Simek
  0 siblings, 0 replies; 2+ messages in thread
From: Michal Simek @ 2014-02-18 16:10 UTC (permalink / raw)
  To: Guenter Roeck; +Cc: microblaze-uclinux, linux-kernel, achew

[-- Attachment #1: Type: text/plain, Size: 1157 bytes --]

On 02/18/2014 07:46 AM, Guenter Roeck wrote:
> microblaze:allmodconfig complains for some configurations that 'heartbeat'
> is redefined as different kind of symbol. This is seen in test compiles
> of watchdog drivers, which often use 'heartbeat' as ststic variable.
> 
> Since 'heartbeat' is an unfortunate name for a global function,
> rename it to microblaze_heartbeat. Also rename the setup function
> to microblaze_setup_heartbeat.
> 
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>
> ---
> v2: Use microblaze_ instead of xilinx_ as function prefix.
> 
>  arch/microblaze/include/asm/setup.h |    4 ++--
>  arch/microblaze/kernel/heartbeat.c  |    4 ++--
>  arch/microblaze/kernel/timer.c      |    4 ++--
>  3 files changed, 6 insertions(+), 6 deletions(-)

Applied. both to microblaze next branch.

Thanks,
Michal

-- 
Michal Simek, Ing. (M.Eng), OpenPGP -> KeyID: FE3D1F91
w: www.monstr.eu p: +42-0-721842854
Maintainer of Linux kernel - Microblaze cpu - http://www.monstr.eu/fdt/
Maintainer of Linux kernel - Xilinx Zynq ARM architecture
Microblaze U-BOOT custodian and responsible for u-boot arm zynq platform



[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 263 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2014-02-18 16:10 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-02-18  6:46 [PATCH v2] microblaze: Rename global function heartbeat() Guenter Roeck
2014-02-18 16:10 ` Michal Simek

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.