All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] Rename NOP transceiver in JZ4740 platform data
@ 2014-07-05  5:34 Apelete Seketeli
  2014-07-05  5:34 ` [PATCH] mips: jz4740: rename usb_nop_xceiv to usb_phy_generic Apelete Seketeli
  0 siblings, 1 reply; 2+ messages in thread
From: Apelete Seketeli @ 2014-07-05  5:34 UTC (permalink / raw)
  To: Ralf Baechle, Lars-Peter Clausen, John Crispin, Paul Gortmaker,
	Vinod Koul, linux-mips
  Cc: linux-kernel

Hello,

The name of the NOP transceiver driver was changed during v3.16
release cycle from usb_phy_gen_xceiv to usb_phy_generic.

The patch that comes as a follow up of this message renames
accordingly the NOP transceiver driver in JZ4740 platform data to fix
a subsequent kernel panic.

Please consider for merge in 3.16 if possible since it fixes an issue
that makes the Ben Nanonote unable to boot.

Changes were rebased on top of the linux-mips master branch, built and
tested successfully.

The following changes since commit bc0b9d9:

  Merge branch 'master' of git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux

are available in the git repository at:

  git://git.seketeli.net/~apelete/linux-mips.git rename-jz4740-xceiv

Apelete Seketeli (1):
  mips: jz4740: rename usb_nop_xceiv to usb_phy_generic

 arch/mips/jz4740/platform.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
1.7.10.4


^ permalink raw reply	[flat|nested] 2+ messages in thread

* [PATCH] mips: jz4740: rename usb_nop_xceiv to usb_phy_generic
  2014-07-05  5:34 [PATCH] Rename NOP transceiver in JZ4740 platform data Apelete Seketeli
@ 2014-07-05  5:34 ` Apelete Seketeli
  0 siblings, 0 replies; 2+ messages in thread
From: Apelete Seketeli @ 2014-07-05  5:34 UTC (permalink / raw)
  To: Ralf Baechle, Lars-Peter Clausen, John Crispin, Paul Gortmaker,
	Vinod Koul, linux-mips
  Cc: linux-kernel

Rename usb_nop_xceiv to usb_phy_generic in platform data to match the
name change of the nop transceiver driver in commit 4525bee.
This patch fixes a kernel panic due to an unhandled kernel unaligned
access.

Signed-off-by: Apelete Seketeli <apelete@seketeli.net>
---
 arch/mips/jz4740/platform.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/mips/jz4740/platform.c b/arch/mips/jz4740/platform.c
index a447101..0b12f27 100644
--- a/arch/mips/jz4740/platform.c
+++ b/arch/mips/jz4740/platform.c
@@ -59,7 +59,7 @@ struct platform_device jz4740_usb_ohci_device = {
 
 /* USB Device Controller */
 struct platform_device jz4740_udc_xceiv_device = {
-	.name = "usb_phy_gen_xceiv",
+	.name = "usb_phy_generic",
 	.id   = 0,
 };
 
-- 
1.7.10.4


^ permalink raw reply related	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2014-07-05  5:34 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-07-05  5:34 [PATCH] Rename NOP transceiver in JZ4740 platform data Apelete Seketeli
2014-07-05  5:34 ` [PATCH] mips: jz4740: rename usb_nop_xceiv to usb_phy_generic Apelete Seketeli

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.