All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] xl: Use proper path for 'do_flr' functionality.
@ 2014-07-08 19:00 konrad
  2014-07-10 15:23 ` Ian Campbell
  0 siblings, 1 reply; 5+ messages in thread
From: konrad @ 2014-07-08 19:00 UTC (permalink / raw)
  To: ian.jackson, stefano.stabellini, ian.campbell, xen-devel

From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>

Commit f74035d3b1e827ff6ff1873e2f10feb011a8d0d2 "xl: PCI code cleanups"
introduced an regression where it changed the name from:
/sys/bus/pci/drivers/pciback/do_flr
to
libxl_sprintf(ctx, "%s/pciback/do_flr", SYSFS_PCI_DEV);

And SYSFS_PCI_DEV is "/sys/bus/pci/devices", meaning we would
do /sys/bus/pci/devices/pciback/do_flr. The proper define
should have been SYSFS_PCIBACK_DRIVER, which is what this patch does.

Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
---
[v2: Fix it up per Jan's review]
---
 tools/libxl/libxl_pci.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/tools/libxl/libxl_pci.c b/tools/libxl/libxl_pci.c
index 5a7cc9e..529563d 100644
--- a/tools/libxl/libxl_pci.c
+++ b/tools/libxl/libxl_pci.c
@@ -965,7 +965,7 @@ static int libxl__device_pci_reset(libxl__gc *gc, unsigned int domain, unsigned
     char *reset;
     int fd, rc;
 
-    reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCI_DEV);
+    reset = libxl__sprintf(gc, "%s/do_flr", SYSFS_PCIBACK_DRIVER);
     fd = open(reset, O_WRONLY);
     if (fd >= 0) {
         char *buf = libxl__sprintf(gc, PCI_BDF, domain, bus, dev, func);
-- 
1.7.7.6

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] xl: Use proper path for 'do_flr' functionality.
  2014-07-08 19:00 [PATCH] xl: Use proper path for 'do_flr' functionality konrad
@ 2014-07-10 15:23 ` Ian Campbell
  2014-07-11 19:50   ` Konrad Rzeszutek Wilk
  0 siblings, 1 reply; 5+ messages in thread
From: Ian Campbell @ 2014-07-10 15:23 UTC (permalink / raw)
  To: konrad; +Cc: xen-devel, ian.jackson, stefano.stabellini


On Tue, 2014-07-08 at 15:00 -0400, konrad@kernel.org wrote:
> From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
> 
> Commit f74035d3b1e827ff6ff1873e2f10feb011a8d0d2 "xl: PCI code cleanups"
> introduced an regression where it changed the name from:
> /sys/bus/pci/drivers/pciback/do_flr
> to
> libxl_sprintf(ctx, "%s/pciback/do_flr", SYSFS_PCI_DEV);
> 
> And SYSFS_PCI_DEV is "/sys/bus/pci/devices", meaning we would
> do /sys/bus/pci/devices/pciback/do_flr. The proper define
> should have been SYSFS_PCIBACK_DRIVER, which is what this patch does.
> 
> Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>

Acked and applied, correcting the title to say libxl.

Ian.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] xl: Use proper path for 'do_flr' functionality.
  2014-07-10 15:23 ` Ian Campbell
@ 2014-07-11 19:50   ` Konrad Rzeszutek Wilk
  0 siblings, 0 replies; 5+ messages in thread
From: Konrad Rzeszutek Wilk @ 2014-07-11 19:50 UTC (permalink / raw)
  To: Ian Campbell; +Cc: konrad, xen-devel, ian.jackson, stefano.stabellini

On Thu, Jul 10, 2014 at 04:23:16PM +0100, Ian Campbell wrote:
> 
> On Tue, 2014-07-08 at 15:00 -0400, konrad@kernel.org wrote:
> > From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
> > 
> > Commit f74035d3b1e827ff6ff1873e2f10feb011a8d0d2 "xl: PCI code cleanups"
> > introduced an regression where it changed the name from:
> > /sys/bus/pci/drivers/pciback/do_flr
> > to
> > libxl_sprintf(ctx, "%s/pciback/do_flr", SYSFS_PCI_DEV);
> > 
> > And SYSFS_PCI_DEV is "/sys/bus/pci/devices", meaning we would
> > do /sys/bus/pci/devices/pciback/do_flr. The proper define
> > should have been SYSFS_PCIBACK_DRIVER, which is what this patch does.
> > 
> > Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
> 
> Acked and applied, correcting the title to say libxl.

Duh. Thank and will be more careful in the future.
> 
> Ian.
> 
> 
> 

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH] xl: Use proper path for 'do_flr' functionality.
@ 2014-06-24 14:47 konrad
  2014-06-24 13:54 ` Jan Beulich
  0 siblings, 1 reply; 5+ messages in thread
From: konrad @ 2014-06-24 14:47 UTC (permalink / raw)
  To: xen-devel, ian.campbell, ian.jackson

From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>

Commit f74035d3b1e827ff6ff1873e2f10feb011a8d0d2 "xl: PCI code cleanups"
introduced an regression where it changed the name from:
/sys/bus/pci/drivers/pciback/do_flr
to
libxl_sprintf(ctx, "%s/pciback/do_flr", SYSFS_PCI_DEV);

And SYSFS_PCI_DEV is "/sys/bus/pci/devices", meaning we would
do /sys/bus/pci/devices/pciback/do_flr. The proper define
should have been SYSFS_PCIBACK_DRIVER, which is what this patch does.

Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
---
 tools/libxl/libxl_pci.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/tools/libxl/libxl_pci.c b/tools/libxl/libxl_pci.c
index 5a7cc9e..d3b35d8 100644
--- a/tools/libxl/libxl_pci.c
+++ b/tools/libxl/libxl_pci.c
@@ -965,7 +965,7 @@ static int libxl__device_pci_reset(libxl__gc *gc, unsigned int domain, unsigned
     char *reset;
     int fd, rc;
 
-    reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCI_DEV);
+    reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCIBACK_DRIVER);
     fd = open(reset, O_WRONLY);
     if (fd >= 0) {
         char *buf = libxl__sprintf(gc, PCI_BDF, domain, bus, dev, func);
-- 
1.7.7.6

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] xl: Use proper path for 'do_flr' functionality.
  2014-06-24 14:47 konrad
@ 2014-06-24 13:54 ` Jan Beulich
  0 siblings, 0 replies; 5+ messages in thread
From: Jan Beulich @ 2014-06-24 13:54 UTC (permalink / raw)
  To: konrad; +Cc: ian.jackson, ian.campbell, xen-devel

>>> On 24.06.14 at 16:47, <konrad@kernel.org> wrote:
> From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
> 
> Commit f74035d3b1e827ff6ff1873e2f10feb011a8d0d2 "xl: PCI code cleanups"
> introduced an regression where it changed the name from:
> /sys/bus/pci/drivers/pciback/do_flr
> to
> libxl_sprintf(ctx, "%s/pciback/do_flr", SYSFS_PCI_DEV);
> 
> And SYSFS_PCI_DEV is "/sys/bus/pci/devices", meaning we would
> do /sys/bus/pci/devices/pciback/do_flr. The proper define
> should have been SYSFS_PCIBACK_DRIVER, which is what this patch does.
> 
> Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
> ---
>  tools/libxl/libxl_pci.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/tools/libxl/libxl_pci.c b/tools/libxl/libxl_pci.c
> index 5a7cc9e..d3b35d8 100644
> --- a/tools/libxl/libxl_pci.c
> +++ b/tools/libxl/libxl_pci.c
> @@ -965,7 +965,7 @@ static int libxl__device_pci_reset(libxl__gc *gc, 
> unsigned int domain, unsigned
>      char *reset;
>      int fd, rc;
>  
> -    reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCI_DEV);
> +    reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCIBACK_DRIVER);

Don't you then need to drop the literal /pciback part here?

Jan

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2014-07-11 19:50 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-07-08 19:00 [PATCH] xl: Use proper path for 'do_flr' functionality konrad
2014-07-10 15:23 ` Ian Campbell
2014-07-11 19:50   ` Konrad Rzeszutek Wilk
  -- strict thread matches above, loose matches on Subject: below --
2014-06-24 14:47 konrad
2014-06-24 13:54 ` Jan Beulich

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.