All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH] Add trace messages to input.c.
@ 2015-01-16 19:08 Don Koch
  2015-01-19  7:34 ` Gerd Hoffmann
  0 siblings, 1 reply; 5+ messages in thread
From: Don Koch @ 2015-01-16 19:08 UTC (permalink / raw)
  To: qemu-devel; +Cc: Anthony Liguori, Don Koch, Gerd Hoffmann

Signed-off-by: Don Koch <dkoch@verizon.com>
---
 trace-events | 1 +
 ui/input.c   | 1 +
 2 files changed, 2 insertions(+)

diff --git a/trace-events b/trace-events
index 97c7ac3..6a60f19 100644
--- a/trace-events
+++ b/trace-events
@@ -1136,6 +1136,7 @@ vnc_key_sync_numlock(bool on) "%d"
 vnc_key_sync_capslock(bool on) "%d"
 
 # ui/input.c
+do_mouse_set(void *mon, int index) "%p index %d"
 input_event_key_number(int conidx, int number, const char *qcode, bool down) "con %d, key number 0x%x [%s], down %d"
 input_event_key_qcode(int conidx, const char *qcode, bool down) "con %d, key qcode %s, down %d"
 input_event_btn(int conidx, const char *btn, bool down) "con %d, button %s, down %d"
diff --git a/ui/input.c b/ui/input.c
index 7ba99e5..35dd783 100644
--- a/ui/input.c
+++ b/ui/input.c
@@ -532,6 +532,7 @@ void do_mouse_set(Monitor *mon, const QDict *qdict)
     int index = qdict_get_int(qdict, "index");
     int found = 0;
 
+    trace_do_mouse_set(mon, index);
     QTAILQ_FOREACH(s, &handlers, node) {
         if (s->id != index) {
             continue;
-- 
1.8.3.1

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] Add trace messages to input.c.
  2015-01-16 19:08 [Qemu-devel] [PATCH] Add trace messages to input.c Don Koch
@ 2015-01-19  7:34 ` Gerd Hoffmann
  2015-01-19 14:31   ` Don Koch
  0 siblings, 1 reply; 5+ messages in thread
From: Gerd Hoffmann @ 2015-01-19  7:34 UTC (permalink / raw)
  To: Don Koch; +Cc: qemu-devel, Anthony Liguori

On Fr, 2015-01-16 at 14:08 -0500, Don Koch wrote:
> Signed-off-by: Don Koch <dkoch@verizon.com>

> +    trace_do_mouse_set(mon, index);

First, I think we should have a better name for that one, maybe
"input_mouse_set" ?

Second I'm wondering what the use case is.  The place is a bit strange
(tracing management not guest behavior), also all the existing input
trace points log the device index so you can already see how the events
are routed ...

cheers,
  Gerd

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] Add trace messages to input.c.
  2015-01-19  7:34 ` Gerd Hoffmann
@ 2015-01-19 14:31   ` Don Koch
  2015-01-22 10:01     ` Gerd Hoffmann
  0 siblings, 1 reply; 5+ messages in thread
From: Don Koch @ 2015-01-19 14:31 UTC (permalink / raw)
  To: Gerd Hoffmann; +Cc: qemu-devel, Anthony Liguori

On Mon, 19 Jan 2015 08:34:22 +0100
Gerd Hoffmann <kraxel@redhat.com> wrote:

> On Fr, 2015-01-16 at 14:08 -0500, Don Koch wrote:
> > Signed-off-by: Don Koch <dkoch@verizon.com>
> 
> > +    trace_do_mouse_set(mon, index);
> 
> First, I think we should have a better name for that one, maybe
> "input_mouse_set" ?

The trace name or the routine it's in? The trace name was obviously
taken from the name of the routine it is in.

> Second I'm wondering what the use case is.  The place is a bit strange
> (tracing management not guest behavior), also all the existing input
> trace points log the device index so you can already see how the events
> are routed ...

I believe this was used for debugging vmware mouse support we've been
working on.

Thanks,
-d

> cheers,
>   Gerd
> 
> 

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] Add trace messages to input.c.
  2015-01-19 14:31   ` Don Koch
@ 2015-01-22 10:01     ` Gerd Hoffmann
  2015-01-22 14:32       ` Don Koch
  0 siblings, 1 reply; 5+ messages in thread
From: Gerd Hoffmann @ 2015-01-22 10:01 UTC (permalink / raw)
  To: Don Koch; +Cc: qemu-devel, Anthony Liguori

  Hi,

> I believe this was used for debugging vmware mouse support we've been
> working on.

Wouldn't it be more useful to trace qemu_input_handler_* calls for that,
especially qemu_input_handler_activate?  So you also see changes
triggered by the guest, such as enabling vmmouse, or initializing the
usb-tablet?

cheers,
  Gerd

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PATCH] Add trace messages to input.c.
  2015-01-22 10:01     ` Gerd Hoffmann
@ 2015-01-22 14:32       ` Don Koch
  0 siblings, 0 replies; 5+ messages in thread
From: Don Koch @ 2015-01-22 14:32 UTC (permalink / raw)
  To: Gerd Hoffmann; +Cc: qemu-devel, Anthony Liguori

On Thu, 22 Jan 2015 11:01:14 +0100
Gerd Hoffmann <kraxel@redhat.com> wrote:

>   Hi,
> 
> > I believe this was used for debugging vmware mouse support we've been
> > working on.
> 
> Wouldn't it be more useful to trace qemu_input_handler_* calls for that,
> especially qemu_input_handler_activate?  So you also see changes
> triggered by the guest, such as enabling vmmouse, or initializing the
> usb-tablet?

Could be. This was for an effort done in the past; so, I've forgetten the
context. We can drop this change, if you want.

Thanks,
-d

> cheers,
>   Gerd
> 
> 

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2015-01-22 14:32 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-01-16 19:08 [Qemu-devel] [PATCH] Add trace messages to input.c Don Koch
2015-01-19  7:34 ` Gerd Hoffmann
2015-01-19 14:31   ` Don Koch
2015-01-22 10:01     ` Gerd Hoffmann
2015-01-22 14:32       ` Don Koch

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.