All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net-next 00/18] switchdev: spring cleanup
@ 2015-03-30  8:40 sfeldma
  2015-03-30  8:40 ` [PATCH net-next 01/18] switchdev: introduce get/set attrs ops sfeldma
                   ` (18 more replies)
  0 siblings, 19 replies; 55+ messages in thread
From: sfeldma @ 2015-03-30  8:40 UTC (permalink / raw)
  To: netdev; +Cc: jiri, roopa, linux, f.fainelli

From: Scott Feldman <sfeldma@gmail.com>

The main theme of this patch set is to cleanup swdev in preparation for
new features or fixes to be added soon.  We have a pretty good idea now how
to handle stacked drivers in swdev, but there where some loose ends.  For
example, if a set failed in the middle of walking the lower devs, we would
leave the system in an undefined state...there was no way to recover back to
the previous state.  Speaking of sets, also recognize a pattern that most
swdev API accesses are gets or sets of port attributes, so go ahead and make
port attr get/set the central swdev API, and convert everything that is
set-ish/get-ish to this new API.

Features/fixes that should follow from this cleanup:

 - solve the duplicate pkt forwarding issue
 - get/set bridge attrs, like ageing_time, from/to device
 - get/set more bridge port attrs from/to device

There are some rename cleanups tagging along at the end, to give swdev
consistent naming.

And finally, some much needed updates to the switchdev.txt documentation to
hopefully capture the state-of-the-art of swdev.  Hopefully, we can do a better
job keeping this document up-to-date.

Tested with rocker, of course, to make sure nothing functional broke.  There
are a couple minor tweaks to DSA code for getting switch ID and setting STP
updates to use new API, but not expecting amy breakage there.


Scott Feldman (18):
  switchdev: introduce get/set attrs ops
  switchdev: flesh out get/set attr ops
  switchdev: convert parent_id_get to swdev attr get
  switchdev: convert STP update to swdev attr set
  switchdev: add bridge port flags attr
  rocker: use swdev get/set attr for bridge port flags
  switchdev: add new swdev bridge setlink
  rocker: cut over to new swdev_port_bridge_setlink
  bonding: cut over to new swdev_port_bridge_setlink
  team: cut over to new swdev_port_bridge_setlink
  switchdev: remove old netdev_switch_port_bridge_setlink
  switchdev: remove unused netdev_switch_port_bridge_dellink
  switchdev: remove unused NETIF_F_HW_SWITCH_OFFLOAD
  switchdev: add new swdev_port_bridge_getlink
  rocker: cut over to new swdev_port_bridge_getlink
  switchdev: rename netdev_switch_fib_* to swdev_fib_*
  switchdev: rename netdev_switch_notifier_* to swdev_notifier_*
  switchdev: bring documentation up-to-date

 Documentation/networking/switchdev.txt |  426 +++++++++++++++++++++++++++-----
 drivers/net/bonding/bond_main.c        |    8 +-
 drivers/net/ethernet/rocker/rocker.c   |  108 +++-----
 drivers/net/team/team.c                |    5 +-
 include/linux/netdev_features.h        |    5 +-
 include/net/switchdev.h                |  144 ++++++-----
 net/bridge/br.c                        |   22 +-
 net/bridge/br_netlink.c                |   24 +-
 net/bridge/br_stp.c                    |    6 +-
 net/core/ethtool.c                     |    1 -
 net/core/net-sysfs.c                   |   10 +-
 net/core/rtnetlink.c                   |    9 +-
 net/dsa/slave.c                        |   35 ++-
 net/ipv4/fib_trie.c                    |   38 ++-
 net/switchdev/switchdev.c              |  334 ++++++++++++++-----------
 15 files changed, 750 insertions(+), 425 deletions(-)

-- 
1.7.10.4

^ permalink raw reply	[flat|nested] 55+ messages in thread

end of thread, other threads:[~2015-04-02  1:02 UTC | newest]

Thread overview: 55+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-03-30  8:40 [PATCH net-next 00/18] switchdev: spring cleanup sfeldma
2015-03-30  8:40 ` [PATCH net-next 01/18] switchdev: introduce get/set attrs ops sfeldma
2015-03-30  8:40 ` [PATCH net-next 02/18] switchdev: flesh out get/set attr ops sfeldma
2015-03-30 11:55   ` Jiri Pirko
2015-03-30 18:32   ` Arad, Ronen
2015-03-30 20:46     ` Jiri Pirko
2015-03-30 21:00       ` Scott Feldman
2015-03-31  0:22   ` Arad, Ronen
2015-03-31  0:38     ` Scott Feldman
2015-03-31 15:37       ` roopa
     [not found]       ` <CAJieiUh0Svt3LZsgoi7RaV8Be0eFyRvoJU3BmW7v3fEvwfXiHg@mail.gmail.com>
2015-03-31 16:05         ` Scott Feldman
2015-03-30  8:40 ` [PATCH net-next 03/18] switchdev: convert parent_id_get to swdev attr get sfeldma
2015-03-30  8:40 ` [PATCH net-next 04/18] switchdev: convert STP update to swdev attr set sfeldma
2015-03-30 11:54   ` Jiri Pirko
2015-03-30 13:47     ` roopa
2015-03-30  8:40 ` [PATCH net-next 05/18] switchdev: add bridge port flags attr sfeldma
2015-03-30  8:40 ` [PATCH net-next 06/18] rocker: use swdev get/set attr for bridge port flags sfeldma
2015-03-30 12:01   ` Jiri Pirko
2015-03-30  8:40 ` [PATCH net-next 07/18] switchdev: add new swdev bridge setlink sfeldma
2015-03-30 12:31   ` Jiri Pirko
2015-03-30  8:40 ` [PATCH net-next 08/18] rocker: cut over to new swdev_port_bridge_setlink sfeldma
2015-03-30  8:40 ` [PATCH net-next 09/18] bonding: " sfeldma
2015-03-30  8:40 ` [PATCH net-next 10/18] team: " sfeldma
2015-03-30  8:40 ` [PATCH net-next 11/18] switchdev: remove old netdev_switch_port_bridge_setlink sfeldma
2015-03-30 13:23   ` roopa
2015-03-30 20:20     ` Scott Feldman
2015-03-30 20:46       ` Arad, Ronen
2015-03-30 21:27         ` Scott Feldman
2015-03-31  0:08           ` Arad, Ronen
2015-03-31  0:44             ` Scott Feldman
2015-03-31  5:52             ` Jiri Pirko
2015-03-31 19:15               ` Arad, Ronen
2015-03-31 21:52                 ` Jiri Pirko
2015-03-31 23:32                   ` Arad, Ronen
2015-04-01  2:38                     ` Scott Feldman
2015-04-01 12:03                       ` Jamal Hadi Salim
2015-04-01 17:56                         ` Scott Feldman
2015-04-02  1:01                     ` Florian Fainelli
2015-03-30  8:40 ` [PATCH net-next 12/18] switchdev: remove unused netdev_switch_port_bridge_dellink sfeldma
2015-03-30 13:23   ` roopa
2015-03-30  8:40 ` [PATCH net-next 13/18] switchdev: remove unused NETIF_F_HW_SWITCH_OFFLOAD sfeldma
2015-03-30 13:38   ` roopa
2015-03-30 20:48     ` Samudrala, Sridhar
2015-03-30 21:20     ` Scott Feldman
2015-03-31 15:34       ` roopa
     [not found]       ` <CAJieiUiL4QRQAC30=bkYadYD2L2cOcn7mNLV98uH3Go0exMO+A@mail.gmail.com>
2015-03-31 16:03         ` Scott Feldman
2015-03-30  8:40 ` [PATCH net-next 14/18] switchdev: add new swdev_port_bridge_getlink sfeldma
2015-03-30  8:40 ` [PATCH net-next 15/18] rocker: cut over to " sfeldma
2015-03-30  8:40 ` [PATCH net-next 16/18] switchdev: rename netdev_switch_fib_* to swdev_fib_* sfeldma
2015-03-30  8:40 ` [PATCH net-next 17/18] switchdev: rename netdev_switch_notifier_* to swdev_notifier_* sfeldma
2015-03-30  8:40 ` [PATCH net-next 18/18] switchdev: bring documentation up-to-date sfeldma
2015-03-30 12:00 ` [PATCH net-next 00/18] switchdev: spring cleanup Jiri Pirko
2015-03-30 13:11   ` Andy Gospodarek
2015-03-30 15:00     ` roopa
2015-03-30 16:11       ` Or Gerlitz

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.