All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: qemu-devel@nongnu.org
Cc: mdroth@linux.vnet.ibm.com
Subject: [Qemu-devel] [PATCH 07/16] qapi: Simplify inclusion cycle detection
Date: Fri, 12 Jun 2015 16:51:05 +0200	[thread overview]
Message-ID: <1434120674-8122-8-git-send-email-armbru@redhat.com> (raw)
In-Reply-To: <1434120674-8122-1-git-send-email-armbru@redhat.com>

We maintain a stack of filenames in include_hist for convenient cycle
detection.

As error_path() demonstrates, the same information is readily
available in the expr_info, so just use that, and drop include_hist.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
---
 scripts/qapi.py | 18 ++++++++----------
 1 file changed, 8 insertions(+), 10 deletions(-)

diff --git a/scripts/qapi.py b/scripts/qapi.py
index bde8521..a24a7e2 100644
--- a/scripts/qapi.py
+++ b/scripts/qapi.py
@@ -101,15 +101,10 @@ class QAPIExprError(Exception):
 
 class QAPISchema:
 
-    def __init__(self, fp, include_hist = [],
-                 previously_included = [], incl_info = None):
-        """ include_hist is a stack used to detect inclusion cycles
-            previously_included is a global state used to avoid multiple
-                                inclusions of the same file"""
+    def __init__(self, fp, previously_included = [], incl_info = None):
         abs_fname = os.path.abspath(fp.name)
         fname = fp.name
         self.fname = fname
-        include_hist = include_hist + [(fname, abs_fname)]
         previously_included.append(abs_fname)
         self.incl_info = incl_info
         self.src = fp.read()
@@ -135,10 +130,13 @@ class QAPISchema:
                                         % include)
                 incl_abs_fname = os.path.join(os.path.dirname(abs_fname),
                                               include)
-                for elem in include_hist:
-                    if incl_abs_fname == elem[1]:
+                # catch inclusion cycle
+                inf = expr_info
+                while inf:
+                    if incl_abs_fname == os.path.abspath(inf['file']):
                         raise QAPIExprError(expr_info, "Inclusion loop for %s"
                                             % include)
+                    inf = inf['parent']
                 # skip multiple include of the same file
                 if incl_abs_fname in previously_included:
                     continue
@@ -147,8 +145,8 @@ class QAPISchema:
                 except IOError, e:
                     raise QAPIExprError(expr_info,
                                         '%s: %s' % (e.strerror, include))
-                exprs_include = QAPISchema(fobj, include_hist,
-                                           previously_included, expr_info)
+                exprs_include = QAPISchema(fobj, previously_included,
+                                           expr_info)
                 self.exprs.extend(exprs_include.exprs)
             else:
                 expr_elem = {'expr': expr,
-- 
1.9.3

  parent reply	other threads:[~2015-06-12 14:51 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-12 14:50 [Qemu-devel] [PATCH 00/16] qapi: Miscellaneous fixes and cleanups Markus Armbruster
2015-06-12 14:50 ` [Qemu-devel] [PATCH 01/16] MAINTAINERS: Fix up QAPI and QAPI schema file patterns Markus Armbruster
2015-06-12 22:50   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 02/16] qapi: Drop bogus command from docs Markus Armbruster
2015-06-12 22:51   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 03/16] qapi: Eliminate superfluous QAPISchema attribute input_dir Markus Armbruster
2015-06-12 22:54   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 04/16] qapi: Eliminate superfluous QAPISchema attribute include_hist Markus Armbruster
2015-06-12 23:11   ` Eric Blake
2015-06-16  8:43     ` Markus Armbruster
2015-06-12 14:51 ` [Qemu-devel] [PATCH 05/16] qapi: Improve a couple of confusing variable names Markus Armbruster
2015-06-12 23:16   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 06/16] qapi: Fix file name in error messages for included files Markus Armbruster
2015-06-12 23:19   ` Eric Blake
2015-06-12 14:51 ` Markus Armbruster [this message]
2015-06-12 23:30   ` [Qemu-devel] [PATCH 07/16] qapi: Simplify inclusion cycle detection Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 08/16] qapi: Fix to reject stray 't', 'f' and 'n' Markus Armbruster
2015-06-12 23:35   ` Eric Blake
2015-06-16  8:31     ` Markus Armbruster
2015-06-12 14:51 ` [Qemu-devel] [PATCH 09/16] qapi: Move exprs checking from parse_schema() to check_exprs() Markus Armbruster
2015-06-12 23:41   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 10/16] qapi: Better separate the different kinds of helpers Markus Armbruster
2015-06-12 23:42   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 11/16] tests/qapi-schema: New flat union array branch test case Markus Armbruster
2015-06-13 16:55   ` Eric Blake
2015-06-16  8:33     ` Markus Armbruster
2015-06-12 14:51 ` [Qemu-devel] [PATCH 12/16] qapi: Catch and reject flat union branch of array type Markus Armbruster
2015-06-14  2:19   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 13/16] qapi-types: Don't filter out expressions with 'gen' Markus Armbruster
2015-06-14  2:20   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 14/16] qapi-types: Drop unused members parameters Markus Armbruster
2015-06-14  2:21   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 15/16] qapi-types: Split generate_fwd_builtin() off generate_fwd_struct() Markus Armbruster
2015-06-14  2:22   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 16/16] qapi-types: Bury code dead since commit 6b5abc7 Markus Armbruster
2015-06-14  2:23   ` Eric Blake

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1434120674-8122-8-git-send-email-armbru@redhat.com \
    --to=armbru@redhat.com \
    --cc=mdroth@linux.vnet.ibm.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.