All of lore.kernel.org
 help / color / mirror / Atom feed
From: Eric Blake <eblake@redhat.com>
To: Markus Armbruster <armbru@redhat.com>, qemu-devel@nongnu.org
Cc: mdroth@linux.vnet.ibm.com
Subject: Re: [Qemu-devel] [PATCH 09/16] qapi: Move exprs checking from parse_schema() to check_exprs()
Date: Fri, 12 Jun 2015 17:41:24 -0600	[thread overview]
Message-ID: <557B6E24.7010700@redhat.com> (raw)
In-Reply-To: <1434120674-8122-10-git-send-email-armbru@redhat.com>

[-- Attachment #1: Type: text/plain, Size: 1096 bytes --]

On 06/12/2015 08:51 AM, Markus Armbruster wrote:
> To have expression semantic analysis in one place rather than two.
> 
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
>  scripts/qapi.py | 142 ++++++++++++++++++++++++++------------------------------
>  1 file changed, 66 insertions(+), 76 deletions(-)

Again, yay for a good testsuite proving this doesn't mess things up :)


> +
> +    return map(lambda expr_elem: expr_elem['expr'], exprs)

I had to go research what this actually does, but it looks correct.

>  
>  def parse_schema(fname):
> -    global all_names
> -    exprs = []
> -
> -    # First pass: read entire file into memory
>      try:
>          schema = QAPISchema(open(fname, "r"))
> +        return check_exprs(schema.exprs)
>      except (QAPISchemaError, QAPIExprError), e:
>          print >>sys.stderr, e
>          exit(1)

Wow, that's really just a thin wrapper now!

Reviewed-by: Eric Blake <eblake@redhat.com>

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org


[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 604 bytes --]

  reply	other threads:[~2015-06-12 23:41 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-12 14:50 [Qemu-devel] [PATCH 00/16] qapi: Miscellaneous fixes and cleanups Markus Armbruster
2015-06-12 14:50 ` [Qemu-devel] [PATCH 01/16] MAINTAINERS: Fix up QAPI and QAPI schema file patterns Markus Armbruster
2015-06-12 22:50   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 02/16] qapi: Drop bogus command from docs Markus Armbruster
2015-06-12 22:51   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 03/16] qapi: Eliminate superfluous QAPISchema attribute input_dir Markus Armbruster
2015-06-12 22:54   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 04/16] qapi: Eliminate superfluous QAPISchema attribute include_hist Markus Armbruster
2015-06-12 23:11   ` Eric Blake
2015-06-16  8:43     ` Markus Armbruster
2015-06-12 14:51 ` [Qemu-devel] [PATCH 05/16] qapi: Improve a couple of confusing variable names Markus Armbruster
2015-06-12 23:16   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 06/16] qapi: Fix file name in error messages for included files Markus Armbruster
2015-06-12 23:19   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 07/16] qapi: Simplify inclusion cycle detection Markus Armbruster
2015-06-12 23:30   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 08/16] qapi: Fix to reject stray 't', 'f' and 'n' Markus Armbruster
2015-06-12 23:35   ` Eric Blake
2015-06-16  8:31     ` Markus Armbruster
2015-06-12 14:51 ` [Qemu-devel] [PATCH 09/16] qapi: Move exprs checking from parse_schema() to check_exprs() Markus Armbruster
2015-06-12 23:41   ` Eric Blake [this message]
2015-06-12 14:51 ` [Qemu-devel] [PATCH 10/16] qapi: Better separate the different kinds of helpers Markus Armbruster
2015-06-12 23:42   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 11/16] tests/qapi-schema: New flat union array branch test case Markus Armbruster
2015-06-13 16:55   ` Eric Blake
2015-06-16  8:33     ` Markus Armbruster
2015-06-12 14:51 ` [Qemu-devel] [PATCH 12/16] qapi: Catch and reject flat union branch of array type Markus Armbruster
2015-06-14  2:19   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 13/16] qapi-types: Don't filter out expressions with 'gen' Markus Armbruster
2015-06-14  2:20   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 14/16] qapi-types: Drop unused members parameters Markus Armbruster
2015-06-14  2:21   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 15/16] qapi-types: Split generate_fwd_builtin() off generate_fwd_struct() Markus Armbruster
2015-06-14  2:22   ` Eric Blake
2015-06-12 14:51 ` [Qemu-devel] [PATCH 16/16] qapi-types: Bury code dead since commit 6b5abc7 Markus Armbruster
2015-06-14  2:23   ` Eric Blake

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=557B6E24.7010700@redhat.com \
    --to=eblake@redhat.com \
    --cc=armbru@redhat.com \
    --cc=mdroth@linux.vnet.ibm.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.