All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] usb: move assignment out of if condition
@ 2015-06-30 13:02 Kris Borer
  2015-06-30 13:35 ` Sergei Shtylyov
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Kris Borer @ 2015-06-30 13:02 UTC (permalink / raw)
  To: gregkh
  Cc: stern, balbi, pmladek, antoine.tenart, hdegoede, sergei.shtylyov,
	rafael.j.wysocki, linux-usb, linux-kernel, Kris Borer

Fix four occurrences of the checkpatch.pl error:

ERROR: do not use assignment in if condition

Signed-off-by: Kris Borer <kborer@gmail.com>
---
 drivers/usb/core/hcd.c | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
index be5b207..e268c45 100644
--- a/drivers/usb/core/hcd.c
+++ b/drivers/usb/core/hcd.c
@@ -2683,12 +2683,13 @@ int usb_add_hcd(struct usb_hcd *hcd,
 	 * bottom up so that hcds can customize the root hubs before hub_wq
 	 * starts talking to them.  (Note, bus id is assigned early too.)
 	 */
-	if ((retval = hcd_buffer_create(hcd)) != 0) {
+	retval = hcd_buffer_create(hcd);
+	if (retval != 0) {
 		dev_dbg(hcd->self.controller, "pool alloc failed\n");
 		goto err_create_buf;
 	}
-
-	if ((retval = usb_register_bus(&hcd->self)) < 0)
+	retval = usb_register_bus(&hcd->self);
+	if (retval < 0)
 		goto err_register_bus;
 
 	rhdev = usb_alloc_dev(NULL, &hcd->self, 0);
@@ -2734,7 +2735,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
 	/* "reset" is misnamed; its role is now one-time init. the controller
 	 * should already have been reset (and boot firmware kicked off etc).
 	 */
-	if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
+	retval = hcd->driver->reset(hcd);
+	if (hcd->driver->reset && retval < 0) {
 		dev_err(hcd->self.controller, "can't setup: %d\n", retval);
 		goto err_hcd_driver_setup;
 	}
@@ -2766,7 +2768,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
 	}
 
 	/* starting here, usbcore will pay attention to this root hub */
-	if ((retval = register_root_hub(hcd)) != 0)
+	retval = register_root_hub(hcd);
+	if (retval != 0)
 		goto err_register_root_hub;
 
 	retval = sysfs_create_group(&rhdev->dev.kobj, &usb_bus_attr_group);
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] usb: move assignment out of if condition
  2015-06-30 13:02 [PATCH] usb: move assignment out of if condition Kris Borer
@ 2015-06-30 13:35 ` Sergei Shtylyov
  2015-06-30 13:35 ` Oliver Neukum
  2015-06-30 15:09 ` Greg KH
  2 siblings, 0 replies; 4+ messages in thread
From: Sergei Shtylyov @ 2015-06-30 13:35 UTC (permalink / raw)
  To: Kris Borer, gregkh
  Cc: stern, balbi, pmladek, antoine.tenart, hdegoede,
	rafael.j.wysocki, linux-usb, linux-kernel

Hello.

On 6/30/2015 4:02 PM, Kris Borer wrote:

> Fix four occurrences of the checkpatch.pl error:

> ERROR: do not use assignment in if condition

> Signed-off-by: Kris Borer <kborer@gmail.com>
> ---
>   drivers/usb/core/hcd.c | 13 ++++++++-----
>   1 file changed, 8 insertions(+), 5 deletions(-)

> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
> index be5b207..e268c45 100644
> --- a/drivers/usb/core/hcd.c
> +++ b/drivers/usb/core/hcd.c
[...]
> @@ -2734,7 +2735,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
>   	/* "reset" is misnamed; its role is now one-time init. the controller
>   	 * should already have been reset (and boot firmware kicked off etc).
>   	 */
> -	if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
> +	retval = hcd->driver->reset(hcd);
> +	if (hcd->driver->reset && retval < 0) {

    If hcd->driver->reset() is NULL, this change warrants a kernel oops.

[...]

WBR, Sergei


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] usb: move assignment out of if condition
  2015-06-30 13:02 [PATCH] usb: move assignment out of if condition Kris Borer
  2015-06-30 13:35 ` Sergei Shtylyov
@ 2015-06-30 13:35 ` Oliver Neukum
  2015-06-30 15:09 ` Greg KH
  2 siblings, 0 replies; 4+ messages in thread
From: Oliver Neukum @ 2015-06-30 13:35 UTC (permalink / raw)
  To: Kris Borer
  Cc: gregkh, stern, balbi, pmladek, antoine.tenart, hdegoede,
	sergei.shtylyov, rafael.j.wysocki, linux-usb, linux-kernel

On Tue, 2015-06-30 at 09:02 -0400, Kris Borer wrote:
> Fix four occurrences of the checkpatch.pl error:
> 
> ERROR: do not use assignment in if condition
> 
> Signed-off-by: Kris Borer <kborer@gmail.com>

Sorry, but NACK!
Those patches are totally broken.

> ---
>  drivers/usb/core/hcd.c | 13 ++++++++-----
>  1 file changed, 8 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
> index be5b207..e268c45 100644
> --- a/drivers/usb/core/hcd.c
> +++ b/drivers/usb/core/hcd.c
> @@ -2683,12 +2683,13 @@ int usb_add_hcd(struct usb_hcd *hcd,
>  	 * bottom up so that hcds can customize the root hubs before hub_wq
>  	 * starts talking to them.  (Note, bus id is assigned early too.)
>  	 */
> -	if ((retval = hcd_buffer_create(hcd)) != 0) {
> +	retval = hcd_buffer_create(hcd);
> +	if (retval != 0) {
>  		dev_dbg(hcd->self.controller, "pool alloc failed\n");
>  		goto err_create_buf;
>  	}
> -
> -	if ((retval = usb_register_bus(&hcd->self)) < 0)
> +	retval = usb_register_bus(&hcd->self);
> +	if (retval < 0)
>  		goto err_register_bus;
>  
>  	rhdev = usb_alloc_dev(NULL, &hcd->self, 0);
> @@ -2734,7 +2735,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
>  	/* "reset" is misnamed; its role is now one-time init. the controller
>  	 * should already have been reset (and boot firmware kicked off etc).
>  	 */
> -	if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
> +	retval = hcd->driver->reset(hcd);

You happily follow the NULL pointer.

	Regards
		Oliver



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] usb: move assignment out of if condition
  2015-06-30 13:02 [PATCH] usb: move assignment out of if condition Kris Borer
  2015-06-30 13:35 ` Sergei Shtylyov
  2015-06-30 13:35 ` Oliver Neukum
@ 2015-06-30 15:09 ` Greg KH
  2 siblings, 0 replies; 4+ messages in thread
From: Greg KH @ 2015-06-30 15:09 UTC (permalink / raw)
  To: Kris Borer
  Cc: stern, balbi, pmladek, antoine.tenart, hdegoede, sergei.shtylyov,
	rafael.j.wysocki, linux-usb, linux-kernel

On Tue, Jun 30, 2015 at 09:02:22AM -0400, Kris Borer wrote:
> Fix four occurrences of the checkpatch.pl error:
> 
> ERROR: do not use assignment in if condition

If you are going to do stuff like this, use Coccinelle so you are sure
you don't break the code.

Also always test your changes, if possible.

greg k-h

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2015-06-30 15:10 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-06-30 13:02 [PATCH] usb: move assignment out of if condition Kris Borer
2015-06-30 13:35 ` Sergei Shtylyov
2015-06-30 13:35 ` Oliver Neukum
2015-06-30 15:09 ` Greg KH

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.