All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/18] ALUA device handler update, part 1
@ 2015-11-09 15:08 Hannes Reinecke
  2015-11-09 15:08 ` [PATCH 01/18] scsi_dh: move 'dh_state' sysfs attribute to generic code Hannes Reinecke
                   ` (19 more replies)
  0 siblings, 20 replies; 50+ messages in thread
From: Hannes Reinecke @ 2015-11-09 15:08 UTC (permalink / raw)
  To: Martin K. Petersen
  Cc: Christoph Hellwig, Jamed Bottomley, linux-scsi,
	Johannes Thumshirn, Ewan Milne, Hannes Reinecke

Hi all,

here's the first part of my ALUA device handler update.
It's mainly bugfixes and minor improvements; the two important
things are the addition of VPD parsing functions scsi_vpd_lun_id()
and scsi_vpd_tpg_id().
This series has been split off from the original 'Asynchronous ALUA'
patchset, as these bits are pretty uncontroversial and have a good
chance of being merged reasonably soon.

The second part of the ALUA device handler update will be posted
(and, doubtlessly, discussed) once this part is in.

Patch is relative to 4.4/scsi-queue by mkp, and based upon the
'scsi: rescan VPD attributes' patch I send earlier.

As usual, comments and reviews are welcome.

Hannes Reinecke (18):
  scsi_dh: move 'dh_state' sysfs attribute to generic code
  scsi: ignore errors from scsi_dh_add_device()
  scsi_dh_alua: Disable ALUA handling for non-disk devices
  scsi_dh_alua: Use vpd_pg83 information
  scsi_dh_alua: improved logging
  scsi_dh_alua: sanitze sense code handling
  scsi_dh_alua: use standard logging functions
  scsi_dh_alua: return standard SCSI return codes in submit_rtpg
  scsi_dh_alua: fixup description of stpg_endio()
  scsi: remove scsi_show_sense_hdr()
  scsi_dh_alua: use flag for RTPG extended header
  scsi_dh_alua: use unaligned access macros
  scsi_dh_alua: rework alua_check_tpgs() to return the tpgs mode
  scsi_dh_alua: simplify sense code handling
  scsi: Add scsi_vpd_lun_id()
  scsi: export 'device_id' to sysfs
  scsi: Add scsi_vpd_tpg_id()
  scsi_dh_alua: use scsi_vpd_tpg_id()

 drivers/scsi/device_handler/scsi_dh_alua.c | 294 ++++++++++-------------------
 drivers/scsi/scsi_dh.c                     |  68 +------
 drivers/scsi/scsi_lib.c                    | 188 ++++++++++++++++++
 drivers/scsi/scsi_sysfs.c                  |  82 +++++++-
 include/scsi/scsi_dbg.h                    |   2 -
 include/scsi/scsi_device.h                 |   2 +
 6 files changed, 373 insertions(+), 263 deletions(-)

-- 
1.8.5.6


^ permalink raw reply	[flat|nested] 50+ messages in thread
* [PATCHv2 00/18] ALUA device handler update, part 1
@ 2015-12-01  9:16 Hannes Reinecke
  2015-12-01  9:16 ` [PATCH 05/18] scsi_dh_alua: improved logging Hannes Reinecke
  0 siblings, 1 reply; 50+ messages in thread
From: Hannes Reinecke @ 2015-12-01  9:16 UTC (permalink / raw)
  To: Martin K. Petersen
  Cc: Christoph Hellwig, Ewan Milne, James Bottomley,
	Johannes Thumshirn, Bart van Assche, linux-scsi, Hannes Reinecke

Hi all,

here's the first part of my ALUA device handler update.
It's mainly bugfixes and minor improvements; the two important
things are the addition of VPD parsing functions scsi_vpd_lun_id()
and scsi_vpd_tpg_id().
This series has been split off from the original 'Asynchronous ALUA'
patchset, as these bits are pretty uncontroversial and have a good
chance of being merged reasonably soon.

The second part of the ALUA device handler update will be posted
(and, doubtlessly, discussed) once this part is in.

Patchset is relative to 4.5/scsi-queue by mkp.
The entire tree can be found at

kernel.org:/pub/scm/linux/kernel/git/hare/scsi-devel.git
branch alua.v7

As usual, comments and reviews are welcome.

Changes to v1:
- Update to 4.5/scsi-queue
- Rename 'device_id' to 'wwid'

Hannes Reinecke (18):
  scsi_dh: move 'dh_state' sysfs attribute to generic code
  scsi: ignore errors from scsi_dh_add_device()
  scsi_dh_alua: Disable ALUA handling for non-disk devices
  scsi_dh_alua: Use vpd_pg83 information
  scsi_dh_alua: improved logging
  scsi_dh_alua: sanitze sense code handling
  scsi_dh_alua: use standard logging functions
  scsi_dh_alua: return standard SCSI return codes in submit_rtpg
  scsi_dh_alua: fixup description of stpg_endio()
  scsi: remove scsi_show_sense_hdr()
  scsi_dh_alua: use flag for RTPG extended header
  scsi_dh_alua: use unaligned access macros
  scsi_dh_alua: rework alua_check_tpgs() to return the tpgs mode
  scsi_dh_alua: simplify sense code handling
  scsi: Add scsi_vpd_lun_id()
  scsi: export 'wwid' to sysfs
  scsi: Add scsi_vpd_tpg_id()
  scsi_dh_alua: use scsi_vpd_tpg_id()

 drivers/scsi/device_handler/scsi_dh_alua.c | 294 ++++++++++-------------------
 drivers/scsi/scsi_dh.c                     |  72 +------
 drivers/scsi/scsi_lib.c                    | 188 ++++++++++++++++++
 drivers/scsi/scsi_priv.h                   |   3 +-
 drivers/scsi/scsi_sysfs.c                  |  82 +++++++-
 include/scsi/scsi_dbg.h                    |   2 -
 include/scsi/scsi_device.h                 |   2 +
 7 files changed, 374 insertions(+), 269 deletions(-)

-- 
1.8.5.6


^ permalink raw reply	[flat|nested] 50+ messages in thread

end of thread, other threads:[~2015-12-01  9:28 UTC | newest]

Thread overview: 50+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-11-09 15:08 [PATCH 00/18] ALUA device handler update, part 1 Hannes Reinecke
2015-11-09 15:08 ` [PATCH 01/18] scsi_dh: move 'dh_state' sysfs attribute to generic code Hannes Reinecke
2015-11-24 12:14   ` Johannes Thumshirn
2015-11-30 16:59   ` Martin K. Petersen
2015-11-09 15:08 ` [PATCH 02/18] scsi: ignore errors from scsi_dh_add_device() Hannes Reinecke
2015-11-24 12:14   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 03/18] scsi_dh_alua: Disable ALUA handling for non-disk devices Hannes Reinecke
2015-11-24 12:14   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 04/18] scsi_dh_alua: Use vpd_pg83 information Hannes Reinecke
2015-11-24 12:15   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 05/18] scsi_dh_alua: improved logging Hannes Reinecke
2015-11-24 12:15   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 06/18] scsi_dh_alua: sanitze sense code handling Hannes Reinecke
2015-11-24 12:16   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 07/18] scsi_dh_alua: use standard logging functions Hannes Reinecke
2015-11-24 12:16   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 08/18] scsi_dh_alua: return standard SCSI return codes in submit_rtpg Hannes Reinecke
2015-11-24 12:16   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 09/18] scsi_dh_alua: fixup description of stpg_endio() Hannes Reinecke
2015-11-24 12:16   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 10/18] scsi: remove scsi_show_sense_hdr() Hannes Reinecke
2015-11-24 12:16   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 11/18] scsi_dh_alua: use flag for RTPG extended header Hannes Reinecke
2015-11-24 12:16   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 12/18] scsi_dh_alua: use unaligned access macros Hannes Reinecke
2015-11-24 12:17   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 13/18] scsi_dh_alua: rework alua_check_tpgs() to return the tpgs mode Hannes Reinecke
2015-11-24 12:17   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 14/18] scsi_dh_alua: simplify sense code handling Hannes Reinecke
2015-11-24 12:17   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 15/18] scsi: Add scsi_vpd_lun_id() Hannes Reinecke
2015-11-24 12:17   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 16/18] scsi: export 'device_id' to sysfs Hannes Reinecke
2015-11-24 12:17   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 17/18] scsi: Add scsi_vpd_tpg_id() Hannes Reinecke
2015-11-24 12:17   ` Johannes Thumshirn
2015-11-09 15:08 ` [PATCH 18/18] scsi_dh_alua: use scsi_vpd_tpg_id() Hannes Reinecke
2015-11-24 12:18   ` Johannes Thumshirn
2015-11-19  8:35 ` [PATCH 00/18] ALUA device handler update, part 1 Christoph Hellwig
2015-11-19  9:42   ` Hannes Reinecke
2015-11-20 10:47 ` Christoph Hellwig
2015-11-20 10:52   ` Hannes Reinecke
2015-11-20 10:54     ` Christoph Hellwig
2015-11-20 11:02       ` Hannes Reinecke
2015-11-20 22:58     ` Bart Van Assche
2015-11-23 16:10       ` Hannes Reinecke
2015-11-23 16:18         ` Bart Van Assche
2015-11-24 15:29           ` Hannes Reinecke
2015-12-01  9:16 [PATCHv2 " Hannes Reinecke
2015-12-01  9:16 ` [PATCH 05/18] scsi_dh_alua: improved logging Hannes Reinecke
2015-12-01  9:28   ` Johannes Thumshirn

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.