All of lore.kernel.org
 help / color / mirror / Atom feed
From: Henry Chen <henryc.chen@mediatek.com>
To: John Crispin <blogic@openwrt.org>
Cc: Matthias Brugger <matthias.bgg@gmail.com>,
	Steven Liu <steven.liu@mediatek.com>,
	Sascha Hauer <s.hauer@pengutronix.de>,
	<linux-kernel@vger.kernel.org>, Flora Fu <flora.fu@mediatek.com>,
	<linux-mediatek@lists.infradead.org>,
	Lee Jones <lee.jones@linaro.org>,
	<linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH V2 4/4] mfd: mediatek: add MT6323 support to MT6397 driver
Date: Tue, 26 Jan 2016 11:07:23 +0800	[thread overview]
Message-ID: <1453777643.26374.11.camel@mtksdaap41> (raw)
In-Reply-To: <56A670A3.5030100@openwrt.org>

On Mon, 2016-01-25 at 19:59 +0100, John Crispin wrote:
> 
> On 25/01/2016 19:44, Matthias Brugger wrote:
> > On Monday 25 Jan 2016 16:36:40 John Crispin wrote:
> >> Hi,
> >>
> >> On 25/01/2016 13:41, Lee Jones wrote:
> >>> Please honour the subject format of the subsystem you are contributing
> >>> to.
> >>>
> >>> `git log --oneline -- $subsystem` gives you this.
> >>>
> >>> On Mon, 25 Jan 2016, John Crispin wrote:
> >>>> Signed-off-by: John Crispin <blogic@openwrt.org>
> >>>> ---
> >>
> >> [...]
> >>
> >>>> @@ -261,6 +271,15 @@ static int mt6397_probe(struct platform_device
> >>>> *pdev)
> >>>>
> >>>>  	}
> >>>>  	
> >>>>  	switch (id & 0xff) {
> >>>>
> >>>> +	case MT6323_CID_CODE:
> >>>> +		mt6397->int_con[0] = MT6323_INT_CON0;
> >>>
> >>> This is confusing.  You're still using memory allocated for a mt6397
> >>> device.
> >>
> >> the variable is currently defined as struct mt6397_chip *mt6397;
> >> shall i only change the name or also create a patch to rename the struct ?
> >>
> > 
> > I think we should rename the struct and the file as well.
> > 
> > Cheers,
> > Matthias
> 
> Hi,
> 
> that would have been my next question. renaming the struct would imply
> renaming the driver and the whole namespace contained within. We would
> then also need to change the Kconfig and Makefile. I am happy to do this
> but want to be sure that is is actually wanted.
> 
> 	John
Hi,

Since mt6323 was similar with mt6397, I think we can reuse the
mt6397_chip without duplicate code.

Maybe we can rename the local variable name to avoid confusing.

struct mt6397_chip *mt_pmic;
...
...
switch (id & 0xff) {
	case MT6323_CID_CODE:
		mt_pmic->int_con[0] = MT6323_INT_CON0;
		mt_pmic->int_con[1] = MT6323_INT_CON1;
...
...

Henry

WARNING: multiple messages have this Message-ID (diff)
From: Henry Chen <henryc.chen@mediatek.com>
To: John Crispin <blogic@openwrt.org>
Cc: Matthias Brugger <matthias.bgg@gmail.com>,
	Steven Liu <steven.liu@mediatek.com>,
	Sascha Hauer <s.hauer@pengutronix.de>,
	linux-kernel@vger.kernel.org, Flora Fu <flora.fu@mediatek.com>,
	linux-mediatek@lists.infradead.org,
	Lee Jones <lee.jones@linaro.org>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH V2 4/4] mfd: mediatek: add MT6323 support to MT6397 driver
Date: Tue, 26 Jan 2016 11:07:23 +0800	[thread overview]
Message-ID: <1453777643.26374.11.camel@mtksdaap41> (raw)
In-Reply-To: <56A670A3.5030100@openwrt.org>

On Mon, 2016-01-25 at 19:59 +0100, John Crispin wrote:
> 
> On 25/01/2016 19:44, Matthias Brugger wrote:
> > On Monday 25 Jan 2016 16:36:40 John Crispin wrote:
> >> Hi,
> >>
> >> On 25/01/2016 13:41, Lee Jones wrote:
> >>> Please honour the subject format of the subsystem you are contributing
> >>> to.
> >>>
> >>> `git log --oneline -- $subsystem` gives you this.
> >>>
> >>> On Mon, 25 Jan 2016, John Crispin wrote:
> >>>> Signed-off-by: John Crispin <blogic@openwrt.org>
> >>>> ---
> >>
> >> [...]
> >>
> >>>> @@ -261,6 +271,15 @@ static int mt6397_probe(struct platform_device
> >>>> *pdev)
> >>>>
> >>>>  	}
> >>>>  	
> >>>>  	switch (id & 0xff) {
> >>>>
> >>>> +	case MT6323_CID_CODE:
> >>>> +		mt6397->int_con[0] = MT6323_INT_CON0;
> >>>
> >>> This is confusing.  You're still using memory allocated for a mt6397
> >>> device.
> >>
> >> the variable is currently defined as struct mt6397_chip *mt6397;
> >> shall i only change the name or also create a patch to rename the struct ?
> >>
> > 
> > I think we should rename the struct and the file as well.
> > 
> > Cheers,
> > Matthias
> 
> Hi,
> 
> that would have been my next question. renaming the struct would imply
> renaming the driver and the whole namespace contained within. We would
> then also need to change the Kconfig and Makefile. I am happy to do this
> but want to be sure that is is actually wanted.
> 
> 	John
Hi,

Since mt6323 was similar with mt6397, I think we can reuse the
mt6397_chip without duplicate code.

Maybe we can rename the local variable name to avoid confusing.

struct mt6397_chip *mt_pmic;
...
...
switch (id & 0xff) {
	case MT6323_CID_CODE:
		mt_pmic->int_con[0] = MT6323_INT_CON0;
		mt_pmic->int_con[1] = MT6323_INT_CON1;
...
...

Henry

WARNING: multiple messages have this Message-ID (diff)
From: henryc.chen@mediatek.com (Henry Chen)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH V2 4/4] mfd: mediatek: add MT6323 support to MT6397 driver
Date: Tue, 26 Jan 2016 11:07:23 +0800	[thread overview]
Message-ID: <1453777643.26374.11.camel@mtksdaap41> (raw)
In-Reply-To: <56A670A3.5030100@openwrt.org>

On Mon, 2016-01-25 at 19:59 +0100, John Crispin wrote:
> 
> On 25/01/2016 19:44, Matthias Brugger wrote:
> > On Monday 25 Jan 2016 16:36:40 John Crispin wrote:
> >> Hi,
> >>
> >> On 25/01/2016 13:41, Lee Jones wrote:
> >>> Please honour the subject format of the subsystem you are contributing
> >>> to.
> >>>
> >>> `git log --oneline -- $subsystem` gives you this.
> >>>
> >>> On Mon, 25 Jan 2016, John Crispin wrote:
> >>>> Signed-off-by: John Crispin <blogic@openwrt.org>
> >>>> ---
> >>
> >> [...]
> >>
> >>>> @@ -261,6 +271,15 @@ static int mt6397_probe(struct platform_device
> >>>> *pdev)
> >>>>
> >>>>  	}
> >>>>  	
> >>>>  	switch (id & 0xff) {
> >>>>
> >>>> +	case MT6323_CID_CODE:
> >>>> +		mt6397->int_con[0] = MT6323_INT_CON0;
> >>>
> >>> This is confusing.  You're still using memory allocated for a mt6397
> >>> device.
> >>
> >> the variable is currently defined as struct mt6397_chip *mt6397;
> >> shall i only change the name or also create a patch to rename the struct ?
> >>
> > 
> > I think we should rename the struct and the file as well.
> > 
> > Cheers,
> > Matthias
> 
> Hi,
> 
> that would have been my next question. renaming the struct would imply
> renaming the driver and the whole namespace contained within. We would
> then also need to change the Kconfig and Makefile. I am happy to do this
> but want to be sure that is is actually wanted.
> 
> 	John
Hi,

Since mt6323 was similar with mt6397, I think we can reuse the
mt6397_chip without duplicate code.

Maybe we can rename the local variable name to avoid confusing.

struct mt6397_chip *mt_pmic;
...
...
switch (id & 0xff) {
	case MT6323_CID_CODE:
		mt_pmic->int_con[0] = MT6323_INT_CON0;
		mt_pmic->int_con[1] = MT6323_INT_CON1;
...
...

Henry

  reply	other threads:[~2016-01-26  3:37 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-01-25 10:14 [PATCH V2 0/4] mfd: mediatek: add mt6323 support to the mt6397 driver John Crispin
2016-01-25 10:14 ` John Crispin
2016-01-25 10:14 ` [PATCH V2 1/4] dt-bindings: mfd: Add bindings for the MediaTek MT6323 PMIC John Crispin
2016-01-25 10:14   ` John Crispin
2016-01-25 10:14   ` John Crispin
2016-01-25 12:41   ` Lee Jones
2016-01-25 12:41     ` Lee Jones
2016-01-25 10:14 ` [PATCH V2 2/4] mfd: mediatek: int_con and int_status may vary in location John Crispin
2016-01-25 10:14   ` John Crispin
2016-01-25 12:33   ` Lee Jones
2016-01-25 12:33     ` Lee Jones
2016-01-25 10:14 ` [PATCH V2 3/4] mfd: mediatek: add support for different Slave types John Crispin
2016-01-25 10:14   ` John Crispin
2016-01-25 12:37   ` Lee Jones
2016-01-25 12:37     ` Lee Jones
2016-01-25 10:14 ` [PATCH V2 4/4] mfd: mediatek: add MT6323 support to MT6397 driver John Crispin
2016-01-25 10:14   ` John Crispin
2016-01-25 12:41   ` Lee Jones
2016-01-25 12:41     ` Lee Jones
2016-01-25 15:36     ` John Crispin
2016-01-25 15:36       ` John Crispin
2016-01-25 18:44       ` Matthias Brugger
2016-01-25 18:44         ` Matthias Brugger
2016-01-25 18:59         ` John Crispin
2016-01-25 18:59           ` John Crispin
2016-01-26  3:07           ` Henry Chen [this message]
2016-01-26  3:07             ` Henry Chen
2016-01-26  3:07             ` Henry Chen
2016-01-26  7:14             ` John Crispin
2016-01-26  7:14               ` John Crispin
2016-01-26  8:34               ` Lee Jones
2016-01-26  8:34                 ` Lee Jones
2016-01-26  8:44                 ` John Crispin
2016-01-26  8:44                   ` John Crispin
2016-01-26 12:05                 ` John Crispin
2016-01-26 12:05                   ` John Crispin
2016-01-26 14:00                   ` Lee Jones
2016-01-26 14:00                     ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1453777643.26374.11.camel@mtksdaap41 \
    --to=henryc.chen@mediatek.com \
    --cc=blogic@openwrt.org \
    --cc=flora.fu@mediatek.com \
    --cc=lee.jones@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=s.hauer@pengutronix.de \
    --cc=steven.liu@mediatek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.