All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/3] drm/i915/gtt: Reference mappable_end variable from pointer
@ 2016-03-18  7:53 Joonas Lahtinen
  2016-03-18  7:53 ` [PATCH 2/3] drm/i915: Rename dev_priv->gtt to dev_priv->ggtt Joonas Lahtinen
                   ` (3 more replies)
  0 siblings, 4 replies; 11+ messages in thread
From: Joonas Lahtinen @ 2016-03-18  7:53 UTC (permalink / raw)
  To: Intel graphics driver community testing & development

Reference variable value from pointer, not assumed pointer destination.

Since:

commit c44ef60e437019b8ca1dab8b4d2e8761fd4ce1e9
Author: Mika Kuoppala <mika.kuoppala@linux.intel.com>
Date:   Thu Jun 25 18:35:05 2015 +0300

    drm/i915/gtt: Allow >= 4GB sizes for vm.

Cc: Mika Kuoppala <mika.kuoppala@linux.intel.com>
Signed-off-by: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
---
 drivers/gpu/drm/i915/i915_gem_gtt.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/i915/i915_gem_gtt.c b/drivers/gpu/drm/i915/i915_gem_gtt.c
index 9c752fe..5c90952 100644
--- a/drivers/gpu/drm/i915/i915_gem_gtt.c
+++ b/drivers/gpu/drm/i915/i915_gem_gtt.c
@@ -3103,8 +3103,7 @@ static int gen6_gmch_probe(struct drm_device *dev,
 	 * a coarse sanity check.
 	 */
 	if ((*mappable_end < (64<<20) || (*mappable_end > (512<<20)))) {
-		DRM_ERROR("Unknown GMADR size (%llx)\n",
-			  dev_priv->gtt.mappable_end);
+		DRM_ERROR("Unknown GMADR size (%llx)\n", *mappable_end);
 		return -ENXIO;
 	}
 
-- 
2.5.0

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2016-03-21  9:41 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-03-18  7:53 [PATCH 1/3] drm/i915/gtt: Reference mappable_end variable from pointer Joonas Lahtinen
2016-03-18  7:53 ` [PATCH 2/3] drm/i915: Rename dev_priv->gtt to dev_priv->ggtt Joonas Lahtinen
2016-03-18  8:16   ` Chris Wilson
2016-03-18  7:53 ` [PATCH 3/3] drm/i915/gtt: Clean up GGTT probing code Joonas Lahtinen
2016-03-18  8:19   ` Chris Wilson
2016-03-18  8:21 ` [PATCH 1/3] drm/i915/gtt: Reference mappable_end variable from pointer Chris Wilson
2016-03-18  8:54   ` Joonas Lahtinen
2016-03-21  9:35     ` Daniel Vetter
2016-03-21  9:39       ` Chris Wilson
2016-03-21  9:41         ` Daniel Vetter
2016-03-18 11:11 ` ✗ Fi.CI.BAT: warning for series starting with [1/3] " Patchwork

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.