All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] gpio: tegra: Implement gpio_get_direction callback
@ 2016-04-29 12:31 ` Laxman Dewangan
  0 siblings, 0 replies; 7+ messages in thread
From: Laxman Dewangan @ 2016-04-29 12:31 UTC (permalink / raw)
  To: linus.walleij, swarren, thierry.reding
  Cc: linux-gpio, linux-tegra, linux-kernel, Laxman Dewangan

Implement gpio_get_direction() callback for Tegra GPIO.
The direction is only valid if the pin is configured as
GPIO. If pin is not configured in GPIO mode then this
function return error.

This makes debugfs and initial reading of the state of
the lines more accurate.

Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
---
This patch is based on discussion on series 
Re: [PATCH V5 0/4] gpio: tegra: Cleanups and support for debounce
From Linus W:
It would be nice if you also implement .get_direction() which makes
debugfs and initial reading of the state of the lines more accurate.

 drivers/gpio/gpio-tegra.c | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/drivers/gpio/gpio-tegra.c b/drivers/gpio/gpio-tegra.c
index b3ddd92..6f2292b 100644
--- a/drivers/gpio/gpio-tegra.c
+++ b/drivers/gpio/gpio-tegra.c
@@ -191,6 +191,24 @@ static int tegra_gpio_direction_output(struct gpio_chip *chip, unsigned offset,
 	return 0;
 }
 
+static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
+{
+	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
+	u32 pin_mask = BIT(GPIO_BIT(offset));
+	u32 cnf, oe;
+
+	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
+	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
+	if (cnf & pin_mask) {
+		if (oe & pin_mask)
+			return GPIOF_DIR_OUT;
+
+		return GPIOF_DIR_IN;
+	}
+
+	return -EINVAL;
+}
+
 static int tegra_gpio_set_debounce(struct gpio_chip *chip, unsigned int offset,
 				   unsigned int debounce)
 {
@@ -575,6 +593,7 @@ static int tegra_gpio_probe(struct platform_device *pdev)
 	tgi->gc.get			= tegra_gpio_get;
 	tgi->gc.direction_output	= tegra_gpio_direction_output;
 	tgi->gc.set			= tegra_gpio_set;
+	tgi->gc.get_direction		= tegra_gpio_get_direction;
 	tgi->gc.to_irq			= tegra_gpio_to_irq;
 	tgi->gc.base			= 0;
 	tgi->gc.ngpio			= tgi->bank_count * 32;
-- 
2.1.4


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* [PATCH] gpio: tegra: Implement gpio_get_direction callback
@ 2016-04-29 12:31 ` Laxman Dewangan
  0 siblings, 0 replies; 7+ messages in thread
From: Laxman Dewangan @ 2016-04-29 12:31 UTC (permalink / raw)
  To: linus.walleij, swarren, thierry.reding
  Cc: linux-gpio, linux-tegra, linux-kernel, Laxman Dewangan

Implement gpio_get_direction() callback for Tegra GPIO.
The direction is only valid if the pin is configured as
GPIO. If pin is not configured in GPIO mode then this
function return error.

This makes debugfs and initial reading of the state of
the lines more accurate.

Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
---
This patch is based on discussion on series 
Re: [PATCH V5 0/4] gpio: tegra: Cleanups and support for debounce
>From Linus W:
It would be nice if you also implement .get_direction() which makes
debugfs and initial reading of the state of the lines more accurate.

 drivers/gpio/gpio-tegra.c | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/drivers/gpio/gpio-tegra.c b/drivers/gpio/gpio-tegra.c
index b3ddd92..6f2292b 100644
--- a/drivers/gpio/gpio-tegra.c
+++ b/drivers/gpio/gpio-tegra.c
@@ -191,6 +191,24 @@ static int tegra_gpio_direction_output(struct gpio_chip *chip, unsigned offset,
 	return 0;
 }
 
+static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
+{
+	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
+	u32 pin_mask = BIT(GPIO_BIT(offset));
+	u32 cnf, oe;
+
+	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
+	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
+	if (cnf & pin_mask) {
+		if (oe & pin_mask)
+			return GPIOF_DIR_OUT;
+
+		return GPIOF_DIR_IN;
+	}
+
+	return -EINVAL;
+}
+
 static int tegra_gpio_set_debounce(struct gpio_chip *chip, unsigned int offset,
 				   unsigned int debounce)
 {
@@ -575,6 +593,7 @@ static int tegra_gpio_probe(struct platform_device *pdev)
 	tgi->gc.get			= tegra_gpio_get;
 	tgi->gc.direction_output	= tegra_gpio_direction_output;
 	tgi->gc.set			= tegra_gpio_set;
+	tgi->gc.get_direction		= tegra_gpio_get_direction;
 	tgi->gc.to_irq			= tegra_gpio_to_irq;
 	tgi->gc.base			= 0;
 	tgi->gc.ngpio			= tgi->bank_count * 32;
-- 
2.1.4


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* [PATCH] gpio: tegra: Implement gpio_get_direction callback
@ 2016-04-29 12:31 ` Laxman Dewangan
  0 siblings, 0 replies; 7+ messages in thread
From: Laxman Dewangan @ 2016-04-29 12:31 UTC (permalink / raw)
  To: linus.walleij, swarren, thierry.reding
  Cc: linux-gpio, linux-tegra, linux-kernel, Laxman Dewangan

Implement gpio_get_direction() callback for Tegra GPIO.
The direction is only valid if the pin is configured as
GPIO. If pin is not configured in GPIO mode then this
function return error.

This makes debugfs and initial reading of the state of
the lines more accurate.

Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
---
This patch is based on discussion on series 
Re: [PATCH V5 0/4] gpio: tegra: Cleanups and support for debounce
>From Linus W:
It would be nice if you also implement .get_direction() which makes
debugfs and initial reading of the state of the lines more accurate.

 drivers/gpio/gpio-tegra.c | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/drivers/gpio/gpio-tegra.c b/drivers/gpio/gpio-tegra.c
index b3ddd92..6f2292b 100644
--- a/drivers/gpio/gpio-tegra.c
+++ b/drivers/gpio/gpio-tegra.c
@@ -191,6 +191,24 @@ static int tegra_gpio_direction_output(struct gpio_chip *chip, unsigned offset,
 	return 0;
 }
 
+static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
+{
+	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
+	u32 pin_mask = BIT(GPIO_BIT(offset));
+	u32 cnf, oe;
+
+	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
+	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
+	if (cnf & pin_mask) {
+		if (oe & pin_mask)
+			return GPIOF_DIR_OUT;
+
+		return GPIOF_DIR_IN;
+	}
+
+	return -EINVAL;
+}
+
 static int tegra_gpio_set_debounce(struct gpio_chip *chip, unsigned int offset,
 				   unsigned int debounce)
 {
@@ -575,6 +593,7 @@ static int tegra_gpio_probe(struct platform_device *pdev)
 	tgi->gc.get			= tegra_gpio_get;
 	tgi->gc.direction_output	= tegra_gpio_direction_output;
 	tgi->gc.set			= tegra_gpio_set;
+	tgi->gc.get_direction		= tegra_gpio_get_direction;
 	tgi->gc.to_irq			= tegra_gpio_to_irq;
 	tgi->gc.base			= 0;
 	tgi->gc.ngpio			= tgi->bank_count * 32;
-- 
2.1.4

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback
  2016-04-29 12:31 ` Laxman Dewangan
@ 2016-04-29 15:30   ` Jon Hunter
  -1 siblings, 0 replies; 7+ messages in thread
From: Jon Hunter @ 2016-04-29 15:30 UTC (permalink / raw)
  To: Laxman Dewangan, linus.walleij, swarren, thierry.reding
  Cc: linux-gpio, linux-tegra, linux-kernel


On 29/04/16 13:31, Laxman Dewangan wrote:
> Implement gpio_get_direction() callback for Tegra GPIO.
> The direction is only valid if the pin is configured as
> GPIO. If pin is not configured in GPIO mode then this
> function return error.
> 
> This makes debugfs and initial reading of the state of
> the lines more accurate.
> 
> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
> ---
> This patch is based on discussion on series 
> Re: [PATCH V5 0/4] gpio: tegra: Cleanups and support for debounce
> From Linus W:
> It would be nice if you also implement .get_direction() which makes
> debugfs and initial reading of the state of the lines more accurate.
> 
>  drivers/gpio/gpio-tegra.c | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
> 
> diff --git a/drivers/gpio/gpio-tegra.c b/drivers/gpio/gpio-tegra.c
> index b3ddd92..6f2292b 100644
> --- a/drivers/gpio/gpio-tegra.c
> +++ b/drivers/gpio/gpio-tegra.c
> @@ -191,6 +191,24 @@ static int tegra_gpio_direction_output(struct gpio_chip *chip, unsigned offset,
>  	return 0;
>  }
>  
> +static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
> +{
> +	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
> +	u32 pin_mask = BIT(GPIO_BIT(offset));
> +	u32 cnf, oe;
> +
> +	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
> +	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
> +	if (cnf & pin_mask) {

Nit ... does not look like there is any point in reading GPIO_OE if cnf
& pin_mask == 0, so you could move the test before reading GPIO_OE and
then ...

> +		if (oe & pin_mask)
> +			return GPIOF_DIR_OUT;
> +
> +		return GPIOF_DIR_IN;

You could ...

	return (oe & mask) ? GPIOF_DIR_OUT : GPIOF_DIR_IN;

Cheers
Jon

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback
@ 2016-04-29 15:30   ` Jon Hunter
  0 siblings, 0 replies; 7+ messages in thread
From: Jon Hunter @ 2016-04-29 15:30 UTC (permalink / raw)
  To: Laxman Dewangan, linus.walleij, swarren, thierry.reding
  Cc: linux-gpio, linux-tegra, linux-kernel


On 29/04/16 13:31, Laxman Dewangan wrote:
> Implement gpio_get_direction() callback for Tegra GPIO.
> The direction is only valid if the pin is configured as
> GPIO. If pin is not configured in GPIO mode then this
> function return error.
> 
> This makes debugfs and initial reading of the state of
> the lines more accurate.
> 
> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
> ---
> This patch is based on discussion on series 
> Re: [PATCH V5 0/4] gpio: tegra: Cleanups and support for debounce
> From Linus W:
> It would be nice if you also implement .get_direction() which makes
> debugfs and initial reading of the state of the lines more accurate.
> 
>  drivers/gpio/gpio-tegra.c | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
> 
> diff --git a/drivers/gpio/gpio-tegra.c b/drivers/gpio/gpio-tegra.c
> index b3ddd92..6f2292b 100644
> --- a/drivers/gpio/gpio-tegra.c
> +++ b/drivers/gpio/gpio-tegra.c
> @@ -191,6 +191,24 @@ static int tegra_gpio_direction_output(struct gpio_chip *chip, unsigned offset,
>  	return 0;
>  }
>  
> +static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
> +{
> +	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
> +	u32 pin_mask = BIT(GPIO_BIT(offset));
> +	u32 cnf, oe;
> +
> +	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
> +	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
> +	if (cnf & pin_mask) {

Nit ... does not look like there is any point in reading GPIO_OE if cnf
& pin_mask == 0, so you could move the test before reading GPIO_OE and
then ...

> +		if (oe & pin_mask)
> +			return GPIOF_DIR_OUT;
> +
> +		return GPIOF_DIR_IN;

You could ...

	return (oe & mask) ? GPIOF_DIR_OUT : GPIOF_DIR_IN;

Cheers
Jon

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback
  2016-04-29 12:31 ` Laxman Dewangan
@ 2016-04-29 16:17     ` Stephen Warren
  -1 siblings, 0 replies; 7+ messages in thread
From: Stephen Warren @ 2016-04-29 16:17 UTC (permalink / raw)
  To: Laxman Dewangan
  Cc: linus.walleij-QSEj5FYQhm4dnm+yROfE0A,
	thierry.reding-Re5JQEeQqe8AvxtiuMwx3w,
	linux-gpio-u79uwXL29TY76Z2rM5mHXA,
	linux-tegra-u79uwXL29TY76Z2rM5mHXA,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA

On 04/29/2016 06:31 AM, Laxman Dewangan wrote:
> Implement gpio_get_direction() callback for Tegra GPIO.
> The direction is only valid if the pin is configured as
> GPIO. If pin is not configured in GPIO mode then this
> function return error.
>
> This makes debugfs and initial reading of the state of
> the lines more accurate.

> +static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
> +{
> +	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
> +	u32 pin_mask = BIT(GPIO_BIT(offset));
> +	u32 cnf, oe;
> +
> +	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
> +	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
> +	if (cnf & pin_mask) {
> +		if (oe & pin_mask)
> +			return GPIOF_DIR_OUT;
> +
> +		return GPIOF_DIR_IN;
> +	}
> +
> +	return -EINVAL;
> +}

Conceptually looks fine, but I have similar comments to Jon; whenever 
there's an error condition, just fail immediately. That way you avoid 
the entire rest of the function being indented:

cnf = ...
if (!(cnf ...)
     return -EINVAL;
oe = ...
return ...

The only indented code there is the error handling. At least to me, this 
makes the code a lot more readable since there are far fewer 
combinations of conditionals.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback
@ 2016-04-29 16:17     ` Stephen Warren
  0 siblings, 0 replies; 7+ messages in thread
From: Stephen Warren @ 2016-04-29 16:17 UTC (permalink / raw)
  To: Laxman Dewangan
  Cc: linus.walleij, thierry.reding, linux-gpio, linux-tegra, linux-kernel

On 04/29/2016 06:31 AM, Laxman Dewangan wrote:
> Implement gpio_get_direction() callback for Tegra GPIO.
> The direction is only valid if the pin is configured as
> GPIO. If pin is not configured in GPIO mode then this
> function return error.
>
> This makes debugfs and initial reading of the state of
> the lines more accurate.

> +static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
> +{
> +	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
> +	u32 pin_mask = BIT(GPIO_BIT(offset));
> +	u32 cnf, oe;
> +
> +	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
> +	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
> +	if (cnf & pin_mask) {
> +		if (oe & pin_mask)
> +			return GPIOF_DIR_OUT;
> +
> +		return GPIOF_DIR_IN;
> +	}
> +
> +	return -EINVAL;
> +}

Conceptually looks fine, but I have similar comments to Jon; whenever 
there's an error condition, just fail immediately. That way you avoid 
the entire rest of the function being indented:

cnf = ...
if (!(cnf ...)
     return -EINVAL;
oe = ...
return ...

The only indented code there is the error handling. At least to me, this 
makes the code a lot more readable since there are far fewer 
combinations of conditionals.

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2016-04-29 16:17 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-04-29 12:31 [PATCH] gpio: tegra: Implement gpio_get_direction callback Laxman Dewangan
2016-04-29 12:31 ` Laxman Dewangan
2016-04-29 12:31 ` Laxman Dewangan
2016-04-29 15:30 ` Jon Hunter
2016-04-29 15:30   ` Jon Hunter
     [not found] ` <1461933078-20366-1-git-send-email-ldewangan-DDmLM1+adcrQT0dZR+AlfA@public.gmane.org>
2016-04-29 16:17   ` Stephen Warren
2016-04-29 16:17     ` Stephen Warren

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.