All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] ixgbe: rename ixgbe_rxtx_vec.c to ixgbe_rxtx_vec_sse.c
@ 2016-05-11  3:45 Jianbo Liu
  2016-05-31 16:46 ` Bruce Richardson
  0 siblings, 1 reply; 2+ messages in thread
From: Jianbo Liu @ 2016-05-11  3:45 UTC (permalink / raw)
  To: dev, bruce.richardson; +Cc: Jianbo Liu

To be consistent with the naming for ARM NEON implementation,
ixgbe_rxtx_vec.c is renamed to ixgbe_rxtx_vec_sse.c.

Signed-off-by: Jianbo Liu <jianbo.liu@linaro.org>
---
 drivers/net/ixgbe/Makefile                                   | 2 +-
 drivers/net/ixgbe/{ixgbe_rxtx_vec.c => ixgbe_rxtx_vec_sse.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/net/ixgbe/{ixgbe_rxtx_vec.c => ixgbe_rxtx_vec_sse.c} (100%)

diff --git a/drivers/net/ixgbe/Makefile b/drivers/net/ixgbe/Makefile
index b1c7a60..12b63b4 100644
--- a/drivers/net/ixgbe/Makefile
+++ b/drivers/net/ixgbe/Makefile
@@ -111,7 +111,7 @@ SRCS-$(CONFIG_RTE_LIBRTE_IXGBE_PMD) += ixgbe_pf.c
 ifeq ($(CONFIG_RTE_ARCH_ARM64),y)
 SRCS-$(CONFIG_RTE_IXGBE_INC_VECTOR) += ixgbe_rxtx_vec_neon.c
 else
-SRCS-$(CONFIG_RTE_IXGBE_INC_VECTOR) += ixgbe_rxtx_vec.c
+SRCS-$(CONFIG_RTE_IXGBE_INC_VECTOR) += ixgbe_rxtx_vec_sse.c
 endif
 
 ifeq ($(CONFIG_RTE_NIC_BYPASS),y)
diff --git a/drivers/net/ixgbe/ixgbe_rxtx_vec.c b/drivers/net/ixgbe/ixgbe_rxtx_vec_sse.c
similarity index 100%
rename from drivers/net/ixgbe/ixgbe_rxtx_vec.c
rename to drivers/net/ixgbe/ixgbe_rxtx_vec_sse.c
-- 
2.4.11

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] ixgbe: rename ixgbe_rxtx_vec.c to ixgbe_rxtx_vec_sse.c
  2016-05-11  3:45 [PATCH] ixgbe: rename ixgbe_rxtx_vec.c to ixgbe_rxtx_vec_sse.c Jianbo Liu
@ 2016-05-31 16:46 ` Bruce Richardson
  0 siblings, 0 replies; 2+ messages in thread
From: Bruce Richardson @ 2016-05-31 16:46 UTC (permalink / raw)
  To: Jianbo Liu; +Cc: dev

On Wed, May 11, 2016 at 09:15:09AM +0530, Jianbo Liu wrote:
> To be consistent with the naming for ARM NEON implementation,
> ixgbe_rxtx_vec.c is renamed to ixgbe_rxtx_vec_sse.c.
> 
> Signed-off-by: Jianbo Liu <jianbo.liu@linaro.org>
> ---
Acked-by: Bruce Richardson <bruce.richardson@intel.com>

Applied to dpdk-next-net/rel_16_07

/Bruce

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2016-05-31 16:46 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-05-11  3:45 [PATCH] ixgbe: rename ixgbe_rxtx_vec.c to ixgbe_rxtx_vec_sse.c Jianbo Liu
2016-05-31 16:46 ` Bruce Richardson

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.