All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE()
@ 2015-10-04 20:38 Sergei Shtylyov
  2015-10-04 20:50 ` [PATCH 1/8] ehci-pci: " Sergei Shtylyov
                   ` (7 more replies)
  0 siblings, 8 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 20:38 UTC (permalink / raw)
  To: gregkh, linux-usb; +Cc: linux-kernel

Hello.

   Here's a set of 8 patches against the 'usb-next' branch of Greg KH's 
'usb.git' repo. It's to eliminate the use of the PCI_DEVICE() macro where
less verbose PCI_VDEVICE() should have been used.

[1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE()
[2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE()
[3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()
[4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE()
[5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE()
[6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE()
[7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE()
[8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()

WBR, Sergei


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
@ 2015-10-04 20:50 ` Sergei Shtylyov
  2015-10-04 20:52 ` [PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() " Sergei Shtylyov
                   ` (6 subsequent siblings)
  7 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 20:50 UTC (permalink / raw)
  To: gregkh, linux-usb, stern; +Cc: linux-kernel

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/host/ehci-pci.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Index: usb/drivers/usb/host/ehci-pci.c
===================================================================
--- usb.orig/drivers/usb/host/ehci-pci.c
+++ usb/drivers/usb/host/ehci-pci.c
@@ -49,9 +49,9 @@ static inline bool is_intel_quark_x1000(
  */
 static const struct pci_device_id bypass_pci_id_table[] = {
 	/* ChipIdea on Intel MID platform */
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0811), },
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0829), },
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0xe006), },
+	{ PCI_VDEVICE(INTEL, 0x0811), },
+	{ PCI_VDEVICE(INTEL, 0x0829), },
+	{ PCI_VDEVICE(INTEL, 0xe006), },
 	{}
 };
 


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
  2015-10-04 20:50 ` [PATCH 1/8] ehci-pci: " Sergei Shtylyov
@ 2015-10-04 20:52 ` Sergei Shtylyov
  2015-10-04 20:55 ` [PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() " Sergei Shtylyov
                   ` (5 subsequent siblings)
  7 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 20:52 UTC (permalink / raw)
  To: gregkh, linux-usb, stern; +Cc: linux-kernel

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/host/ohci-pci.c |   20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

Index: usb/drivers/usb/host/ohci-pci.c
===================================================================
--- usb.orig/drivers/usb/host/ohci-pci.c
+++ usb/drivers/usb/host/ohci-pci.c
@@ -167,27 +167,27 @@ static int ohci_quirk_amd700(struct usb_
 /* List of quirks for OHCI */
 static const struct pci_device_id ohci_pci_quirks[] = {
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_AMD, 0x740c),
+		PCI_VDEVICE(AMD, 0x740c),
 		.driver_data = (unsigned long)ohci_quirk_amd756,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_OPTI, 0xc861),
+		PCI_VDEVICE(OPTI, 0xc861),
 		.driver_data = (unsigned long)ohci_quirk_opti,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_NS, PCI_ANY_ID),
+		PCI_VDEVICE(NS, PCI_ANY_ID),
 		.driver_data = (unsigned long)ohci_quirk_ns,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_COMPAQ, 0xa0f8),
+		PCI_VDEVICE(COMPAQ, 0xa0f8),
 		.driver_data = (unsigned long)ohci_quirk_zfmicro,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_TOSHIBA_2, 0x01b6),
+		PCI_VDEVICE(TOSHIBA_2, 0x01b6),
 		.driver_data = (unsigned long)ohci_quirk_toshiba_scc,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_NEC, PCI_DEVICE_ID_NEC_USB),
+		PCI_VDEVICE(NEC, PCI_DEVICE_ID_NEC_USB),
 		.driver_data = (unsigned long)ohci_quirk_nec,
 	},
 	{
@@ -199,19 +199,19 @@ static const struct pci_device_id ohci_p
 		.driver_data	= (unsigned long) broken_suspend,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_ITE, 0x8152),
+		PCI_VDEVICE(ITE, 0x8152),
 		.driver_data = (unsigned long) broken_suspend,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_ATI, 0x4397),
+		PCI_VDEVICE(ATI, 0x4397),
 		.driver_data = (unsigned long)ohci_quirk_amd700,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_ATI, 0x4398),
+		PCI_VDEVICE(ATI, 0x4398),
 		.driver_data = (unsigned long)ohci_quirk_amd700,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_ATI, 0x4399),
+		PCI_VDEVICE(ATI, 0x4399),
 		.driver_data = (unsigned long)ohci_quirk_amd700,
 	},
 


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
  2015-10-04 20:50 ` [PATCH 1/8] ehci-pci: " Sergei Shtylyov
  2015-10-04 20:52 ` [PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() " Sergei Shtylyov
@ 2015-10-04 20:55 ` Sergei Shtylyov
  2015-10-04 21:00 ` [PATCH 4/8] dwc2: pci: " Sergei Shtylyov
                   ` (4 subsequent siblings)
  7 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 20:55 UTC (permalink / raw)
  To: gregkh, linux-usb, Peter.Chen; +Cc: linux-kernel

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/chipidea/ci_hdrc_pci.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Index: usb/drivers/usb/chipidea/ci_hdrc_pci.c
===================================================================
--- usb.orig/drivers/usb/chipidea/ci_hdrc_pci.c
+++ usb/drivers/usb/chipidea/ci_hdrc_pci.c
@@ -142,16 +142,16 @@ static const struct pci_device_id ci_hdr
 		.driver_data = (kernel_ulong_t)&pci_platdata,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0811),
+		PCI_VDEVICE(INTEL, 0x0811),
 		.driver_data = (kernel_ulong_t)&langwell_pci_platdata,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0x0829),
+		PCI_VDEVICE(INTEL, 0x0829),
 		.driver_data = (kernel_ulong_t)&penwell_pci_platdata,
 	},
 	{
 		/* Intel Clovertrail */
-		PCI_DEVICE(PCI_VENDOR_ID_INTEL, 0xe006),
+		PCI_VDEVICE(INTEL, 0xe006),
 		.driver_data = (kernel_ulong_t)&penwell_pci_platdata,
 	},
 	{ 0 } /* end: all zeroes */


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
                   ` (2 preceding siblings ...)
  2015-10-04 20:55 ` [PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() " Sergei Shtylyov
@ 2015-10-04 21:00 ` Sergei Shtylyov
  2015-10-04 21:02 ` [PATCH 5/8] dwc3-pci: " Sergei Shtylyov
                   ` (3 subsequent siblings)
  7 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 21:00 UTC (permalink / raw)
  To: gregkh, linux-usb, johnyoun; +Cc: linux-kernel

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/dwc2/pci.c |    5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Index: usb/drivers/usb/dwc2/pci.c
===================================================================
--- usb.orig/drivers/usb/dwc2/pci.c
+++ usb/drivers/usb/dwc2/pci.c
@@ -145,11 +145,10 @@ err:
 
 static const struct pci_device_id dwc2_pci_ids[] = {
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_SYNOPSYS, PCI_PRODUCT_ID_HAPS_HSOTG),
+		PCI_VDEVICE(SYNOPSYS, PCI_PRODUCT_ID_HAPS_HSOTG),
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_STMICRO,
-			   PCI_DEVICE_ID_STMICRO_USB_OTG),
+		PCI_VDEVICE(STMICRO, PCI_DEVICE_ID_STMICRO_USB_OTG),
 	},
 	{ /* end: all zeroes */ }
 };


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
                   ` (3 preceding siblings ...)
  2015-10-04 21:00 ` [PATCH 4/8] dwc2: pci: " Sergei Shtylyov
@ 2015-10-04 21:02 ` Sergei Shtylyov
  2015-10-04 21:04 ` [PATCH 6/8] amd5536udc: " Sergei Shtylyov
                   ` (2 subsequent siblings)
  7 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 21:02 UTC (permalink / raw)
  To: gregkh, linux-usb, balbi; +Cc: linux-kernel, linux-omap

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/dwc3/dwc3-pci.c |   17 +++++++----------
 1 file changed, 7 insertions(+), 10 deletions(-)

Index: usb/drivers/usb/dwc3/dwc3-pci.c
===================================================================
--- usb.orig/drivers/usb/dwc3/dwc3-pci.c
+++ usb/drivers/usb/dwc3/dwc3-pci.c
@@ -174,16 +174,13 @@ static void dwc3_pci_remove(struct pci_d
 }
 
 static const struct pci_device_id dwc3_pci_id_table[] = {
-	{
-		PCI_DEVICE(PCI_VENDOR_ID_SYNOPSYS,
-				PCI_DEVICE_ID_SYNOPSYS_HAPSUSB3),
-	},
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_BSW), },
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_BYT), },
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_MRFLD), },
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_SPTLP), },
-	{ PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_SPTH), },
-	{ PCI_DEVICE(PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_NL_USB), },
+	{ PCI_VDEVICE(SYNOPSYS, PCI_DEVICE_ID_SYNOPSYS_HAPSUSB3), },
+	{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_BSW), },
+	{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_BYT), },
+	{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_MRFLD), },
+	{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_SPTLP), },
+	{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_SPTH), },
+	{ PCI_VDEVICE(AMD, PCI_DEVICE_ID_AMD_NL_USB), },
 	{  }	/* Terminating Entry */
 };
 MODULE_DEVICE_TABLE(pci, dwc3_pci_id_table);


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
                   ` (4 preceding siblings ...)
  2015-10-04 21:02 ` [PATCH 5/8] dwc3-pci: " Sergei Shtylyov
@ 2015-10-04 21:04 ` Sergei Shtylyov
  2015-10-04 21:07 ` [PATCH 7/8] pch_udc: " Sergei Shtylyov
  2015-10-04 21:08 ` [PATCH 8/8] bdc_pci: " Sergei Shtylyov
  7 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 21:04 UTC (permalink / raw)
  To: gregkh, linux-usb, balbi; +Cc: linux-kernel, linux-geode

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/gadget/udc/amd5536udc.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Index: usb/drivers/usb/gadget/udc/amd5536udc.c
===================================================================
--- usb.orig/drivers/usb/gadget/udc/amd5536udc.c
+++ usb/drivers/usb/gadget/udc/amd5536udc.c
@@ -3405,7 +3405,7 @@ static int udc_remote_wakeup(struct udc
 /* PCI device parameters */
 static const struct pci_device_id pci_id[] = {
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_AMD, 0x2096),
+		PCI_VDEVICE(AMD, 0x2096),
 		.class =	(PCI_CLASS_SERIAL_USB << 8) | 0xfe,
 		.class_mask =	0xffffffff,
 	},


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
                   ` (5 preceding siblings ...)
  2015-10-04 21:04 ` [PATCH 6/8] amd5536udc: " Sergei Shtylyov
@ 2015-10-04 21:07 ` Sergei Shtylyov
  2015-10-04 21:08 ` [PATCH 8/8] bdc_pci: " Sergei Shtylyov
  7 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 21:07 UTC (permalink / raw)
  To: gregkh, linux-usb, balbi; +Cc: linux-kernel

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/gadget/udc/pch_udc.c |    9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

Index: usb/drivers/usb/gadget/udc/pch_udc.c
===================================================================
--- usb.orig/drivers/usb/gadget/udc/pch_udc.c
+++ usb/drivers/usb/gadget/udc/pch_udc.c
@@ -3232,23 +3232,22 @@ finished:
 
 static const struct pci_device_id pch_udc_pcidev_id[] = {
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_INTEL,
-			   PCI_DEVICE_ID_INTEL_QUARK_X1000_UDC),
+		PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_QUARK_X1000_UDC),
 		.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
 		.class_mask = 0xffffffff,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_INTEL_EG20T_UDC),
+		PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_EG20T_UDC),
 		.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
 		.class_mask = 0xffffffff,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_ROHM, PCI_DEVICE_ID_ML7213_IOH_UDC),
+		PCI_VDEVICE(ROHM, PCI_DEVICE_ID_ML7213_IOH_UDC),
 		.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
 		.class_mask = 0xffffffff,
 	},
 	{
-		PCI_DEVICE(PCI_VENDOR_ID_ROHM, PCI_DEVICE_ID_ML7831_IOH_UDC),
+		PCI_VDEVICE(ROHM, PCI_DEVICE_ID_ML7831_IOH_UDC),
 		.class = (PCI_CLASS_SERIAL_USB << 8) | 0xfe,
 		.class_mask = 0xffffffff,
 	},


^ permalink raw reply	[flat|nested] 11+ messages in thread

* [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
                   ` (6 preceding siblings ...)
  2015-10-04 21:07 ` [PATCH 7/8] pch_udc: " Sergei Shtylyov
@ 2015-10-04 21:08 ` Sergei Shtylyov
  2015-10-05  3:16   ` Greg KH
  7 siblings, 1 reply; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-04 21:08 UTC (permalink / raw)
  To: gregkh, linux-usb, balbi; +Cc: linux-kernel

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>

---
 drivers/usb/gadget/udc/bdc/bdc_pci.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Index: usb/drivers/usb/gadget/udc/bdc/bdc_pci.c
===================================================================
--- usb.orig/drivers/usb/gadget/udc/bdc/bdc_pci.c
+++ usb/drivers/usb/gadget/udc/bdc/bdc_pci.c
@@ -113,7 +113,7 @@ static void bdc_pci_remove(struct pci_de
 }
 
 static struct pci_device_id bdc_pci_id_table[] = {
-	{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, BDC_PCI_PID), },
+	{ PCI_VDEVICE(BROADCOM, BDC_PCI_PID), },
 	{} /* Terminating Entry */
 };
 


^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-04 21:08 ` [PATCH 8/8] bdc_pci: " Sergei Shtylyov
@ 2015-10-05  3:16   ` Greg KH
  2015-10-05 13:13     ` Sergei Shtylyov
  0 siblings, 1 reply; 11+ messages in thread
From: Greg KH @ 2015-10-05  3:16 UTC (permalink / raw)
  To: Sergei Shtylyov; +Cc: linux-usb, balbi, linux-kernel

On Mon, Oct 05, 2015 at 12:08:26AM +0300, Sergei Shtylyov wrote:
> Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Why?  I hate PCI_VDEVICE(), it's impossible to grep for things and does
not help with readability and is pointless.  My one wish was that when I
was the PCI maintainer I would have just deleted the thing from the
kernel entirely instead of leaving it there hoping no one would use it.

I don't like these types of pointless patches, sorry.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()
  2015-10-05  3:16   ` Greg KH
@ 2015-10-05 13:13     ` Sergei Shtylyov
  0 siblings, 0 replies; 11+ messages in thread
From: Sergei Shtylyov @ 2015-10-05 13:13 UTC (permalink / raw)
  To: Greg KH; +Cc: linux-usb, balbi, linux-kernel

Hello.

On 10/5/2015 6:16 AM, Greg KH wrote:

>> Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

> Why?

    Seemed a good idea to me back in March. :-)

> I hate PCI_VDEVICE(), it's impossible to grep for things and does

    Didn't think about grepping...

> not help with readability and is pointless.  My one wish was that when I
> was the PCI maintainer I would have just deleted the thing from the
> kernel entirely instead of leaving it there hoping no one would use it.

    Thanks for the idea. :-)

> I don't like these types of pointless patches, sorry.

    I hope you don't have the same strong feelings about PCI_DEVICE_SUB().
There's one place (in ohci-pci.c IIRC) it can be used...

> thanks,
>
> greg k-h

MBR, Sergei


^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2015-10-05 13:13 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-10-04 20:38 [PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE() Sergei Shtylyov
2015-10-04 20:50 ` [PATCH 1/8] ehci-pci: " Sergei Shtylyov
2015-10-04 20:52 ` [PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() " Sergei Shtylyov
2015-10-04 20:55 ` [PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() " Sergei Shtylyov
2015-10-04 21:00 ` [PATCH 4/8] dwc2: pci: " Sergei Shtylyov
2015-10-04 21:02 ` [PATCH 5/8] dwc3-pci: " Sergei Shtylyov
2015-10-04 21:04 ` [PATCH 6/8] amd5536udc: " Sergei Shtylyov
2015-10-04 21:07 ` [PATCH 7/8] pch_udc: " Sergei Shtylyov
2015-10-04 21:08 ` [PATCH 8/8] bdc_pci: " Sergei Shtylyov
2015-10-05  3:16   ` Greg KH
2015-10-05 13:13     ` Sergei Shtylyov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.