All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH nf-next] netfilter: xt_TCPMSS: Refactor the codes to decrease one condition check and more readable
@ 2016-09-07  2:40 fgao
  2016-09-24 19:14 ` Pablo Neira Ayuso
  0 siblings, 1 reply; 2+ messages in thread
From: fgao @ 2016-09-07  2:40 UTC (permalink / raw)
  To: pablo, netfilter-devel, coreteam; +Cc: gfree.wind, Gao Feng

From: Gao Feng <fgao@ikuai8.com>

The origin codes perform two condition checks with dst_mtu(skb_dst(skb))
and in_mtu. And the last statement is "min(dst_mtu(skb_dst(skb)),
in_mtu) - minlen". It may let reader think about how about the result.
Would it be negative.

Now assign the result of min(dst_mtu(skb_dst(skb)), in_mtu) to a new
variable, then only perform one condition check, and it is more readable.

Signed-off-by: Gao Feng <fgao@ikuai8.com>
---
 net/netfilter/xt_TCPMSS.c | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)

diff --git a/net/netfilter/xt_TCPMSS.c b/net/netfilter/xt_TCPMSS.c
index e118397..872db2d 100644
--- a/net/netfilter/xt_TCPMSS.c
+++ b/net/netfilter/xt_TCPMSS.c
@@ -110,18 +110,14 @@ tcpmss_mangle_packet(struct sk_buff *skb,
 	if (info->mss == XT_TCPMSS_CLAMP_PMTU) {
 		struct net *net = par->net;
 		unsigned int in_mtu = tcpmss_reverse_mtu(net, skb, family);
+		unsigned int min_mtu = min(dst_mtu(skb_dst(skb)), in_mtu);
 
-		if (dst_mtu(skb_dst(skb)) <= minlen) {
+		if (min_mtu <= minlen) {
 			net_err_ratelimited("unknown or invalid path-MTU (%u)\n",
-					    dst_mtu(skb_dst(skb)));
+					    min_mtu);
 			return -1;
 		}
-		if (in_mtu <= minlen) {
-			net_err_ratelimited("unknown or invalid path-MTU (%u)\n",
-					    in_mtu);
-			return -1;
-		}
-		newmss = min(dst_mtu(skb_dst(skb)), in_mtu) - minlen;
+		newmss = min_mtu - minlen;
 	} else
 		newmss = info->mss;
 
-- 
1.9.1



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH nf-next] netfilter: xt_TCPMSS: Refactor the codes to decrease one condition check and more readable
  2016-09-07  2:40 [PATCH nf-next] netfilter: xt_TCPMSS: Refactor the codes to decrease one condition check and more readable fgao
@ 2016-09-24 19:14 ` Pablo Neira Ayuso
  0 siblings, 0 replies; 2+ messages in thread
From: Pablo Neira Ayuso @ 2016-09-24 19:14 UTC (permalink / raw)
  To: fgao; +Cc: netfilter-devel, coreteam, gfree.wind

On Wed, Sep 07, 2016 at 10:40:24AM +0800, fgao@ikuai8.com wrote:
> From: Gao Feng <fgao@ikuai8.com>
> 
> The origin codes perform two condition checks with dst_mtu(skb_dst(skb))
> and in_mtu. And the last statement is "min(dst_mtu(skb_dst(skb)),
> in_mtu) - minlen". It may let reader think about how about the result.
> Would it be negative.
> 
> Now assign the result of min(dst_mtu(skb_dst(skb)), in_mtu) to a new
> variable, then only perform one condition check, and it is more readable.

Applied, thanks.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2016-09-24 19:14 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-09-07  2:40 [PATCH nf-next] netfilter: xt_TCPMSS: Refactor the codes to decrease one condition check and more readable fgao
2016-09-24 19:14 ` Pablo Neira Ayuso

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.