All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v4 00/12] qla2xxx: Feature updates for target.
@ 2017-01-20  6:27 Himanshu Madhani
  2017-01-20  6:27 ` [PATCH v4 01/12] qla2xxx: Remove direct access of scsi_status field in se_cmd Himanshu Madhani
                   ` (13 more replies)
  0 siblings, 14 replies; 16+ messages in thread
From: Himanshu Madhani @ 2017-01-20  6:27 UTC (permalink / raw)
  To: target-devel, bart.vanassche, hch, nab
  Cc: giridhar.malavali, linux-scsi, himanshu.madhani

Hi Bart,

Please consider this updated series for inclusion in target-pending.

Changes from v3 --> v4

o Fixed warnings reported by smatch tool.
o Fixed indentatation warnings reported by smatch tool.

Changes from v2 --> v3

o Cleaned up sparse warnings reported by you.

Changes from v1 --> v2

o Updated review comments and added Reviewed-by tags for necessary patches.
o We left the one particular review comment to add helper routine to
  be addressed at later time in the follow up bug fixes pathes which we
  will be sending in few weeks.
o Added patch to simplify SRB usage in driver.
o Cleaned up warnings reported by sparse option w=1.

Please apply to target-pending.

Thanks,
Himanshu 

Himanshu Madhani (2):
  qla2xxx: Remove SRR code.
  qla2xxx: Remove unused reverse_ini_mode.

Joe Carnuccio (1):
  qla2xxx: Simplify usage of SRB structure in driver.

Quinn Tran (9):
  qla2xxx: Remove direct access of scsi_status field in se_cmd
  qla2xxx: Cleanup TMF code translation from qla_target.
  qla2xxx: Make trace flags more readable.
  qla2xxx: Fix wrong argument in sp done callback.
  qla2xxx: Use d_id instead of s_id for more clarity.
  qla2xxx: Track I-T nexus as single fc_port struct.
  qla2xxx: Add framework for Async fabric discovery.
  qla2xxx: Add Dual mode support in the driver
  qla2xxx: Improve RSCN handling in driver

 drivers/scsi/qla2xxx/qla_attr.c    |    3 +
 drivers/scsi/qla2xxx/qla_bsg.c     |   23 +-
 drivers/scsi/qla2xxx/qla_def.h     |  306 ++++-
 drivers/scsi/qla2xxx/qla_dfs.c     |   11 +-
 drivers/scsi/qla2xxx/qla_fw.h      |  106 +-
 drivers/scsi/qla2xxx/qla_gbl.h     |   72 +-
 drivers/scsi/qla2xxx/qla_gs.c      |  726 +++++++++--
 drivers/scsi/qla2xxx/qla_init.c    | 1612 ++++++++++++++++++------
 drivers/scsi/qla2xxx/qla_inline.h  |   18 +-
 drivers/scsi/qla2xxx/qla_iocb.c    |  167 ++-
 drivers/scsi/qla2xxx/qla_isr.c     |  317 +++--
 drivers/scsi/qla2xxx/qla_mbx.c     |  232 ++--
 drivers/scsi/qla2xxx/qla_mr.c      |   48 +-
 drivers/scsi/qla2xxx/qla_os.c      |  330 +++--
 drivers/scsi/qla2xxx/qla_target.c  | 2392 +++++++++++++++++-------------------
 drivers/scsi/qla2xxx/qla_target.h  |  252 +---
 drivers/scsi/qla2xxx/tcm_qla2xxx.c |  256 ++--
 drivers/scsi/qla2xxx/tcm_qla2xxx.h |    4 +-
 18 files changed, 4324 insertions(+), 2551 deletions(-)

-- 
1.8.3.1


^ permalink raw reply	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2017-01-24 18:32 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-01-20  6:27 [PATCH v4 00/12] qla2xxx: Feature updates for target Himanshu Madhani
2017-01-20  6:27 ` [PATCH v4 01/12] qla2xxx: Remove direct access of scsi_status field in se_cmd Himanshu Madhani
2017-01-20  6:27 ` [PATCH v4 02/12] qla2xxx: Cleanup TMF code translation from qla_target Himanshu Madhani
2017-01-20  6:27 ` [PATCH v4 03/12] qla2xxx: Make trace flags more readable Himanshu Madhani
2017-01-20  6:27 ` [PATCH v4 04/12] qla2xxx: Remove SRR code Himanshu Madhani
2017-01-20  6:27 ` [PATCH v4 05/12] qla2xxx: Fix wrong argument in sp done callback Himanshu Madhani
2017-01-20  6:27 ` [PATCH v4 06/12] qla2xxx: Use d_id instead of s_id for more clarity Himanshu Madhani
2017-01-20  6:27 ` [PATCH v4 07/12] qla2xxx: Track I-T nexus as single fc_port struct Himanshu Madhani
2017-01-20  6:28 ` [PATCH v4 08/12] qla2xxx: Add framework for Async fabric discovery Himanshu Madhani
2017-01-20  6:28 ` [PATCH v4 09/12] qla2xxx: Add Dual mode support in the driver Himanshu Madhani
2017-01-20  6:28 ` [PATCH v4 10/12] qla2xxx: Remove unused reverse_ini_mode Himanshu Madhani
2017-01-20  6:28 ` [PATCH v4 11/12] qla2xxx: Improve RSCN handling in driver Himanshu Madhani
2017-01-20  6:28 ` [PATCH v4 12/12] qla2xxx: Simplify usage of SRB structure " Himanshu Madhani
2017-01-20 22:09 ` [PATCH v4 00/12] qla2xxx: Feature updates for target Bart Van Assche
2017-01-24 17:24 ` Bart Van Assche
2017-01-24 18:32   ` Madhani, Himanshu

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.