All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/19] staging: ks7010: refactor host interface
@ 2017-04-26  0:55 Tobin C. Harding
  2017-04-26  0:55 ` [PATCH 01/19] staging: ks7010: rename constant SLP_SLEEP to SLP_ASLEEP Tobin C. Harding
                   ` (19 more replies)
  0 siblings, 20 replies; 23+ messages in thread
From: Tobin C. Harding @ 2017-04-26  0:55 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: Wolfram Sang, driverdev-devel

This is an attempt to improve the readability of the host interface
code, and ease future development. Refactoring only, no changes to the
functionality of the code.

Patch 01 renames a constant to use adjective instead of noun.

Patch 02 removes redundant code.

Patch 03 removes unused local variable.

Patch 04 moves null check closer to memory allocation.

Patch 05 removes magic numbers.

Patch 06 removes duplicate code.

Patch 07 refactors call to kmalloc(), uses local variable to separate
expression, calculating size of allocation, from call to kmalloc().

Patch 08 adds a helper function to reduce code duplication.

Patch 09 abstracts connection status flag access.

Patch 10 adds enumeration type 'sleep_mode_type' instead of preprocessor defines.

Patch 11 fixes checkpatch warning, multiple new lines.

Patch 12 makes uniform the abbreviation used for 'management' when
naming identifiers.

Patch 13 removes unnecessary void * cast from calls to netdev_priv().

Patch 14 inverts 'if' statement conditional, adding 'continue'
statement to continue loop. Reduces indentation of subsequent code.

Patch 15 cleans up macro definition, removes commented out code and
braces. This macro causes two checkpatch checks to be emitted
(MACRO_ARG_REUSE, MACRO_ARG_PRECEDENCE), please review carefully.

Patch 16 adds enumeration type 'multi_cast_filter_type' instead of preprocessor defines.

Patch 17 fixes/adds enumeration tags.

Patch 18 renames header and source files 'ks_hostif' to 'hostif'.

Patch 19 renames header and source files 'ks7010_sdio' to 'sdio'.

Patch series was created using `git format-patch -M ...`

Series is untested, builds on x86_64 and PowerPC.

Tobin C. Harding (19):
  staging: ks7010: rename constant SLP_SLEEP to SLP_ASLEEP
  staging: ks7010: remove unnecessary address check
  staging: ks7010: remove unused local variable eap_key
  staging: ks7010: move skb null check near allocation
  staging: ks7010: remove magic numbers
  staging: ks7010: remove duplicate code
  staging: ks7010: clean memory allocation
  staging: ks7010: add hostif_generic_request()
  staging: ks7010: abstract connection status
  staging: ks7010: add enum sleep_mode_type
  staging: ks7010: fix checkpatch LINE_SPACING
  staging: ks7010: make abbreviation mgmt uniform
  staging: ks7010: remove cast from netdev_priv()
  staging: ks7010: continue from loop on unmatched mac
  staging: ks7010: clean up macro ps_confirm_wait_inc
  staging: ks7010: add enum multicast_filter_type
  staging: ks7010: fix enumeration tags
  staging: ks7010: rename ks_hostif to hostif
  staging: ks7010: rename ks_hostif to hostif

 drivers/staging/ks7010/Makefile                  |   2 +-
 drivers/staging/ks7010/eap_packet.h              |   2 +
 drivers/staging/ks7010/{ks_hostif.c => hostif.c} | 366 +++++++++------------
 drivers/staging/ks7010/{ks_hostif.h => hostif.h} |  43 +--
 drivers/staging/ks7010/ks_wlan.h                 |   6 +-
 drivers/staging/ks7010/ks_wlan_net.c             | 388 ++++++++++-------------
 drivers/staging/ks7010/{ks7010_sdio.c => sdio.c} |  12 +-
 drivers/staging/ks7010/{ks7010_sdio.h => sdio.h} |   0
 8 files changed, 358 insertions(+), 461 deletions(-)
 rename drivers/staging/ks7010/{ks_hostif.c => hostif.c} (89%)
 rename drivers/staging/ks7010/{ks_hostif.h => hostif.h} (97%)
 rename drivers/staging/ks7010/{ks7010_sdio.c => sdio.c} (99%)
 rename drivers/staging/ks7010/{ks7010_sdio.h => sdio.h} (100%)

-- 
2.7.4

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply	[flat|nested] 23+ messages in thread

end of thread, other threads:[~2017-04-27  0:28 UTC | newest]

Thread overview: 23+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-04-26  0:55 [PATCH 00/19] staging: ks7010: refactor host interface Tobin C. Harding
2017-04-26  0:55 ` [PATCH 01/19] staging: ks7010: rename constant SLP_SLEEP to SLP_ASLEEP Tobin C. Harding
2017-04-26  0:55 ` [PATCH 02/19] staging: ks7010: remove unnecessary address check Tobin C. Harding
2017-04-26  0:55 ` [PATCH 03/19] staging: ks7010: remove unused local variable eap_key Tobin C. Harding
2017-04-26  0:55 ` [PATCH 04/19] staging: ks7010: move skb null check near allocation Tobin C. Harding
2017-04-26  0:55 ` [PATCH 05/19] staging: ks7010: remove magic numbers Tobin C. Harding
2017-04-26  0:55 ` [PATCH 06/19] staging: ks7010: remove duplicate code Tobin C. Harding
2017-04-26  0:55 ` [PATCH 07/19] staging: ks7010: clean memory allocation Tobin C. Harding
2017-04-26  0:55 ` [PATCH 08/19] staging: ks7010: add hostif_generic_request() Tobin C. Harding
2017-04-26  0:55 ` [PATCH 09/19] staging: ks7010: abstract connection status Tobin C. Harding
2017-04-26  0:55 ` [PATCH 10/19] staging: ks7010: add enum sleep_mode_type Tobin C. Harding
2017-04-26  0:55 ` [PATCH 11/19] staging: ks7010: fix checkpatch LINE_SPACING Tobin C. Harding
2017-04-26  0:55 ` [PATCH 12/19] staging: ks7010: make abbreviation mgmt uniform Tobin C. Harding
2017-04-26  0:55 ` [PATCH 13/19] staging: ks7010: remove cast from netdev_priv() Tobin C. Harding
2017-04-26  0:55 ` [PATCH 14/19] staging: ks7010: continue from loop on unmatched mac Tobin C. Harding
2017-04-26  0:55 ` [PATCH 15/19] staging: ks7010: clean up macro ps_confirm_wait_inc Tobin C. Harding
2017-04-26  0:55 ` [PATCH 16/19] staging: ks7010: add enum multicast_filter_type Tobin C. Harding
2017-04-26  0:55 ` [PATCH 17/19] staging: ks7010: fix enumeration tags Tobin C. Harding
2017-04-26  0:55 ` [PATCH 18/19] staging: ks7010: rename ks_hostif to hostif Tobin C. Harding
2017-04-27  0:21   ` Tobin C. Harding
2017-04-26  0:55 ` [PATCH 19/19] " Tobin C. Harding
2017-04-27  0:22   ` Tobin C. Harding
2017-04-27  0:28 ` [PATCH 00/19] staging: ks7010: refactor host interface Tobin C. Harding

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.