All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH] hw/ppc/spapr: Adjust firmware name for PCI bridges
@ 2017-06-07  8:20 Thomas Huth
  2017-06-08  4:14 ` David Gibson
  0 siblings, 1 reply; 2+ messages in thread
From: Thomas Huth @ 2017-06-07  8:20 UTC (permalink / raw)
  To: qemu-ppc, qemu-devel, David Gibson; +Cc: Alexander Graf, abologna

SLOF uses "pci" as name for PCI bridges nodes in the device tree instead
of "pci-bridges", so booting via bootindex from a device behind a PCI
bridge currently does not work since QEMU passes the wrong name in the
"qemu,boot-list" property. Fix it by changing the name of the PCI bridge
nodes to "pci" instead.

Buglink: https://bugzilla.redhat.com/show_bug.cgi?id=1459170
Signed-off-by: Thomas Huth <thuth@redhat.com>
---
 hw/ppc/spapr.c | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/hw/ppc/spapr.c b/hw/ppc/spapr.c
index 91b4057..27b1f3c 100644
--- a/hw/ppc/spapr.c
+++ b/hw/ppc/spapr.c
@@ -2441,6 +2441,12 @@ static char *spapr_get_fw_dev_path(FWPathProvider *p, BusState *bus,
         return g_strdup_printf("disk@%"PRIX64, (uint64_t)id << 32);
     }
 
+    if (g_str_equal("pci-bridge", qdev_fw_name(dev))) {
+        /* SLOF uses "pci" instead of "pci-bridge" for PCI bridges */
+        PCIDevice *pcidev = CAST(PCIDevice, dev, TYPE_PCI_DEVICE);
+        return g_strdup_printf("pci@%x", PCI_SLOT(pcidev->devfn));
+    }
+
     return NULL;
 }
 
-- 
1.8.3.1

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [Qemu-devel] [PATCH] hw/ppc/spapr: Adjust firmware name for PCI bridges
  2017-06-07  8:20 [Qemu-devel] [PATCH] hw/ppc/spapr: Adjust firmware name for PCI bridges Thomas Huth
@ 2017-06-08  4:14 ` David Gibson
  0 siblings, 0 replies; 2+ messages in thread
From: David Gibson @ 2017-06-08  4:14 UTC (permalink / raw)
  To: Thomas Huth; +Cc: qemu-ppc, qemu-devel, Alexander Graf, abologna

[-- Attachment #1: Type: text/plain, Size: 1442 bytes --]

On Wed, Jun 07, 2017 at 10:20:27AM +0200, Thomas Huth wrote:
> SLOF uses "pci" as name for PCI bridges nodes in the device tree instead
> of "pci-bridges", so booting via bootindex from a device behind a PCI
> bridge currently does not work since QEMU passes the wrong name in the
> "qemu,boot-list" property. Fix it by changing the name of the PCI bridge
> nodes to "pci" instead.
> 
> Buglink: https://bugzilla.redhat.com/show_bug.cgi?id=1459170
> Signed-off-by: Thomas Huth <thuth@redhat.com>

Applied to ppc-for-2.10.

> ---
>  hw/ppc/spapr.c | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/hw/ppc/spapr.c b/hw/ppc/spapr.c
> index 91b4057..27b1f3c 100644
> --- a/hw/ppc/spapr.c
> +++ b/hw/ppc/spapr.c
> @@ -2441,6 +2441,12 @@ static char *spapr_get_fw_dev_path(FWPathProvider *p, BusState *bus,
>          return g_strdup_printf("disk@%"PRIX64, (uint64_t)id << 32);
>      }
>  
> +    if (g_str_equal("pci-bridge", qdev_fw_name(dev))) {
> +        /* SLOF uses "pci" instead of "pci-bridge" for PCI bridges */
> +        PCIDevice *pcidev = CAST(PCIDevice, dev, TYPE_PCI_DEVICE);
> +        return g_strdup_printf("pci@%x", PCI_SLOT(pcidev->devfn));
> +    }
> +
>      return NULL;
>  }
>  

-- 
David Gibson			| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au	| minimalist, thank you.  NOT _the_ _other_
				| _way_ _around_!
http://www.ozlabs.org/~dgibson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2017-06-08  4:29 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-06-07  8:20 [Qemu-devel] [PATCH] hw/ppc/spapr: Adjust firmware name for PCI bridges Thomas Huth
2017-06-08  4:14 ` David Gibson

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.