All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chris Wilson <chris@chris-wilson.co.uk>
To: Mika Kuoppala <mika.kuoppala@linux.intel.com>,
	intel-gfx@lists.freedesktop.org
Cc: Mika@freedesktop.org
Subject: Re: [PATCH 1/2] drm/i915: Introduce execlist_port_* accessors
Date: Thu, 02 Nov 2017 15:03:31 +0000	[thread overview]
Message-ID: <150963501181.6111.10657282814200657443@mail.alporthouse.com> (raw)
In-Reply-To: <20171102143238.4829-1-mika.kuoppala@linux.intel.com>

Quoting Mika Kuoppala (2017-11-02 14:32:38)
> From: Mika Kuoppala <mika.kuoppala@intel.com>
> 
> Instead of trusting that first available port is at index 0,
> use accessor to hide this. This is a preparation for a
> following patches where head can be at arbitrary location
> in the port array.
> 
> v2: improved commit message, elsp_ready readability (Chris)
> v3: s/execlist_port_index/execlist_port (Chris)
> v4: rebase to new naming
> v5: fix port_next indexing
> v6: adapt to preempt
> v7: improved _port_next (Chris)
> 
> Cc: Michał Winiarski <michal.winiarski@intel.com>
> Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
> Cc: Chris Wilson <chris@chris-wilson.co.uk>
> Signed-off-by: Mika Kuoppala <mika.kuoppala@linux.intel.com>
> ---
>  drivers/gpu/drm/i915/i915_gpu_error.c      |  6 ++--
>  drivers/gpu/drm/i915/i915_guc_submission.c | 50 ++++++++++++++++++------------
>  drivers/gpu/drm/i915/intel_engine_cs.c     | 18 ++++++-----
>  drivers/gpu/drm/i915/intel_lrc.c           | 49 ++++++++++++++++++-----------
>  drivers/gpu/drm/i915/intel_ringbuffer.h    | 44 ++++++++++++++++++++++++--
>  5 files changed, 119 insertions(+), 48 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/i915_gpu_error.c b/drivers/gpu/drm/i915/i915_gpu_error.c
> index 653fb69e7ecb..6d0bdb03b3f0 100644
> --- a/drivers/gpu/drm/i915/i915_gpu_error.c
> +++ b/drivers/gpu/drm/i915/i915_gpu_error.c
> @@ -1333,11 +1333,13 @@ static void engine_record_requests(struct intel_engine_cs *engine,
>  static void error_record_engine_execlists(struct intel_engine_cs *engine,
>                                           struct drm_i915_error_engine *ee)
>  {
> -       const struct intel_engine_execlists * const execlists = &engine->execlists;
> +       struct intel_engine_execlists * const execlists = &engine->execlists;
>         unsigned int n;
>  
>         for (n = 0; n < execlists_num_ports(execlists); n++) {
> -               struct drm_i915_gem_request *rq = port_request(&execlists->port[n]);
> +               struct drm_i915_gem_request *rq;
> +
> +               rq = port_request(execlists_port(execlists, n));
>  
This newline isn't as interesting as the others. No one will shed a tear
if it is removed.

>                 if (!rq)
>                         break;

> @@ -665,7 +670,8 @@ static void execlists_dequeue(struct intel_engine_cs *engine)
>  
>                                 if (submit)
>                                         port_assign(port, last);
> -                               port++;
> +
> +                               port = execlists_port_next(execlists, port);
>  

Spare us this newline as well. Let's have the advance and BUG() tightly
coupled.

>                                 GEM_BUG_ON(port_isset(port));
>                         }
> @@ -699,8 +705,10 @@ static void execlists_dequeue(struct intel_engine_cs *engine)
>  void
>  execlists_cancel_port_requests(struct intel_engine_execlists * const execlists)
>  {
> -       struct execlist_port *port = execlists->port;
>         unsigned int num_ports = execlists_num_ports(execlists);
> +       struct execlist_port *port;
> +
> +       port = execlists_port_head(execlists);
>  
>         while (num_ports-- && port_isset(port)) {

	for (port = execlists_port_head(execlists);
	     num_ports-- && port_isset(port);
	     port = execlists_head_complete(execlists, port)) {

Might as well complete the transformation to more normal code ;)

> +static inline struct execlist_port *
> +execlists_head_complete(struct intel_engine_execlists * const execlists,
>                         struct execlist_port * const port)
>  {
>         const unsigned int m = execlists->port_mask;
> @@ -580,6 +618,8 @@ execlists_port_complete(struct intel_engine_execlists * const execlists,
>  
>         memmove(port, port + 1, m * sizeof(struct execlist_port));
>         memset(port + m, 0, sizeof(struct execlist_port));
> +
> +       return execlists_port_head(execlists);

Hang on a sec, isn't port->head itself meant to advance here? Oh,
that'll be the next patch and this is just prep.

Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
-Chris
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2017-11-02 15:03 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-10-31 15:27 [PATCH 1/2] drm/i915: Introduce execlist_port_* accessors Mika Kuoppala
2017-10-31 15:27 ` [PATCH 2/2] drm/i915: Move execlists port head instead of memmoving array Mika Kuoppala
2017-10-31 15:42   ` Chris Wilson
2017-11-02 15:07   ` Chris Wilson
2017-11-22 13:52     ` Mika Kuoppala
2017-11-22 13:57       ` Chris Wilson
2017-10-31 15:41 ` [PATCH 1/2] drm/i915: Introduce execlist_port_* accessors Chris Wilson
2017-10-31 15:56   ` Chris Wilson
2017-11-02 10:38   ` Mika Kuoppala
2017-11-02 10:57     ` Chris Wilson
2017-11-02 14:14       ` Mika Kuoppala
2017-11-02 14:15         ` Mika Kuoppala
2017-10-31 15:51 ` ✗ Fi.CI.BAT: failure for series starting with [1/2] " Patchwork
2017-11-02 14:32 ` [PATCH 1/2] " Mika Kuoppala
2017-11-02 15:03   ` Chris Wilson [this message]
  -- strict thread matches above, loose matches on Subject: below --
2017-11-30  9:10 [PATCH 0/2] execlist port handling improvements Mika Kuoppala
2017-11-30  9:10 ` [PATCH 1/2] drm/i915: Introduce execlist_port_* accessors Mika Kuoppala
2017-11-30 10:21   ` Chris Wilson
2017-10-19 14:39 Mika Kuoppala
2017-10-19 14:48 ` Chris Wilson
2017-10-20 12:00   ` Mika Kuoppala
2017-10-19 14:50 ` Chris Wilson
2017-10-20 10:34 ` Joonas Lahtinen
2017-10-20 11:12   ` Mika Kuoppala
2017-10-20 11:26     ` Chris Wilson
2017-10-20 12:53     ` Mika Kuoppala

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=150963501181.6111.10657282814200657443@mail.alporthouse.com \
    --to=chris@chris-wilson.co.uk \
    --cc=Mika@freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=mika.kuoppala@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.