All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 00/11] staging: mt7621-gpio: use mediatek as binding instead of custom mtk
@ 2018-05-16  5:29 Sergio Paracuellos
  2018-05-16  5:29 ` [PATCH v2 01/11] staging: mt7621-gpio: dt-bindings: add documentation for mt7621-gpio Sergio Paracuellos
                   ` (10 more replies)
  0 siblings, 11 replies; 16+ messages in thread
From: Sergio Paracuellos @ 2018-05-16  5:29 UTC (permalink / raw)
  To: gregkh; +Cc: neil, driverdev-devel

The following series updated mt7621-gpio driver to use 'mediatek'
which is already defined in kernel bindings documentation instead
of add a new custom one 'mtk' for this company. mt7621-gpio device-tree
documentation has been added also to the staging driver directory.

v2:
 - Join some patch ("staging: mt7621-gpio: avoid use of globals 
   and use platform_data instead") with the needed fixes to make 
   it work pointed out by NeilBrown
 - Add gpio interrupts to documentation and device tree in order to
   can try them
 - Other minor code cleanups have been added also.

After this changes only testing interrupts should be remaining to
get this out of staging.

Hope this helps.

Best regards,
     Sergio

Sergio Paracuellos (11):
  staging: mt7621-gpio: dt-bindings: add documentation for mt7621-gpio
  staging: mt7621-gpio: update TODO file
  staging: mt7621-dts: update gpios related entries to use 'mediatek'
  staging: mt7621-gpio: replace 'mtk' to use correct one 'mediatek'
  staging: mt7621-gpio: avoid use of globals and use platform_data
    instead
  staging: mt7621-dts: add interrupt device tree nodes for the gpio
    controller
  staging: mt7621-gpio: dt-bindings: add interrupt nodes to bindings doc
  staging: mt7621-gpio: avoid devm_kzalloc() hidden inside declarations
  staging: mt7621-gpio: use ternary operator in return in
    mediatek_gpio_get_direction
  staging: mt7621-gpio: use MTK_BANK_WIDTH instead of magic number
  staging: mt7621-gpio: update TODO list

 drivers/staging/mt7621-dts/mt7621.dtsi             |  11 +-
 drivers/staging/mt7621-gpio/TODO                   |   3 +-
 drivers/staging/mt7621-gpio/gpio-mt7621.c          | 111 +++++++++++++--------
 .../staging/mt7621-gpio/mediatek,mt7621-gpio.txt   |  58 +++++++++++
 4 files changed, 137 insertions(+), 46 deletions(-)
 create mode 100644 drivers/staging/mt7621-gpio/mediatek,mt7621-gpio.txt

-- 
2.7.4

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2018-05-17  4:39 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-05-16  5:29 [PATCH v2 00/11] staging: mt7621-gpio: use mediatek as binding instead of custom mtk Sergio Paracuellos
2018-05-16  5:29 ` [PATCH v2 01/11] staging: mt7621-gpio: dt-bindings: add documentation for mt7621-gpio Sergio Paracuellos
2018-05-16  5:29 ` [PATCH v2 02/11] staging: mt7621-gpio: update TODO file Sergio Paracuellos
2018-05-16  5:29 ` [PATCH v2 03/11] staging: mt7621-dts: update gpios related entries to use 'mediatek' Sergio Paracuellos
2018-05-16  5:29 ` [PATCH v2 04/11] staging: mt7621-gpio: replace 'mtk' to use correct one 'mediatek' Sergio Paracuellos
2018-05-16  5:29 ` [PATCH v2 05/11] staging: mt7621-gpio: avoid use of globals and use platform_data instead Sergio Paracuellos
2018-05-16  5:29 ` [PATCH v2 06/11] staging: mt7621-dts: add interrupt device tree nodes for the gpio controller Sergio Paracuellos
2018-05-16  5:30 ` [PATCH v2 07/11] staging: mt7621-gpio: dt-bindings: add interrupt nodes to bindings doc Sergio Paracuellos
2018-05-16  5:30 ` [PATCH v2 08/11] staging: mt7621-gpio: avoid devm_kzalloc() hidden inside declarations Sergio Paracuellos
2018-05-16  8:04   ` Dan Carpenter
2018-05-16  8:56     ` Sergio Paracuellos
2018-05-16  9:40       ` Dan Carpenter
2018-05-17  4:39         ` Sergio Paracuellos
2018-05-16  5:30 ` [PATCH v2 09/11] staging: mt7621-gpio: use ternary operator in return in mediatek_gpio_get_direction Sergio Paracuellos
2018-05-16  5:30 ` [PATCH v2 10/11] staging: mt7621-gpio: use MTK_BANK_WIDTH instead of magic number Sergio Paracuellos
2018-05-16  5:30 ` [PATCH v2 11/11] staging: mt7621-gpio: update TODO list Sergio Paracuellos

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.