All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] drivers/of: keep description of function consistent with function name
@ 2020-05-11 15:04 qiwuchen55
  2020-05-19 18:24 ` Rob Herring
  0 siblings, 1 reply; 2+ messages in thread
From: qiwuchen55 @ 2020-05-11 15:04 UTC (permalink / raw)
  To: robh+dt, frowand.list; +Cc: devicetree, chenqiwu

From: chenqiwu <chenqiwu@xiaomi.com>

Currently, there are some descriptions of function not
consistent with function name, fixing them will make
the code more readable.

Signed-off-by: chenqiwu <chenqiwu@xiaomi.com>
---
 drivers/of/fdt.c             |  2 +-
 drivers/of/of_reserved_mem.c | 10 +++++-----
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/of/fdt.c b/drivers/of/fdt.c
index 2cdf64d..a86392a 100644
--- a/drivers/of/fdt.c
+++ b/drivers/of/fdt.c
@@ -471,7 +471,7 @@ void *of_fdt_unflatten_tree(const unsigned long *blob,
 static u32 of_fdt_crc32;
 
 /**
- * res_mem_reserve_reg() - reserve all memory described in 'reg' property
+ * __reserved_mem_reserve_reg() - reserve all memory described in 'reg' property
  */
 static int __init __reserved_mem_reserve_reg(unsigned long node,
 					     const char *uname)
diff --git a/drivers/of/of_reserved_mem.c b/drivers/of/of_reserved_mem.c
index 1a84bc0..6f6fea3 100644
--- a/drivers/of/of_reserved_mem.c
+++ b/drivers/of/of_reserved_mem.c
@@ -46,7 +46,7 @@ static int __init early_init_dt_alloc_reserved_memory_arch(phys_addr_t size,
 }
 
 /**
- * res_mem_save_node() - save fdt node for second pass initialization
+ * fdt_reserved_mem_save_node() - save fdt node for second pass initialization
  */
 void __init fdt_reserved_mem_save_node(unsigned long node, const char *uname,
 				      phys_addr_t base, phys_addr_t size)
@@ -68,8 +68,8 @@ void __init fdt_reserved_mem_save_node(unsigned long node, const char *uname,
 }
 
 /**
- * res_mem_alloc_size() - allocate reserved memory described by 'size', 'align'
- *			  and 'alloc-ranges' properties
+ * __reserved_mem_alloc_size() - allocate reserved memory described by
+ *	'size', 'align'  and 'alloc-ranges' properties.
  */
 static int __init __reserved_mem_alloc_size(unsigned long node,
 	const char *uname, phys_addr_t *res_base, phys_addr_t *res_size)
@@ -165,7 +165,7 @@ static int __init __reserved_mem_alloc_size(unsigned long node,
 	__used __section(__reservedmem_of_table_end);
 
 /**
- * res_mem_init_node() - call region specific reserved memory init code
+ * __reserved_mem_init_node() - call region specific reserved memory init code
  */
 static int __init __reserved_mem_init_node(struct reserved_mem *rmem)
 {
@@ -232,7 +232,7 @@ static void __init __rmem_check_for_overlap(void)
 }
 
 /**
- * fdt_init_reserved_mem - allocate and init all saved reserved memory regions
+ * fdt_init_reserved_mem() - allocate and init all saved reserved memory regions
  */
 void __init fdt_init_reserved_mem(void)
 {
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] drivers/of: keep description of function consistent with function name
  2020-05-11 15:04 [PATCH] drivers/of: keep description of function consistent with function name qiwuchen55
@ 2020-05-19 18:24 ` Rob Herring
  0 siblings, 0 replies; 2+ messages in thread
From: Rob Herring @ 2020-05-19 18:24 UTC (permalink / raw)
  To: qiwuchen55; +Cc: devicetree, chenqiwu, robh+dt, frowand.list

On Mon, 11 May 2020 23:04:57 +0800,  wrote:
> From: chenqiwu <chenqiwu@xiaomi.com>
> 
> Currently, there are some descriptions of function not
> consistent with function name, fixing them will make
> the code more readable.
> 
> Signed-off-by: chenqiwu <chenqiwu@xiaomi.com>
> ---
>  drivers/of/fdt.c             |  2 +-
>  drivers/of/of_reserved_mem.c | 10 +++++-----
>  2 files changed, 6 insertions(+), 6 deletions(-)
> 

Applied, thanks!

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-05-19 18:24 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-11 15:04 [PATCH] drivers/of: keep description of function consistent with function name qiwuchen55
2020-05-19 18:24 ` Rob Herring

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.