All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get()
@ 2020-11-03  3:57 Yejune Deng
  2021-01-07 19:16 ` Dmitry Osipenko
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Yejune Deng @ 2020-11-03  3:57 UTC (permalink / raw)
  To: balbi, gregkh, p.zabel; +Cc: linux-usb, linux-kernel, yejune.deng

devm_reset_control_array_get_optional_shared() looks more readable

Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
---
 drivers/usb/dwc3/core.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
index 841daec..b87acf0 100644
--- a/drivers/usb/dwc3/core.c
+++ b/drivers/usb/dwc3/core.c
@@ -1490,7 +1490,7 @@ static int dwc3_probe(struct platform_device *pdev)
 
 	dwc3_get_properties(dwc);
 
-	dwc->reset = devm_reset_control_array_get(dev, true, true);
+	dwc->reset = devm_reset_control_array_get_optional_shared(dev);
 	if (IS_ERR(dwc->reset))
 		return PTR_ERR(dwc->reset);
 
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get()
  2020-11-03  3:57 [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get() Yejune Deng
@ 2021-01-07 19:16 ` Dmitry Osipenko
  2021-01-07 19:23   ` Greg KH
  2021-01-07 19:33 ` Dmitry Osipenko
  2021-01-08 12:27 ` Felipe Balbi
  2 siblings, 1 reply; 6+ messages in thread
From: Dmitry Osipenko @ 2021-01-07 19:16 UTC (permalink / raw)
  To: Yejune Deng, balbi, gregkh, p.zabel; +Cc: linux-usb, linux-kernel

03.11.2020 06:57, Yejune Deng пишет:
> devm_reset_control_array_get_optional_shared() looks more readable
> 
> Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
> ---
>  drivers/usb/dwc3/core.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
> index 841daec..b87acf0 100644
> --- a/drivers/usb/dwc3/core.c
> +++ b/drivers/usb/dwc3/core.c
> @@ -1490,7 +1490,7 @@ static int dwc3_probe(struct platform_device *pdev)
>  
>  	dwc3_get_properties(dwc);
>  
> -	dwc->reset = devm_reset_control_array_get(dev, true, true);
> +	dwc->reset = devm_reset_control_array_get_optional_shared(dev);
>  	if (IS_ERR(dwc->reset))
>  		return PTR_ERR(dwc->reset);
>  
> 

Greg / Felipe, could you please pick up this patch?

I want to add devm_reset_control_array_get_exclusive_released() for
NVIDIA Tegra drivers and we need to get rid of all the open-coded
devm_reset_control_array_get() users in order to extend the reset API
sanely.

Thanks in advance.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get()
  2021-01-07 19:16 ` Dmitry Osipenko
@ 2021-01-07 19:23   ` Greg KH
  2021-01-07 20:44     ` Dmitry Osipenko
  0 siblings, 1 reply; 6+ messages in thread
From: Greg KH @ 2021-01-07 19:23 UTC (permalink / raw)
  To: Dmitry Osipenko; +Cc: Yejune Deng, balbi, p.zabel, linux-usb, linux-kernel

On Thu, Jan 07, 2021 at 10:16:50PM +0300, Dmitry Osipenko wrote:
> 03.11.2020 06:57, Yejune Deng пишет:
> > devm_reset_control_array_get_optional_shared() looks more readable
> > 
> > Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
> > ---
> >  drivers/usb/dwc3/core.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
> > index 841daec..b87acf0 100644
> > --- a/drivers/usb/dwc3/core.c
> > +++ b/drivers/usb/dwc3/core.c
> > @@ -1490,7 +1490,7 @@ static int dwc3_probe(struct platform_device *pdev)
> >  
> >  	dwc3_get_properties(dwc);
> >  
> > -	dwc->reset = devm_reset_control_array_get(dev, true, true);
> > +	dwc->reset = devm_reset_control_array_get_optional_shared(dev);
> >  	if (IS_ERR(dwc->reset))
> >  		return PTR_ERR(dwc->reset);
> >  
> > 
> 
> Greg / Felipe, could you please pick up this patch?
> 
> I want to add devm_reset_control_array_get_exclusive_released() for
> NVIDIA Tegra drivers and we need to get rid of all the open-coded
> devm_reset_control_array_get() users in order to extend the reset API
> sanely.

Care to ack it or send a reviewed-by for it?

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get()
  2020-11-03  3:57 [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get() Yejune Deng
  2021-01-07 19:16 ` Dmitry Osipenko
@ 2021-01-07 19:33 ` Dmitry Osipenko
  2021-01-08 12:27 ` Felipe Balbi
  2 siblings, 0 replies; 6+ messages in thread
From: Dmitry Osipenko @ 2021-01-07 19:33 UTC (permalink / raw)
  To: Yejune Deng, balbi, gregkh, p.zabel; +Cc: linux-usb, linux-kernel

03.11.2020 06:57, Yejune Deng пишет:
> devm_reset_control_array_get_optional_shared() looks more readable
> 
> Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
> ---
>  drivers/usb/dwc3/core.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
> index 841daec..b87acf0 100644
> --- a/drivers/usb/dwc3/core.c
> +++ b/drivers/usb/dwc3/core.c
> @@ -1490,7 +1490,7 @@ static int dwc3_probe(struct platform_device *pdev)
>  
>  	dwc3_get_properties(dwc);
>  
> -	dwc->reset = devm_reset_control_array_get(dev, true, true);
> +	dwc->reset = devm_reset_control_array_get_optional_shared(dev);
>  	if (IS_ERR(dwc->reset))
>  		return PTR_ERR(dwc->reset);
>  
> 

Reviewed-by: Dmitry Osipenko <digetx@gmail.com>

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get()
  2021-01-07 19:23   ` Greg KH
@ 2021-01-07 20:44     ` Dmitry Osipenko
  0 siblings, 0 replies; 6+ messages in thread
From: Dmitry Osipenko @ 2021-01-07 20:44 UTC (permalink / raw)
  To: Greg KH; +Cc: Yejune Deng, balbi, p.zabel, linux-usb, linux-kernel

07.01.2021 22:23, Greg KH пишет:
> On Thu, Jan 07, 2021 at 10:16:50PM +0300, Dmitry Osipenko wrote:
>> 03.11.2020 06:57, Yejune Deng пишет:
>>> devm_reset_control_array_get_optional_shared() looks more readable
>>>
>>> Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
>>> ---
>>>  drivers/usb/dwc3/core.c | 2 +-
>>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
>>> index 841daec..b87acf0 100644
>>> --- a/drivers/usb/dwc3/core.c
>>> +++ b/drivers/usb/dwc3/core.c
>>> @@ -1490,7 +1490,7 @@ static int dwc3_probe(struct platform_device *pdev)
>>>  
>>>  	dwc3_get_properties(dwc);
>>>  
>>> -	dwc->reset = devm_reset_control_array_get(dev, true, true);
>>> +	dwc->reset = devm_reset_control_array_get_optional_shared(dev);
>>>  	if (IS_ERR(dwc->reset))
>>>  		return PTR_ERR(dwc->reset);
>>>  
>>>
>>
>> Greg / Felipe, could you please pick up this patch?
>>
>> I want to add devm_reset_control_array_get_exclusive_released() for
>> NVIDIA Tegra drivers and we need to get rid of all the open-coded
>> devm_reset_control_array_get() users in order to extend the reset API
>> sanely.
> 
> Care to ack it or send a reviewed-by for it?

I sent r-b, thanks.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get()
  2020-11-03  3:57 [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get() Yejune Deng
  2021-01-07 19:16 ` Dmitry Osipenko
  2021-01-07 19:33 ` Dmitry Osipenko
@ 2021-01-08 12:27 ` Felipe Balbi
  2 siblings, 0 replies; 6+ messages in thread
From: Felipe Balbi @ 2021-01-08 12:27 UTC (permalink / raw)
  To: Yejune Deng, gregkh, p.zabel; +Cc: linux-usb, linux-kernel, yejune.deng

[-- Attachment #1: Type: text/plain, Size: 233 bytes --]

Yejune Deng <yejune.deng@gmail.com> writes:

> devm_reset_control_array_get_optional_shared() looks more readable
>
> Signed-off-by: Yejune Deng <yejune.deng@gmail.com>

Acked-by: Felipe Balbi <balbi@kernel.org>

-- 
balbi

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 857 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-01-08 12:28 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-03  3:57 [PATCH] usb: dwc3: core: Replace devm_reset_control_array_get() Yejune Deng
2021-01-07 19:16 ` Dmitry Osipenko
2021-01-07 19:23   ` Greg KH
2021-01-07 20:44     ` Dmitry Osipenko
2021-01-07 19:33 ` Dmitry Osipenko
2021-01-08 12:27 ` Felipe Balbi

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.