All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c
@ 2020-11-12  7:07 Luo Jiaxing
  2020-11-12  7:07 ` [PATCH v4 1/5] seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro Luo Jiaxing
                   ` (6 more replies)
  0 siblings, 7 replies; 17+ messages in thread
From: Luo Jiaxing @ 2020-11-12  7:07 UTC (permalink / raw)
  To: akpm, viro, andriy.shevchenko
  Cc: linux-kernel, martin.petersen, john.garry, himanshu.madhani,
	felipe.balbi, gregkh, uma.shankar, anshuman.gupta, animesh.manna,
	linux-usb, linux-scsi, linuxarm

We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper macro
for read-write file too.

So we add this macro to help decrease code duplication.

---
 v1->v2:
        1.Rename DEFINE_STORE_ATTRIBUTE() to DEFINE_SHOW_STORE_ATTRIBUTE().
	2.AI Viro points out that he doesn't like the definition of macros
	  like DEFINE_SHOW_ATTRIBUTE.
 v2->v3:
        1.Fixed some spelling mistakes in commit.
        2.Revision description are added for easy tracing.

 v3->v4:
	1.Add AI Viro's comment to v1->v2's revision description.
	2.Fixed a spelling mistakes of "marco" to "macro".
---

Luo Jiaxing (5):
  seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
  scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
  scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
  usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
  drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

 .../gpu/drm/i915/display/intel_display_debugfs.c   |  55 +--------
 drivers/scsi/hisi_sas/hisi_sas_main.c              | 135 +++------------------
 drivers/scsi/qla2xxx/qla_dfs.c                     |  19 +--
 drivers/usb/dwc3/debugfs.c                         |  52 +-------
 include/linux/seq_file.h                           |  15 +++
 5 files changed, 41 insertions(+), 235 deletions(-)

-- 
2.7.4


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2023-09-04  7:12 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-12  7:07 [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c Luo Jiaxing
2020-11-12  7:07 ` [PATCH v4 1/5] seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro Luo Jiaxing
2020-11-12  7:07 ` [PATCH v4 2/5] scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs Luo Jiaxing
2020-11-12  7:07 ` [PATCH v4 3/5] scsi: qla2xxx: " Luo Jiaxing
2020-11-13 23:52   ` kernel test robot
2020-11-13 23:52     ` kernel test robot
2020-11-12  7:07 ` [PATCH v4 4/5] usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE Luo Jiaxing
2020-11-12  7:07 ` [PATCH v4 5/5] drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs Luo Jiaxing
2020-11-13 11:26   ` kernel test robot
2020-11-13 11:26     ` kernel test robot
2020-11-14  5:12   ` kernel test robot
2020-11-14  5:12     ` kernel test robot
2023-06-28 10:40 ` [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c Andy Shevchenko
2023-08-31 18:19 ` Andy Shevchenko
2023-09-01  7:11   ` yangxingui
2023-09-01  8:54     ` Andy Shevchenko
2023-09-04  7:12       ` yangxingui

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.