All of lore.kernel.org
 help / color / mirror / Atom feed
From: Will Deacon <will@kernel.org>
To: Julien Thierry <julien.thierry.kdev@gmail.com>,
	Andre Przywara <andre.przywara@arm.com>
Cc: catalin.marinas@arm.com, kernel-team@android.com,
	Will Deacon <will@kernel.org>,
	kvmarm@lists.cs.columbia.edu, Sami Mujawar <sami.mujawar@arm.com>,
	Marc Zyngier <maz@kernel.org>,
	kvm@vger.kernel.org, Alexandru Elisei <alexandru.elisei@arm.com>
Subject: Re: [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling
Date: Thu, 18 Mar 2021 10:04:55 +0000	[thread overview]
Message-ID: <161606068634.550587.17439092982108275200.b4-ty@kernel.org> (raw)
In-Reply-To: <20210315153350.19988-1-andre.przywara@arm.com>

On Mon, 15 Mar 2021 15:33:28 +0000, Andre Przywara wrote:
> this version is addressing Alexandru's comments, fixing mostly minor
> issues in the naming scheme. The biggest change is to keep the
> ioport__read/ioport_write wrappers for the serial device.
> For more details see the changelog below.
> ==============
> 
> At the moment we use two separate code paths to handle exits for
> KVM_EXIT_IO (ioport.c) and KVM_EXIT_MMIO (mmio.c), even though they
> are semantically very similar. Because the trap handler callback routine
> is different, devices need to decide on one conduit or need to provide
> different handler functions for both of them.
> 
> [...]

Applied to kvmtool (master), thanks!

[01/22] ioport: Remove ioport__setup_arch()
        https://git.kernel.org/will/kvmtool/c/97531eb2ca70
[02/22] hw/serial: Use device abstraction for FDT generator function
        https://git.kernel.org/will/kvmtool/c/a81be31eee6e
[03/22] ioport: Retire .generate_fdt_node functionality
        https://git.kernel.org/will/kvmtool/c/9bc7e2ce343e
[04/22] mmio: Extend handling to include ioport emulation
        https://git.kernel.org/will/kvmtool/c/96f0c86ce221
[05/22] hw/i8042: Clean up data types
        https://git.kernel.org/will/kvmtool/c/fc7696277b29
[06/22] hw/i8042: Refactor trap handler
        https://git.kernel.org/will/kvmtool/c/f7ef3dc0cd28
[07/22] hw/i8042: Switch to new trap handlers
        https://git.kernel.org/will/kvmtool/c/d24bedb1cc9a
[08/22] x86/ioport: Refactor trap handlers
        https://git.kernel.org/will/kvmtool/c/82304999f936
[09/22] x86/ioport: Switch to new trap handlers
        https://git.kernel.org/will/kvmtool/c/3adbcb235020
[10/22] hw/rtc: Refactor trap handlers
        https://git.kernel.org/will/kvmtool/c/8c45f36430bd
[11/22] hw/rtc: Switch to new trap handler
        https://git.kernel.org/will/kvmtool/c/123ee474b97b
[12/22] hw/vesa: Switch trap handling to use MMIO handler
        https://git.kernel.org/will/kvmtool/c/38ae332ffcec
[13/22] hw/serial: Refactor trap handler
        https://git.kernel.org/will/kvmtool/c/47a510600e08
[14/22] hw/serial: Switch to new trap handlers
        https://git.kernel.org/will/kvmtool/c/59866df60b4b
[15/22] vfio: Refactor ioport trap handler
        https://git.kernel.org/will/kvmtool/c/a4a0dac75469
[16/22] vfio: Switch to new ioport trap handlers
        https://git.kernel.org/will/kvmtool/c/579bc61f8798
[17/22] virtio: Switch trap handling to use MMIO handler
        https://git.kernel.org/will/kvmtool/c/205eaa794be7
[18/22] pci: Switch trap handling to use MMIO handler
        https://git.kernel.org/will/kvmtool/c/1f56b9d10a28
[19/22] Remove ioport specific routines
        https://git.kernel.org/will/kvmtool/c/7e19cb54a7cc
[20/22] arm: Reorganise and document memory map
        https://git.kernel.org/will/kvmtool/c/f01cc778bd65
[21/22] hw/serial: ARM/arm64: Use MMIO at higher addresses
        https://git.kernel.org/will/kvmtool/c/45b4968e0de1
[22/22] hw/rtc: ARM/arm64: Use MMIO at higher addresses
        https://git.kernel.org/will/kvmtool/c/382eaad7b695

Cheers,
-- 
Will

https://fixes.arm64.dev
https://next.arm64.dev
https://will.arm64.dev

WARNING: multiple messages have this Message-ID (diff)
From: Will Deacon <will@kernel.org>
To: Julien Thierry <julien.thierry.kdev@gmail.com>,
	Andre Przywara <andre.przywara@arm.com>
Cc: kvm@vger.kernel.org, Will Deacon <will@kernel.org>,
	catalin.marinas@arm.com, Marc Zyngier <maz@kernel.org>,
	Sami Mujawar <sami.mujawar@arm.com>,
	kernel-team@android.com, kvmarm@lists.cs.columbia.edu
Subject: Re: [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling
Date: Thu, 18 Mar 2021 10:04:55 +0000	[thread overview]
Message-ID: <161606068634.550587.17439092982108275200.b4-ty@kernel.org> (raw)
In-Reply-To: <20210315153350.19988-1-andre.przywara@arm.com>

On Mon, 15 Mar 2021 15:33:28 +0000, Andre Przywara wrote:
> this version is addressing Alexandru's comments, fixing mostly minor
> issues in the naming scheme. The biggest change is to keep the
> ioport__read/ioport_write wrappers for the serial device.
> For more details see the changelog below.
> ==============
> 
> At the moment we use two separate code paths to handle exits for
> KVM_EXIT_IO (ioport.c) and KVM_EXIT_MMIO (mmio.c), even though they
> are semantically very similar. Because the trap handler callback routine
> is different, devices need to decide on one conduit or need to provide
> different handler functions for both of them.
> 
> [...]

Applied to kvmtool (master), thanks!

[01/22] ioport: Remove ioport__setup_arch()
        https://git.kernel.org/will/kvmtool/c/97531eb2ca70
[02/22] hw/serial: Use device abstraction for FDT generator function
        https://git.kernel.org/will/kvmtool/c/a81be31eee6e
[03/22] ioport: Retire .generate_fdt_node functionality
        https://git.kernel.org/will/kvmtool/c/9bc7e2ce343e
[04/22] mmio: Extend handling to include ioport emulation
        https://git.kernel.org/will/kvmtool/c/96f0c86ce221
[05/22] hw/i8042: Clean up data types
        https://git.kernel.org/will/kvmtool/c/fc7696277b29
[06/22] hw/i8042: Refactor trap handler
        https://git.kernel.org/will/kvmtool/c/f7ef3dc0cd28
[07/22] hw/i8042: Switch to new trap handlers
        https://git.kernel.org/will/kvmtool/c/d24bedb1cc9a
[08/22] x86/ioport: Refactor trap handlers
        https://git.kernel.org/will/kvmtool/c/82304999f936
[09/22] x86/ioport: Switch to new trap handlers
        https://git.kernel.org/will/kvmtool/c/3adbcb235020
[10/22] hw/rtc: Refactor trap handlers
        https://git.kernel.org/will/kvmtool/c/8c45f36430bd
[11/22] hw/rtc: Switch to new trap handler
        https://git.kernel.org/will/kvmtool/c/123ee474b97b
[12/22] hw/vesa: Switch trap handling to use MMIO handler
        https://git.kernel.org/will/kvmtool/c/38ae332ffcec
[13/22] hw/serial: Refactor trap handler
        https://git.kernel.org/will/kvmtool/c/47a510600e08
[14/22] hw/serial: Switch to new trap handlers
        https://git.kernel.org/will/kvmtool/c/59866df60b4b
[15/22] vfio: Refactor ioport trap handler
        https://git.kernel.org/will/kvmtool/c/a4a0dac75469
[16/22] vfio: Switch to new ioport trap handlers
        https://git.kernel.org/will/kvmtool/c/579bc61f8798
[17/22] virtio: Switch trap handling to use MMIO handler
        https://git.kernel.org/will/kvmtool/c/205eaa794be7
[18/22] pci: Switch trap handling to use MMIO handler
        https://git.kernel.org/will/kvmtool/c/1f56b9d10a28
[19/22] Remove ioport specific routines
        https://git.kernel.org/will/kvmtool/c/7e19cb54a7cc
[20/22] arm: Reorganise and document memory map
        https://git.kernel.org/will/kvmtool/c/f01cc778bd65
[21/22] hw/serial: ARM/arm64: Use MMIO at higher addresses
        https://git.kernel.org/will/kvmtool/c/45b4968e0de1
[22/22] hw/rtc: ARM/arm64: Use MMIO at higher addresses
        https://git.kernel.org/will/kvmtool/c/382eaad7b695

Cheers,
-- 
Will

https://fixes.arm64.dev
https://next.arm64.dev
https://will.arm64.dev
_______________________________________________
kvmarm mailing list
kvmarm@lists.cs.columbia.edu
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm

  parent reply	other threads:[~2021-03-18 10:05 UTC|newest]

Thread overview: 56+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-15 15:33 [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling Andre Przywara
2021-03-15 15:33 ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 01/22] ioport: Remove ioport__setup_arch() Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 02/22] hw/serial: Use device abstraction for FDT generator function Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 03/22] ioport: Retire .generate_fdt_node functionality Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 04/22] mmio: Extend handling to include ioport emulation Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 05/22] hw/i8042: Clean up data types Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 06/22] hw/i8042: Refactor trap handler Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 07/22] hw/i8042: Switch to new trap handlers Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 08/22] x86/ioport: Refactor " Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 09/22] x86/ioport: Switch to new " Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 10/22] hw/rtc: Refactor " Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 11/22] hw/rtc: Switch to new trap handler Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 12/22] hw/vesa: Switch trap handling to use MMIO handler Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 13/22] hw/serial: Refactor trap handler Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-16 15:40   ` Alexandru Elisei
2021-03-16 15:40     ` Alexandru Elisei
2021-03-15 15:33 ` [PATCH kvmtool v3 14/22] hw/serial: Switch to new trap handlers Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 15/22] vfio: Refactor ioport trap handler Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 16/22] vfio: Switch to new ioport trap handlers Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 17/22] virtio: Switch trap handling to use MMIO handler Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 18/22] pci: " Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 19/22] Remove ioport specific routines Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 20/22] arm: Reorganise and document memory map Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-17 15:17   ` Alexandru Elisei
2021-03-17 15:17     ` Alexandru Elisei
2021-03-15 15:33 ` [PATCH kvmtool v3 21/22] hw/serial: ARM/arm64: Use MMIO at higher addresses Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-17 16:17   ` Alexandru Elisei
2021-03-17 16:17     ` Alexandru Elisei
2021-03-15 15:33 ` [PATCH kvmtool v3 22/22] hw/rtc: " Andre Przywara
2021-03-15 15:33   ` Andre Przywara
2021-03-17 17:44 ` [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling Alexandru Elisei
2021-03-17 17:44   ` Alexandru Elisei
2021-03-18 10:04 ` Will Deacon [this message]
2021-03-18 10:04   ` Will Deacon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=161606068634.550587.17439092982108275200.b4-ty@kernel.org \
    --to=will@kernel.org \
    --cc=alexandru.elisei@arm.com \
    --cc=andre.przywara@arm.com \
    --cc=catalin.marinas@arm.com \
    --cc=julien.thierry.kdev@gmail.com \
    --cc=kernel-team@android.com \
    --cc=kvm@vger.kernel.org \
    --cc=kvmarm@lists.cs.columbia.edu \
    --cc=maz@kernel.org \
    --cc=sami.mujawar@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.