All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro
@ 2021-05-24 11:47 ` YueHaibing
  0 siblings, 0 replies; 6+ messages in thread
From: YueHaibing @ 2021-05-24 11:47 UTC (permalink / raw)
  To: lgirdwood, broonie, perex, tiwai
  Cc: patches, alsa-devel, linux-kernel, YueHaibing

Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(),
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <yuehaibing@huawei.com>
---
 sound/soc/codecs/wm8962.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/sound/soc/codecs/wm8962.c b/sound/soc/codecs/wm8962.c
index 34080f497584..ba16bdf9e478 100644
--- a/sound/soc/codecs/wm8962.c
+++ b/sound/soc/codecs/wm8962.c
@@ -3219,9 +3219,8 @@ static int wm8962_beep_event(struct input_dev *dev, unsigned int type,
 	return 0;
 }
 
-static ssize_t wm8962_beep_set(struct device *dev,
-			       struct device_attribute *attr,
-			       const char *buf, size_t count)
+static ssize_t beep_store(struct device *dev, struct device_attribute *attr,
+			  const char *buf, size_t count)
 {
 	struct wm8962_priv *wm8962 = dev_get_drvdata(dev);
 	long int time;
@@ -3236,7 +3235,7 @@ static ssize_t wm8962_beep_set(struct device *dev,
 	return count;
 }
 
-static DEVICE_ATTR(beep, 0200, NULL, wm8962_beep_set);
+static DEVICE_ATTR_WO(beep);
 
 static void wm8962_init_beep(struct snd_soc_component *component)
 {
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro
@ 2021-05-24 11:47 ` YueHaibing
  0 siblings, 0 replies; 6+ messages in thread
From: YueHaibing @ 2021-05-24 11:47 UTC (permalink / raw)
  To: lgirdwood, broonie, perex, tiwai
  Cc: patches, alsa-devel, YueHaibing, linux-kernel

Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(),
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <yuehaibing@huawei.com>
---
 sound/soc/codecs/wm8962.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/sound/soc/codecs/wm8962.c b/sound/soc/codecs/wm8962.c
index 34080f497584..ba16bdf9e478 100644
--- a/sound/soc/codecs/wm8962.c
+++ b/sound/soc/codecs/wm8962.c
@@ -3219,9 +3219,8 @@ static int wm8962_beep_event(struct input_dev *dev, unsigned int type,
 	return 0;
 }
 
-static ssize_t wm8962_beep_set(struct device *dev,
-			       struct device_attribute *attr,
-			       const char *buf, size_t count)
+static ssize_t beep_store(struct device *dev, struct device_attribute *attr,
+			  const char *buf, size_t count)
 {
 	struct wm8962_priv *wm8962 = dev_get_drvdata(dev);
 	long int time;
@@ -3236,7 +3235,7 @@ static ssize_t wm8962_beep_set(struct device *dev,
 	return count;
 }
 
-static DEVICE_ATTR(beep, 0200, NULL, wm8962_beep_set);
+static DEVICE_ATTR_WO(beep);
 
 static void wm8962_init_beep(struct snd_soc_component *component)
 {
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro
  2021-05-24 11:47 ` YueHaibing
@ 2021-05-25 15:56   ` Charles Keepax
  -1 siblings, 0 replies; 6+ messages in thread
From: Charles Keepax @ 2021-05-25 15:56 UTC (permalink / raw)
  To: YueHaibing
  Cc: lgirdwood, broonie, perex, tiwai, patches, alsa-devel, linux-kernel

On Mon, May 24, 2021 at 07:47:53PM +0800, YueHaibing wrote:
> Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
> 
> Signed-off-by: YueHaibing <yuehaibing@huawei.com>
> ---

Acked-by: Charles Keepax <ckeepax@opensource.cirrus.com>

Thanks,
Charles

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro
@ 2021-05-25 15:56   ` Charles Keepax
  0 siblings, 0 replies; 6+ messages in thread
From: Charles Keepax @ 2021-05-25 15:56 UTC (permalink / raw)
  To: YueHaibing; +Cc: alsa-devel, patches, tiwai, lgirdwood, broonie, linux-kernel

On Mon, May 24, 2021 at 07:47:53PM +0800, YueHaibing wrote:
> Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
> 
> Signed-off-by: YueHaibing <yuehaibing@huawei.com>
> ---

Acked-by: Charles Keepax <ckeepax@opensource.cirrus.com>

Thanks,
Charles

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro
  2021-05-24 11:47 ` YueHaibing
@ 2021-05-26 20:21   ` Mark Brown
  -1 siblings, 0 replies; 6+ messages in thread
From: Mark Brown @ 2021-05-26 20:21 UTC (permalink / raw)
  To: lgirdwood, YueHaibing, tiwai, perex
  Cc: Mark, Brown, broonie, alsa-devel, patches, linux-kernel

From: Mark Brown,,, <broonie@kernel.org>

On Mon, 24 May 2021 19:47:53 +0800, YueHaibing wrote:
> Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.

Applied, thanks!

[1/1] ASoC: wm8962: Use DEVICE_ATTR_WO macro
      commit: d04260393ea0ded33448c1fae944cf86c14da994

Best regards,
-- 
Mark Brown,,, <broonie@kernel.org>

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro
@ 2021-05-26 20:21   ` Mark Brown
  0 siblings, 0 replies; 6+ messages in thread
From: Mark Brown @ 2021-05-26 20:21 UTC (permalink / raw)
  To: lgirdwood, YueHaibing, tiwai, perex
  Cc: alsa-devel, Brown, patches, linux-kernel, broonie, Mark

From: Mark Brown,,, <broonie@kernel.org>

On Mon, 24 May 2021 19:47:53 +0800, YueHaibing wrote:
> Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.

Applied, thanks!

[1/1] ASoC: wm8962: Use DEVICE_ATTR_WO macro
      commit: d04260393ea0ded33448c1fae944cf86c14da994

Best regards,
-- 
Mark Brown,,, <broonie@kernel.org>

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-05-26 20:24 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-24 11:47 [PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro YueHaibing
2021-05-24 11:47 ` YueHaibing
2021-05-25 15:56 ` Charles Keepax
2021-05-25 15:56   ` Charles Keepax
2021-05-26 20:21 ` Mark Brown
2021-05-26 20:21   ` Mark Brown

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.