All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net-next] net: make dev_get_port_parent_id slightly more readable
@ 2021-10-08 14:21 Antoine Tenart
  2021-10-10 10:40 ` patchwork-bot+netdevbpf
  0 siblings, 1 reply; 2+ messages in thread
From: Antoine Tenart @ 2021-10-08 14:21 UTC (permalink / raw)
  To: davem, kuba; +Cc: Antoine Tenart, netdev

Cosmetic commit making dev_get_port_parent_id slightly more readable.
There is no need to split the condition to return after calling
devlink_compat_switch_id_get and after that 'recurse' is always true.

Signed-off-by: Antoine Tenart <atenart@kernel.org>
---
 net/core/dev.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/net/core/dev.c b/net/core/dev.c
index 16ab09b6a7f8..35fb32279d7f 100644
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -9159,14 +9159,11 @@ int dev_get_port_parent_id(struct net_device *dev,
 	}
 
 	err = devlink_compat_switch_id_get(dev, ppid);
-	if (!err || err != -EOPNOTSUPP)
+	if (!recurse || err != -EOPNOTSUPP)
 		return err;
 
-	if (!recurse)
-		return -EOPNOTSUPP;
-
 	netdev_for_each_lower_dev(dev, lower_dev, iter) {
-		err = dev_get_port_parent_id(lower_dev, ppid, recurse);
+		err = dev_get_port_parent_id(lower_dev, ppid, true);
 		if (err)
 			break;
 		if (!first.id_len)
-- 
2.31.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH net-next] net: make dev_get_port_parent_id slightly more readable
  2021-10-08 14:21 [PATCH net-next] net: make dev_get_port_parent_id slightly more readable Antoine Tenart
@ 2021-10-10 10:40 ` patchwork-bot+netdevbpf
  0 siblings, 0 replies; 2+ messages in thread
From: patchwork-bot+netdevbpf @ 2021-10-10 10:40 UTC (permalink / raw)
  To: Antoine Tenart; +Cc: davem, kuba, netdev

Hello:

This patch was applied to netdev/net-next.git (master)
by David S. Miller <davem@davemloft.net>:

On Fri,  8 Oct 2021 16:21:03 +0200 you wrote:
> Cosmetic commit making dev_get_port_parent_id slightly more readable.
> There is no need to split the condition to return after calling
> devlink_compat_switch_id_get and after that 'recurse' is always true.
> 
> Signed-off-by: Antoine Tenart <atenart@kernel.org>
> ---
>  net/core/dev.c | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)

Here is the summary with links:
  - [net-next] net: make dev_get_port_parent_id slightly more readable
    https://git.kernel.org/netdev/net-next/c/c0288ae8e6bd

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-10-10 10:40 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-10-08 14:21 [PATCH net-next] net: make dev_get_port_parent_id slightly more readable Antoine Tenart
2021-10-10 10:40 ` patchwork-bot+netdevbpf

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.