All of lore.kernel.org
 help / color / mirror / Atom feed
From: Nicholas Piggin <npiggin@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>,
	Arnd Bergmann <arnd@arndb.de>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Christophe Leroy <christophe.leroy@csgroup.eu>,
	Helge Deller <deller@gmx.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	Kees Cook <keescook@chromium.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Paul Mackerras <paulus@samba.org>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	linux-parisc@vger.kernel.org, linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v2 06/13] asm-generic: Use HAVE_FUNCTION_DESCRIPTORS to define associated stubs
Date: Fri, 15 Oct 2021 18:02:00 +1000	[thread overview]
Message-ID: <1634284464.kd8scm0ckz.astroid@bobo.none> (raw)
In-Reply-To: <7523a005-ea69-7c4c-64ad-bc2537921975@csgroup.eu>

Excerpts from Christophe Leroy's message of October 15, 2021 4:24 pm:
> 
> 
> Le 15/10/2021 à 08:16, Nicholas Piggin a écrit :
>> Excerpts from Christophe Leroy's message of October 14, 2021 3:49 pm:
>>> Replace HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR by
>>> HAVE_FUNCTION_DESCRIPTORS and use it instead of
>>> 'dereference_function_descriptor' macro to know
>>> whether an arch has function descriptors.
>>>
>>> To limit churn in one of the following patches, use
>>> an #ifdef/#else construct with empty first part
>>> instead of an #ifndef in asm-generic/sections.h
>> 
>> Is it worth putting this into Kconfig if you're going to
>> change it? In any case
> 
> That was what I wanted to do in the begining but how can I do that in 
> Kconfig ?
> 
> #ifdef __powerpc64__
> #if defined(_CALL_ELF) && _CALL_ELF == 2
> #define PPC64_ELF_ABI_v2
> #else
> #define PPC64_ELF_ABI_v1
> #endif
> #endif /* __powerpc64__ */
> 
> #ifdef PPC64_ELF_ABI_v1
> #define HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR 1

We have ELFv2 ABI / function descriptors iff big-endian so you could 
just select based on that.

I have a patch that makes the ABI version configurable which cleans
some of this up a bit, but that can be rebased on your series if we
ever merge it. Maybe just add BUILD_BUG_ONs in the above ifdef block
to ensure CONFIG_HAVE_FUNCTION_DESCRIPTORS was set the right way, so
I don't forget.

Thanks,
Nick

WARNING: multiple messages have this Message-ID (diff)
From: Nicholas Piggin <npiggin@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>,
	Arnd Bergmann <arnd@arndb.de>,
	 Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Christophe Leroy <christophe.leroy@csgroup.eu>,
	Helge Deller <deller@gmx.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	Kees Cook <keescook@chromium.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Paul Mackerras <paulus@samba.org>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-parisc@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-mm@kvack.org, linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v2 06/13] asm-generic: Use HAVE_FUNCTION_DESCRIPTORS to define associated stubs
Date: Fri, 15 Oct 2021 18:02:00 +1000	[thread overview]
Message-ID: <1634284464.kd8scm0ckz.astroid@bobo.none> (raw)
In-Reply-To: <7523a005-ea69-7c4c-64ad-bc2537921975@csgroup.eu>

Excerpts from Christophe Leroy's message of October 15, 2021 4:24 pm:
> 
> 
> Le 15/10/2021 à 08:16, Nicholas Piggin a écrit :
>> Excerpts from Christophe Leroy's message of October 14, 2021 3:49 pm:
>>> Replace HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR by
>>> HAVE_FUNCTION_DESCRIPTORS and use it instead of
>>> 'dereference_function_descriptor' macro to know
>>> whether an arch has function descriptors.
>>>
>>> To limit churn in one of the following patches, use
>>> an #ifdef/#else construct with empty first part
>>> instead of an #ifndef in asm-generic/sections.h
>> 
>> Is it worth putting this into Kconfig if you're going to
>> change it? In any case
> 
> That was what I wanted to do in the begining but how can I do that in 
> Kconfig ?
> 
> #ifdef __powerpc64__
> #if defined(_CALL_ELF) && _CALL_ELF == 2
> #define PPC64_ELF_ABI_v2
> #else
> #define PPC64_ELF_ABI_v1
> #endif
> #endif /* __powerpc64__ */
> 
> #ifdef PPC64_ELF_ABI_v1
> #define HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR 1

We have ELFv2 ABI / function descriptors iff big-endian so you could 
just select based on that.

I have a patch that makes the ABI version configurable which cleans
some of this up a bit, but that can be rebased on your series if we
ever merge it. Maybe just add BUILD_BUG_ONs in the above ifdef block
to ensure CONFIG_HAVE_FUNCTION_DESCRIPTORS was set the right way, so
I don't forget.

Thanks,
Nick

WARNING: multiple messages have this Message-ID (diff)
From: Nicholas Piggin <npiggin@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>,
	Arnd Bergmann <arnd@arndb.de>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Christophe Leroy <christophe.leroy@csgroup.eu>,
	Helge Deller <deller@gmx.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	Kees Cook <keescook@chromium.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Paul Mackerras <paulus@samba.org>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	linux-parisc@vger.kernel.org, linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v2 06/13] asm-generic: Use HAVE_FUNCTION_DESCRIPTORS to define associated stubs
Date: Fri, 15 Oct 2021 08:02:00 +0000	[thread overview]
Message-ID: <1634284464.kd8scm0ckz.astroid@bobo.none> (raw)
In-Reply-To: <7523a005-ea69-7c4c-64ad-bc2537921975@csgroup.eu>

Excerpts from Christophe Leroy's message of October 15, 2021 4:24 pm:
> 
> 
> Le 15/10/2021 à 08:16, Nicholas Piggin a écrit :
>> Excerpts from Christophe Leroy's message of October 14, 2021 3:49 pm:
>>> Replace HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR by
>>> HAVE_FUNCTION_DESCRIPTORS and use it instead of
>>> 'dereference_function_descriptor' macro to know
>>> whether an arch has function descriptors.
>>>
>>> To limit churn in one of the following patches, use
>>> an #ifdef/#else construct with empty first part
>>> instead of an #ifndef in asm-generic/sections.h
>> 
>> Is it worth putting this into Kconfig if you're going to
>> change it? In any case
> 
> That was what I wanted to do in the begining but how can I do that in 
> Kconfig ?
> 
> #ifdef __powerpc64__
> #if defined(_CALL_ELF) && _CALL_ELF == 2
> #define PPC64_ELF_ABI_v2
> #else
> #define PPC64_ELF_ABI_v1
> #endif
> #endif /* __powerpc64__ */
> 
> #ifdef PPC64_ELF_ABI_v1
> #define HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR 1

We have ELFv2 ABI / function descriptors iff big-endian so you could 
just select based on that.

I have a patch that makes the ABI version configurable which cleans
some of this up a bit, but that can be rebased on your series if we
ever merge it. Maybe just add BUILD_BUG_ONs in the above ifdef block
to ensure CONFIG_HAVE_FUNCTION_DESCRIPTORS was set the right way, so
I don't forget.

Thanks,
Nick

  reply	other threads:[~2021-10-15  8:03 UTC|newest]

Thread overview: 106+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-14  5:49 [PATCH v2 00/13] Fix LKDTM for PPC64/IA64/PARISC Christophe Leroy
2021-10-14  5:49 ` Christophe Leroy
2021-10-14  5:49 ` Christophe Leroy
2021-10-14  5:49 ` [PATCH v2 01/13] powerpc: Move 'struct ppc64_opd_entry' back into asm/elf.h Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14 21:26   ` Daniel Axtens
2021-10-14 21:26     ` Daniel Axtens
2021-10-14 21:26     ` Daniel Axtens
2021-10-15  5:57   ` Nicholas Piggin
2021-10-15  5:57     ` Nicholas Piggin
2021-10-15  5:57     ` Nicholas Piggin
2021-10-14  5:49 ` [PATCH v2 02/13] powerpc: Rename 'funcaddr' to 'addr' in 'struct ppc64_opd_entry' Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14 21:45   ` Daniel Axtens
2021-10-14 21:45     ` Daniel Axtens
2021-10-15  4:59     ` Christophe Leroy
2021-10-15  4:59       ` Christophe Leroy
2021-10-15  6:01   ` Nicholas Piggin
2021-10-15  6:01     ` Nicholas Piggin
2021-10-15  6:01     ` Nicholas Piggin
2021-10-14  5:49 ` [PATCH v2 03/13] powerpc: Remove func_descr_t Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14 22:17   ` Daniel Axtens
2021-10-14 22:17     ` Daniel Axtens
2021-10-15  5:19     ` Christophe Leroy
2021-10-15  5:19       ` Christophe Leroy
2021-10-15  6:11       ` Nicholas Piggin
2021-10-15  6:11         ` Nicholas Piggin
2021-10-15  6:11         ` Nicholas Piggin
2021-10-14  5:49 ` [PATCH v2 04/13] powerpc: Prepare func_desc_t for refactorisation Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49 ` [PATCH v2 05/13] ia64: Rename 'ip' to 'addr' in 'struct fdesc' Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49 ` [PATCH v2 06/13] asm-generic: Use HAVE_FUNCTION_DESCRIPTORS to define associated stubs Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-15  6:16   ` Nicholas Piggin
2021-10-15  6:16     ` Nicholas Piggin
2021-10-15  6:16     ` Nicholas Piggin
2021-10-15  6:24     ` Christophe Leroy
2021-10-15  6:24       ` Christophe Leroy
2021-10-15  6:24       ` Christophe Leroy
2021-10-15  8:02       ` Nicholas Piggin [this message]
2021-10-15  8:02         ` Nicholas Piggin
2021-10-15  8:02         ` Nicholas Piggin
2021-10-15 11:52         ` Nicholas Piggin
2021-10-15 11:52           ` Nicholas Piggin
2021-10-15 11:52           ` Nicholas Piggin
2021-10-14  5:49 ` [PATCH v2 07/13] asm-generic: Define 'func_desc_t' to commonly describe function descriptors Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  6:52   ` Arnd Bergmann
2021-10-14  6:52     ` Arnd Bergmann
2021-10-14  6:52     ` Arnd Bergmann
2021-10-14  5:49 ` [PATCH v2 08/13] asm-generic: Refactor dereference_[kernel]_function_descriptor() Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-15  6:59   ` Nicholas Piggin
2021-10-15  7:00     ` Nicholas Piggin
2021-10-15  7:00     ` Nicholas Piggin
2021-10-14  5:49 ` [PATCH v2 09/13] lkdtm: Force do_nothing() out of line Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49 ` [PATCH v2 10/13] lkdtm: Really write into kernel text in WRITE_KERN Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:49   ` Christophe Leroy
2021-10-14  5:50 ` [PATCH v2 11/13] lkdtm: Fix lkdtm_EXEC_RODATA() Christophe Leroy
2021-10-14  5:50   ` Christophe Leroy
2021-10-14  5:50   ` Christophe Leroy
2021-10-15 21:32   ` Kees Cook
2021-10-15 21:32     ` Kees Cook
2021-10-15 21:32     ` Kees Cook
2021-10-16  6:41     ` Christophe Leroy
2021-10-16  6:41       ` Christophe Leroy
2021-10-16  6:41       ` Christophe Leroy
2021-10-17  7:50       ` Christophe Leroy
2021-10-17  7:50         ` Christophe Leroy
2021-10-17  7:50         ` Christophe Leroy
2021-10-14  5:50 ` [PATCH v2 12/13] lkdtm: Fix execute_[user]_location() Christophe Leroy
2021-10-14  5:50   ` Christophe Leroy
2021-10-14  5:50   ` Christophe Leroy
2021-10-15 21:31   ` Kees Cook
2021-10-15 21:31     ` Kees Cook
2021-10-15 21:31     ` Kees Cook
2021-10-16  6:42     ` Christophe Leroy
2021-10-16  6:42       ` Christophe Leroy
2021-10-16  6:42       ` Christophe Leroy
2021-11-16 15:07       ` Christophe Leroy
2021-11-16 15:07         ` Christophe Leroy
2021-11-16 15:07         ` Christophe Leroy
2021-10-14  5:50 ` [PATCH v2 13/13] lkdtm: Add a test for function descriptors protection Christophe Leroy
2021-10-14  5:50   ` Christophe Leroy
2021-10-14  5:50   ` Christophe Leroy
2021-10-15 21:35   ` Kees Cook
2021-10-15 21:35     ` Kees Cook
2021-10-15 21:35     ` Kees Cook
2021-10-16  6:28     ` Christophe Leroy
2021-10-16  6:28       ` Christophe Leroy
2021-10-16  6:28       ` Christophe Leroy
2021-10-14 21:35 ` [PATCH v2 00/13] Fix LKDTM for PPC64/IA64/PARISC Daniel Axtens
2021-10-14 21:35   ` Daniel Axtens

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1634284464.kd8scm0ckz.astroid@bobo.none \
    --to=npiggin@gmail.com \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=christophe.leroy@csgroup.eu \
    --cc=deller@gmx.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=keescook@chromium.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.