All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts
@ 2022-01-07 18:46 Christy Lee
  2022-01-07 18:46 ` [PATCH bpf-next v3 1/2] libbpf: rename bpf_prog_attach_xattr() to bpf_prog_attach_opts() Christy Lee
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Christy Lee @ 2022-01-07 18:46 UTC (permalink / raw)
  To: andrii, acme; +Cc: christylee, christyc.y.lee, bpf, kernel-team

All xattr APIs are being dropped, mark bpf_prog_attach_opts() as deprecated
and rename to bpf_prog_attach_xattr(). Replace all usages of the deprecated
function with the new function name.

  [0] Closes: https://github.com/libbpf/libbpf/issues/285

Changelog:
----------
v2 -> v3:
https://lore.kernel.org/all/20220106234639.1418484-2-christylee@fb.com/

* Fixed build break

v1 -> v2:
https://lore.kernel.org/all/20211230000110.1068538-1-christylee@fb.com/

* Used alias instead of returning original function
* Split out selftests to a different commit

Christy Lee (2):
  libbpf: rename bpf_prog_attach_xattr() to bpf_prog_attach_opts()
  selftests/bpf: change bpf_prog_attach_xattr() to
    bpf_prog_attach_opts()

 tools/lib/bpf/bpf.c                                  |  9 +++++++--
 tools/lib/bpf/bpf.h                                  |  4 ++++
 tools/lib/bpf/libbpf.map                             |  1 +
 .../selftests/bpf/prog_tests/cgroup_attach_multi.c   | 12 ++++++------
 4 files changed, 18 insertions(+), 8 deletions(-)

--
2.30.2

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH bpf-next v3 1/2] libbpf: rename bpf_prog_attach_xattr() to bpf_prog_attach_opts()
  2022-01-07 18:46 [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts Christy Lee
@ 2022-01-07 18:46 ` Christy Lee
  2022-01-07 18:46 ` [PATCH bpf-next v3 2/2] selftests/bpf: change " Christy Lee
  2022-01-07 22:00 ` [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts patchwork-bot+netdevbpf
  2 siblings, 0 replies; 4+ messages in thread
From: Christy Lee @ 2022-01-07 18:46 UTC (permalink / raw)
  To: andrii, acme; +Cc: christylee, christyc.y.lee, bpf, kernel-team

All xattr APIs are being dropped, let's converge to the convention used in
high-level APIs and rename bpf_prog_attach_xattr to bpf_prog_attach_opts.

Signed-off-by: Christy Lee <christylee@fb.com>
---
 tools/lib/bpf/bpf.c      | 9 +++++++--
 tools/lib/bpf/bpf.h      | 4 ++++
 tools/lib/bpf/libbpf.map | 1 +
 3 files changed, 12 insertions(+), 2 deletions(-)

diff --git a/tools/lib/bpf/bpf.c b/tools/lib/bpf/bpf.c
index 9b64eed2b003..7e564c4438c9 100644
--- a/tools/lib/bpf/bpf.c
+++ b/tools/lib/bpf/bpf.c
@@ -754,10 +754,10 @@ int bpf_prog_attach(int prog_fd, int target_fd, enum bpf_attach_type type,
 		.flags = flags,
 	);
 
-	return bpf_prog_attach_xattr(prog_fd, target_fd, type, &opts);
+	return bpf_prog_attach_opts(prog_fd, target_fd, type, &opts);
 }
 
-int bpf_prog_attach_xattr(int prog_fd, int target_fd,
+int bpf_prog_attach_opts(int prog_fd, int target_fd,
 			  enum bpf_attach_type type,
 			  const struct bpf_prog_attach_opts *opts)
 {
@@ -778,6 +778,11 @@ int bpf_prog_attach_xattr(int prog_fd, int target_fd,
 	return libbpf_err_errno(ret);
 }
 
+__attribute__((alias("bpf_prog_attach_opts")))
+int bpf_prog_attach_xattr(int prog_fd, int target_fd,
+			  enum bpf_attach_type type,
+			  const struct bpf_prog_attach_opts *opts);
+
 int bpf_prog_detach(int target_fd, enum bpf_attach_type type)
 {
 	union bpf_attr attr;
diff --git a/tools/lib/bpf/bpf.h b/tools/lib/bpf/bpf.h
index 00619f64a040..5dc9fefe73f3 100644
--- a/tools/lib/bpf/bpf.h
+++ b/tools/lib/bpf/bpf.h
@@ -280,6 +280,10 @@ struct bpf_prog_attach_opts {
 
 LIBBPF_API int bpf_prog_attach(int prog_fd, int attachable_fd,
 			       enum bpf_attach_type type, unsigned int flags);
+LIBBPF_API int bpf_prog_attach_opts(int prog_fd, int attachable_fd,
+				     enum bpf_attach_type type,
+				     const struct bpf_prog_attach_opts *opts);
+LIBBPF_DEPRECATED_SINCE(0, 8, "use bpf_prog_attach_opts() instead")
 LIBBPF_API int bpf_prog_attach_xattr(int prog_fd, int attachable_fd,
 				     enum bpf_attach_type type,
 				     const struct bpf_prog_attach_opts *opts);
diff --git a/tools/lib/bpf/libbpf.map b/tools/lib/bpf/libbpf.map
index 529783967793..8262cfca2240 100644
--- a/tools/lib/bpf/libbpf.map
+++ b/tools/lib/bpf/libbpf.map
@@ -247,6 +247,7 @@ LIBBPF_0.0.8 {
 		bpf_link_create;
 		bpf_link_update;
 		bpf_map__set_initial_value;
+		bpf_prog_attach_opts;
 		bpf_program__attach_cgroup;
 		bpf_program__attach_lsm;
 		bpf_program__is_lsm;
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH bpf-next v3 2/2] selftests/bpf: change bpf_prog_attach_xattr() to bpf_prog_attach_opts()
  2022-01-07 18:46 [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts Christy Lee
  2022-01-07 18:46 ` [PATCH bpf-next v3 1/2] libbpf: rename bpf_prog_attach_xattr() to bpf_prog_attach_opts() Christy Lee
@ 2022-01-07 18:46 ` Christy Lee
  2022-01-07 22:00 ` [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts patchwork-bot+netdevbpf
  2 siblings, 0 replies; 4+ messages in thread
From: Christy Lee @ 2022-01-07 18:46 UTC (permalink / raw)
  To: andrii, acme; +Cc: christylee, christyc.y.lee, bpf, kernel-team

bpf_prog_attach_opts() is being deprecated and renamed to
bpf_prog_attach_xattr(). Change all selftests/bpf's uage to the new name.

Signed-off-by: Christy Lee <christylee@fb.com>
---
 .../selftests/bpf/prog_tests/cgroup_attach_multi.c   | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/tools/testing/selftests/bpf/prog_tests/cgroup_attach_multi.c b/tools/testing/selftests/bpf/prog_tests/cgroup_attach_multi.c
index d3e8f729c623..38b3c47293da 100644
--- a/tools/testing/selftests/bpf/prog_tests/cgroup_attach_multi.c
+++ b/tools/testing/selftests/bpf/prog_tests/cgroup_attach_multi.c
@@ -194,14 +194,14 @@ void serial_test_cgroup_attach_multi(void)
 
 	attach_opts.flags = BPF_F_ALLOW_OVERRIDE | BPF_F_REPLACE;
 	attach_opts.replace_prog_fd = allow_prog[0];
-	if (CHECK(!bpf_prog_attach_xattr(allow_prog[6], cg1,
+	if (CHECK(!bpf_prog_attach_opts(allow_prog[6], cg1,
 					 BPF_CGROUP_INET_EGRESS, &attach_opts),
 		  "fail_prog_replace_override", "unexpected success\n"))
 		goto err;
 	CHECK_FAIL(errno != EINVAL);
 
 	attach_opts.flags = BPF_F_REPLACE;
-	if (CHECK(!bpf_prog_attach_xattr(allow_prog[6], cg1,
+	if (CHECK(!bpf_prog_attach_opts(allow_prog[6], cg1,
 					 BPF_CGROUP_INET_EGRESS, &attach_opts),
 		  "fail_prog_replace_no_multi", "unexpected success\n"))
 		goto err;
@@ -209,7 +209,7 @@ void serial_test_cgroup_attach_multi(void)
 
 	attach_opts.flags = BPF_F_ALLOW_MULTI | BPF_F_REPLACE;
 	attach_opts.replace_prog_fd = -1;
-	if (CHECK(!bpf_prog_attach_xattr(allow_prog[6], cg1,
+	if (CHECK(!bpf_prog_attach_opts(allow_prog[6], cg1,
 					 BPF_CGROUP_INET_EGRESS, &attach_opts),
 		  "fail_prog_replace_bad_fd", "unexpected success\n"))
 		goto err;
@@ -217,7 +217,7 @@ void serial_test_cgroup_attach_multi(void)
 
 	/* replacing a program that is not attached to cgroup should fail  */
 	attach_opts.replace_prog_fd = allow_prog[3];
-	if (CHECK(!bpf_prog_attach_xattr(allow_prog[6], cg1,
+	if (CHECK(!bpf_prog_attach_opts(allow_prog[6], cg1,
 					 BPF_CGROUP_INET_EGRESS, &attach_opts),
 		  "fail_prog_replace_no_ent", "unexpected success\n"))
 		goto err;
@@ -225,14 +225,14 @@ void serial_test_cgroup_attach_multi(void)
 
 	/* replace 1st from the top program */
 	attach_opts.replace_prog_fd = allow_prog[0];
-	if (CHECK(bpf_prog_attach_xattr(allow_prog[6], cg1,
+	if (CHECK(bpf_prog_attach_opts(allow_prog[6], cg1,
 					BPF_CGROUP_INET_EGRESS, &attach_opts),
 		  "prog_replace", "errno=%d\n", errno))
 		goto err;
 
 	/* replace program with itself */
 	attach_opts.replace_prog_fd = allow_prog[6];
-	if (CHECK(bpf_prog_attach_xattr(allow_prog[6], cg1,
+	if (CHECK(bpf_prog_attach_opts(allow_prog[6], cg1,
 					BPF_CGROUP_INET_EGRESS, &attach_opts),
 		  "prog_replace", "errno=%d\n", errno))
 		goto err;
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts
  2022-01-07 18:46 [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts Christy Lee
  2022-01-07 18:46 ` [PATCH bpf-next v3 1/2] libbpf: rename bpf_prog_attach_xattr() to bpf_prog_attach_opts() Christy Lee
  2022-01-07 18:46 ` [PATCH bpf-next v3 2/2] selftests/bpf: change " Christy Lee
@ 2022-01-07 22:00 ` patchwork-bot+netdevbpf
  2 siblings, 0 replies; 4+ messages in thread
From: patchwork-bot+netdevbpf @ 2022-01-07 22:00 UTC (permalink / raw)
  To: Christy Lee; +Cc: andrii, acme, christyc.y.lee, bpf, kernel-team

Hello:

This series was applied to bpf/bpf-next.git (master)
by Andrii Nakryiko <andrii@kernel.org>:

On Fri, 7 Jan 2022 10:46:02 -0800 you wrote:
> All xattr APIs are being dropped, mark bpf_prog_attach_opts() as deprecated
> and rename to bpf_prog_attach_xattr(). Replace all usages of the deprecated
> function with the new function name.
> 
>   [0] Closes: https://github.com/libbpf/libbpf/issues/285
> 
> Changelog:
> 
> [...]

Here is the summary with links:
  - [bpf-next,v3,1/2] libbpf: rename bpf_prog_attach_xattr() to bpf_prog_attach_opts()
    https://git.kernel.org/bpf/bpf-next/c/88cbd9222e88
  - [bpf-next,v3,2/2] selftests/bpf: change bpf_prog_attach_xattr() to bpf_prog_attach_opts()
    https://git.kernel.org/bpf/bpf-next/c/f12363ec5a38

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html



^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2022-01-07 22:00 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-07 18:46 [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts Christy Lee
2022-01-07 18:46 ` [PATCH bpf-next v3 1/2] libbpf: rename bpf_prog_attach_xattr() to bpf_prog_attach_opts() Christy Lee
2022-01-07 18:46 ` [PATCH bpf-next v3 2/2] selftests/bpf: change " Christy Lee
2022-01-07 22:00 ` [PATCH bpf-next v3 0/2] libbpf: rename bpf_prog_attach_xattr to bpf_prog_attach_opts patchwork-bot+netdevbpf

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.