All of lore.kernel.org
 help / color / mirror / Atom feed
From: Anshuman Khandual <anshuman.khandual@arm.com>
To: Oscar Salvador <osalvador@suse.de>, David Hildenbrand <david@redhat.com>
Cc: linux-mm@kvack.org, akpm@linux-foundation.org, hca@linux.ibm.com,
	catalin.marinas@arm.com, Vasily Gorbik <gor@linux.ibm.com>,
	Will Deacon <will@kernel.org>, Ard Biesheuvel <ardb@kernel.org>,
	Mark Rutland <mark.rutland@arm.com>,
	linux-arm-kernel@lists.infradead.org, linux-s390@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH V3 0/3] mm/memory_hotplug: Pre-validate the address range with platform
Date: Fri, 22 Jan 2021 11:34:24 +0530	[thread overview]
Message-ID: <1c8c204d-1f96-d3aa-1b7b-ec4cc7b1b79b@arm.com> (raw)
In-Reply-To: <8df4e1e1-1ddd-398e-c9a6-17a67d8a95bc@arm.com>


On 1/20/21 2:07 PM, Anshuman Khandual wrote:
> 
> 
> On 1/19/21 7:10 PM, Oscar Salvador wrote:
>> On Tue, Jan 19, 2021 at 02:33:03PM +0100, David Hildenbrand wrote:
>>> Minor thing, we should make up our mind if we want to call stuff
>>> internally "memhp_" or "mhp". I prefer the latter, because it is shorter.
>>
>> I would rather use the latter as well. I used that in [1].
> 
> Okay, will change all that is 'memhp' as 'mhp' instead.
> 
>> MEMHP_MERGE_RESOURCE should be renamed if we agree on that.
>>
>> [1] https://patchwork.kernel.org/project/linux-mm/cover/20201217130758.11565-1-osalvador@suse.de/
>>

While replacing 'memhp' as 'mhp' in this series, noticed there are
some more 'memhp' scattered around the code from earlier. A mix of
both 'memhp' and 'mhp' might not be a good idea. Hence should we
just change these remaining 'memhp' as 'mhp' as well and possibly
also MEMHP_MERGE_RESOURCE as suggested earlier, in a subsequent
clean up patch ? Would there be a problem with memhp_default_state
being a command line parameter ?

From a tree wide search -

Documentation/admin-guide/kernel-parameters.txt:        memhp_default_state=online/offline
drivers/base/memory.c:int memhp_online_type_from_str(const char *str)
drivers/base/memory.c:  const int online_type = memhp_online_type_from_str(buf);
drivers/base/memory.c:                    online_type_to_str[memhp_default_online_type]);
drivers/base/memory.c:  const int online_type = memhp_online_type_from_str(buf);
drivers/base/memory.c:  memhp_default_online_type = online_type;
include/linux/memory_hotplug.h:extern int memhp_online_type_from_str(const char *str);
include/linux/memory_hotplug.h:extern int memhp_default_online_type;
mm/memory_hotplug.c:int memhp_default_online_type = MMOP_OFFLINE;
mm/memory_hotplug.c:int memhp_default_online_type = MMOP_ONLINE;
mm/memory_hotplug.c:static int __init setup_memhp_default_state(char *str)
mm/memory_hotplug.c:    const int online_type = memhp_online_type_from_str(str);
mm/memory_hotplug.c:            memhp_default_online_type = online_type;
mm/memory_hotplug.c:__setup("memhp_default_state=", setup_memhp_default_state);
mm/memory_hotplug.c:    mem->online_type = memhp_default_online_type;
mm/memory_hotplug.c:    if (memhp_default_online_type != MMOP_OFFLINE)

WARNING: multiple messages have this Message-ID (diff)
From: Anshuman Khandual <anshuman.khandual@arm.com>
To: Oscar Salvador <osalvador@suse.de>, David Hildenbrand <david@redhat.com>
Cc: Mark Rutland <mark.rutland@arm.com>,
	linux-s390@vger.kernel.org, Vasily Gorbik <gor@linux.ibm.com>,
	catalin.marinas@arm.com, hca@linux.ibm.com,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	akpm@linux-foundation.org, Will Deacon <will@kernel.org>,
	Ard Biesheuvel <ardb@kernel.org>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH V3 0/3] mm/memory_hotplug: Pre-validate the address range with platform
Date: Fri, 22 Jan 2021 11:34:24 +0530	[thread overview]
Message-ID: <1c8c204d-1f96-d3aa-1b7b-ec4cc7b1b79b@arm.com> (raw)
In-Reply-To: <8df4e1e1-1ddd-398e-c9a6-17a67d8a95bc@arm.com>


On 1/20/21 2:07 PM, Anshuman Khandual wrote:
> 
> 
> On 1/19/21 7:10 PM, Oscar Salvador wrote:
>> On Tue, Jan 19, 2021 at 02:33:03PM +0100, David Hildenbrand wrote:
>>> Minor thing, we should make up our mind if we want to call stuff
>>> internally "memhp_" or "mhp". I prefer the latter, because it is shorter.
>>
>> I would rather use the latter as well. I used that in [1].
> 
> Okay, will change all that is 'memhp' as 'mhp' instead.
> 
>> MEMHP_MERGE_RESOURCE should be renamed if we agree on that.
>>
>> [1] https://patchwork.kernel.org/project/linux-mm/cover/20201217130758.11565-1-osalvador@suse.de/
>>

While replacing 'memhp' as 'mhp' in this series, noticed there are
some more 'memhp' scattered around the code from earlier. A mix of
both 'memhp' and 'mhp' might not be a good idea. Hence should we
just change these remaining 'memhp' as 'mhp' as well and possibly
also MEMHP_MERGE_RESOURCE as suggested earlier, in a subsequent
clean up patch ? Would there be a problem with memhp_default_state
being a command line parameter ?

From a tree wide search -

Documentation/admin-guide/kernel-parameters.txt:        memhp_default_state=online/offline
drivers/base/memory.c:int memhp_online_type_from_str(const char *str)
drivers/base/memory.c:  const int online_type = memhp_online_type_from_str(buf);
drivers/base/memory.c:                    online_type_to_str[memhp_default_online_type]);
drivers/base/memory.c:  const int online_type = memhp_online_type_from_str(buf);
drivers/base/memory.c:  memhp_default_online_type = online_type;
include/linux/memory_hotplug.h:extern int memhp_online_type_from_str(const char *str);
include/linux/memory_hotplug.h:extern int memhp_default_online_type;
mm/memory_hotplug.c:int memhp_default_online_type = MMOP_OFFLINE;
mm/memory_hotplug.c:int memhp_default_online_type = MMOP_ONLINE;
mm/memory_hotplug.c:static int __init setup_memhp_default_state(char *str)
mm/memory_hotplug.c:    const int online_type = memhp_online_type_from_str(str);
mm/memory_hotplug.c:            memhp_default_online_type = online_type;
mm/memory_hotplug.c:__setup("memhp_default_state=", setup_memhp_default_state);
mm/memory_hotplug.c:    mem->online_type = memhp_default_online_type;
mm/memory_hotplug.c:    if (memhp_default_online_type != MMOP_OFFLINE)

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2021-01-22  6:05 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-18 13:12 [PATCH V3 0/3] mm/memory_hotplug: Pre-validate the address range with platform Anshuman Khandual
2021-01-18 13:12 ` Anshuman Khandual
2021-01-18 13:12 ` [PATCH V3 1/3] mm/memory_hotplug: Prevalidate the address range being added " Anshuman Khandual
2021-01-18 13:12   ` Anshuman Khandual
2021-01-19 12:21   ` David Hildenbrand
2021-01-19 12:21     ` David Hildenbrand
2021-01-20  8:33     ` Anshuman Khandual
2021-01-20  8:33       ` Anshuman Khandual
2021-01-20 10:41       ` David Hildenbrand
2021-01-20 10:41         ` David Hildenbrand
2021-01-20 11:58         ` Oscar Salvador
2021-01-20 11:58           ` Oscar Salvador
2021-01-21  9:23       ` Oscar Salvador
2021-01-21  9:23         ` Oscar Salvador
2021-01-22  9:18   ` David Hildenbrand
2021-01-22  9:18     ` David Hildenbrand
2021-01-22 10:41     ` Anshuman Khandual
2021-01-22 10:41       ` Anshuman Khandual
2021-01-22 10:42       ` David Hildenbrand
2021-01-22 10:42         ` David Hildenbrand
2021-01-22 10:43         ` David Hildenbrand
2021-01-22 10:43           ` David Hildenbrand
2021-01-18 13:13 ` [PATCH V3 2/3] arm64/mm: Define arch_get_mappable_range() Anshuman Khandual
2021-01-18 13:13   ` Anshuman Khandual
2021-01-19 12:24   ` David Hildenbrand
2021-01-19 12:24     ` David Hildenbrand
2021-01-18 13:13 ` [PATCH V3 3/3] s390/mm: " Anshuman Khandual
2021-01-18 13:13   ` Anshuman Khandual
2021-01-19 12:26   ` David Hildenbrand
2021-01-19 12:26     ` David Hildenbrand
2021-01-20  8:28     ` Anshuman Khandual
2021-01-20  8:28       ` Anshuman Khandual
2021-01-20 10:39       ` David Hildenbrand
2021-01-20 10:39         ` David Hildenbrand
2021-01-18 13:13 ` [PATCH RFC] virtio-mem: check against memhp_get_pluggable_range() which memory we can hotplug Anshuman Khandual
2021-01-18 13:13   ` Anshuman Khandual
2021-01-18 13:21   ` Anshuman Khandual
2021-01-18 13:21     ` Anshuman Khandual
2021-01-19 12:27     ` David Hildenbrand
2021-01-19 12:27       ` David Hildenbrand
2021-01-21  9:57     ` David Hildenbrand
2021-01-21  9:57       ` David Hildenbrand
2021-01-22  3:32       ` Anshuman Khandual
2021-01-22  3:32         ` Anshuman Khandual
2021-01-19 13:33 ` [PATCH V3 0/3] mm/memory_hotplug: Pre-validate the address range with platform David Hildenbrand
2021-01-19 13:33   ` David Hildenbrand
2021-01-19 13:40   ` Oscar Salvador
2021-01-19 13:40     ` Oscar Salvador
2021-01-20  8:37     ` Anshuman Khandual
2021-01-20  8:37       ` Anshuman Khandual
2021-01-22  6:04       ` Anshuman Khandual [this message]
2021-01-22  6:04         ` Anshuman Khandual
2021-01-22  8:34         ` David Hildenbrand
2021-01-22  8:34           ` David Hildenbrand

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1c8c204d-1f96-d3aa-1b7b-ec4cc7b1b79b@arm.com \
    --to=anshuman.khandual@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=ardb@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=david@redhat.com \
    --cc=gor@linux.ibm.com \
    --cc=hca@linux.ibm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-s390@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=osalvador@suse.de \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.