All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH]  [ATM]: [he] make code more readable with list_for_each_entry (from Domen Puncer <domen@coderock.org>)
@ 2004-09-21 20:30 chas williams (contractor)
  2004-09-21 22:18 ` David S. Miller
  0 siblings, 1 reply; 2+ messages in thread
From: chas williams (contractor) @ 2004-09-21 20:30 UTC (permalink / raw)
  To: netdev; +Cc: davem, Domen Puncer

dave,

please apply to 2.6.

thanks!

# This is a BitKeeper generated diff -Nru style patch.
#
# ChangeSet
#   2004/09/17 21:09:56-04:00 chas@relax.cmf.nrl.navy.mil 
#   [ATM]: [he] make code more readable with list_for_each_entry (from Domen Puncer <domen@coderock.org>)
# 
# drivers/atm/he.c
#   2004/09/17 21:08:45-04:00 chas@relax.cmf.nrl.navy.mil +2 -3
# 
diff -Nru a/drivers/atm/he.c b/drivers/atm/he.c
--- a/drivers/atm/he.c	2004-09-21 13:48:06 -04:00
+++ b/drivers/atm/he.c	2004-09-21 13:48:06 -04:00
@@ -1963,7 +1963,7 @@
 	struct he_tpd *tpd;
 	int slot, updated = 0;
 #ifdef USE_TPD_POOL
-	struct list_head *p;
+	struct he_tpd *__tpd;
 #endif
 
 	/* 2.1.6 transmit buffer return queue */
@@ -1978,8 +1978,7 @@
 			TBRQ_MULTIPLE(he_dev->tbrq_head) ? " MULTIPLE" : "");
 #ifdef USE_TPD_POOL
 		tpd = NULL;
-		list_for_each(p, &he_dev->outstanding_tpds) {
-			struct he_tpd *__tpd = list_entry(p, struct he_tpd, entry);
+		list_for_each_entry(__tpd, &he_dev->outstanding_tpds, entry) {
 			if (TPD_ADDR(__tpd->status) == TBRQ_TPD(he_dev->tbrq_head)) {
 				tpd = __tpd;
 				list_del(&__tpd->entry);

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH]  [ATM]: [he] make code more readable with list_for_each_entry (from Domen Puncer <domen@coderock.org>)
  2004-09-21 20:30 [PATCH] [ATM]: [he] make code more readable with list_for_each_entry (from Domen Puncer <domen@coderock.org>) chas williams (contractor)
@ 2004-09-21 22:18 ` David S. Miller
  0 siblings, 0 replies; 2+ messages in thread
From: David S. Miller @ 2004-09-21 22:18 UTC (permalink / raw)
  To: chas3; +Cc: chas, netdev, davem, domen

On Tue, 21 Sep 2004 16:30:23 -0400
"chas williams (contractor)" <chas@cmf.nrl.navy.mil> wrote:

> please apply to 2.6.

Applied, thanks.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2004-09-21 22:18 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2004-09-21 20:30 [PATCH] [ATM]: [he] make code more readable with list_for_each_entry (from Domen Puncer <domen@coderock.org>) chas williams (contractor)
2004-09-21 22:18 ` David S. Miller

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.