All of lore.kernel.org
 help / color / mirror / Atom feed
* a quick survey:  "FIELD_SIZEOF" or "MEMBER_SIZE"?
@ 2007-02-03  7:49 Robert P. J. Day
  2007-02-03  8:45 ` Matt Mackall
  0 siblings, 1 reply; 2+ messages in thread
From: Robert P. J. Day @ 2007-02-03  7:49 UTC (permalink / raw)
  To: Linux kernel mailing list


  pardon the interruption but, once upon a time, we were discussing
cleaning up code to use the kernel.h-defined macro "FIELD_SIZEOF".

  some folks suggested that the macro name itself was kind of awkward
as it didn't fit the pattern of "ARRAY_SIZE" defined in that same
header file.

  because of a name clash, "FIELD_SIZE" is not available, but there
was a suggestion of, uh, "MEMBER_SIZE".  :-)

  so, really, those are the two viable choices -- stick with the
current name of FIELD_SIZEOF, or switch to MEMBER_SIZE.  switching is
not a big deal since no one (at least, no one in the current tree)
uses FIELD_SIZEOF as it is, so it's not as if it would be a disruptive
change in the slightest.

  opinions?

rday

-- 
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

http://www.fsdev.dreamhosters.com/wiki/index.php?title=Main_Page
========================================================================

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: a quick survey:  "FIELD_SIZEOF" or "MEMBER_SIZE"?
  2007-02-03  7:49 a quick survey: "FIELD_SIZEOF" or "MEMBER_SIZE"? Robert P. J. Day
@ 2007-02-03  8:45 ` Matt Mackall
  0 siblings, 0 replies; 2+ messages in thread
From: Matt Mackall @ 2007-02-03  8:45 UTC (permalink / raw)
  To: Robert P. J. Day; +Cc: Linux kernel mailing list

On Sat, Feb 03, 2007 at 02:49:34AM -0500, Robert P. J. Day wrote:
> 
>   pardon the interruption but, once upon a time, we were discussing
> cleaning up code to use the kernel.h-defined macro "FIELD_SIZEOF".
> 
>   some folks suggested that the macro name itself was kind of awkward
> as it didn't fit the pattern of "ARRAY_SIZE" defined in that same
> header file.
> 
>   because of a name clash, "FIELD_SIZE" is not available, but there
> was a suggestion of, uh, "MEMBER_SIZE".  :-)
> 
>   so, really, those are the two viable choices -- stick with the
> current name of FIELD_SIZEOF, or switch to MEMBER_SIZE.  switching is
> not a big deal since no one (at least, no one in the current tree)
> uses FIELD_SIZEOF as it is, so it's not as if it would be a disruptive
> change in the slightest.

K&R calls them 'members'. 

We've currently got:

sizeof (built-in)
typeof (built-in)
offsetof (standard macro)
container_of (kernel macro) (1800 of these, ugh)

We don't want:

FIELD_SIZE - they're members
MEMBER_SIZE - inconsistent with the above
member_size - all the above have of
member_size_of - inconsistent with sizeof
member_sizeof - inconsistent _ between words
sizeof_member - same, plus other issues
memsizeof - confusion with memory

So my vote would be for:

membersizeof(a, b)

There's also at least two pieces of code that could use:

membertypeof(a, b)

And please kill all the reimplementations of offsetof while you're at it.

-- 
Mathematics is the supreme nostalgia of our time.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2007-02-03  8:57 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-02-03  7:49 a quick survey: "FIELD_SIZEOF" or "MEMBER_SIZE"? Robert P. J. Day
2007-02-03  8:45 ` Matt Mackall

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.