All of lore.kernel.org
 help / color / mirror / Atom feed
From: Anton Vorontsov <avorontsov@ru.mvista.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH 1/8] Add simple hwconfig infrastructure
Date: Fri, 1 May 2009 00:22:23 +0400	[thread overview]
Message-ID: <20090430202223.GA26421@oksana.dev.rtsoft.ru> (raw)
In-Reply-To: <20090430150050.333d6891.kim.phillips@freescale.com>

On Thu, Apr 30, 2009 at 03:00:50PM -0500, Kim Phillips wrote:
> On Thu, 30 Apr 2009 01:50:00 +0400
> Anton Vorontsov <avorontsov@ru.mvista.com> wrote:
> 
> > This patch implements simple hwconfig infrastructure: an
> > interface for software knobs to control a hardware.
> > 
> > This is very simple implementation, i.e. it is implemented
> > via `hwconfig' environment variable. Later we could write
> > some "hwconfig <enable|disable|list>" commands, ncurses
> > interface for Award BIOS-like interface, and frame-buffer
> > interface for AMI GUI[1] BIOS-like interface with mouse
> > support[2].
> > 
> > Current implementation details/limitations:
> > 
> > 1. Doesn't support options dependencies and mutual exclusion.
> >    We can implement this by integrating apt-get[3] into the
> >    u-boot. But I didn't bother yet.
> > 
> > 2. Since we don't implement hwconfig command, i.e. we're working
> >    with the environement directly, there is no way to tell that
> >    toggling a particular option will need a reboot to take
> >    an effect. So, for now it's advised to always reboot the
> >    target after modifying hwconfig variable.
> > 
> > 3. We support hwconfig options with arguments. For example,
> > 
> >    set hwconfig dr_usb,dr_usb_mode:peripheral,dr_usb_phy_type:ulpi
> 
> so a newbie displays his board's environment and sees the above line
> for the first time.  It's not clear whether they will interpret the
> above as how you would have them:
> 
> >    There are three hwconfig options selected:
> >    1. dr_usb - enable Dual-Role USB controller;
> >    2. dr_usb_mode:peripheral - USB in Function mode;
> >    3. dr_usb_phy_type:ulpi - USB should work with ULPI PHYs.
> 
> or as something starting along the lines of "dr_usb and/or dr_usb_mode
> acquire the 'peripheral' setting,..." and then realize
> "peripheral,dr_usb_phy_type" doesn't make much sense, and have to
> revert to applying different 'weights' to the comma (,) and colon (:)
> token separator characters (to a native English speaker, a colon has
> a higher separation weight than the comma).
> 
> May I suggest something more clearer on the outset, such as:
> 
> set hwconfig "dr_usb=enable; dr_usb_mode=peripheral; dr_usb_phy_type=ulpi"
> 
> or
> 
> set hwconfig "usb=dr; dr_usb_mode=peripheral; dr_usb_phy_type=ulpi"

Yes, much more readable. Will implement.


Thanks!

-- 
Anton Vorontsov
email: cbouatmailru at gmail.com
irc://irc.freenode.net/bd2

  reply	other threads:[~2009-04-30 20:22 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-04-29 21:48 [U-Boot] [PATCH 0/8] hwconfig and some its users (was: Re: [PATCH 2/6] Add FSL "Can use" framework) Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 1/8] Add simple hwconfig infrastructure Anton Vorontsov
2009-04-29 21:59   ` Anton Vorontsov
2009-04-30 20:00   ` Kim Phillips
2009-04-30 20:22     ` Anton Vorontsov [this message]
2009-04-30 22:31   ` Wolfgang Denk
2009-04-30 23:12     ` Anton Vorontsov
2009-05-01  7:33       ` Wolfgang Denk
2009-06-02 20:51   ` Andy Fleming
2009-06-02 22:11     ` Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 2/8] fsl_esdhc: Add device tree fixups Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 3/8] mpc83xx: MPC837XERDB: Add support for FSL eSDHC Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 4/8] mpc83xx: MPC837XEMDS: Fixup eSDHC nodes in device tree Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 5/8] fdt_support, usb: Move fdt_fixup_dr_usb routine to drivers/usb/otg Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 6/8] fsl_dr_usb: Fixup disabled USB controllers nodes in device tree Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 7/8] mpc83xx: MPC8315ERDB: Use hwconfig for board type selection Anton Vorontsov
2009-04-29 21:50 ` [U-Boot] [PATCH 8/8] mpc83xx: MPC837xEMDS: Use hwconfig instead of pci_external_arbiter variable Anton Vorontsov
2009-06-09 20:23 [U-Boot] [PATCH v3 0/8] hwconfig and some its users Anton Vorontsov
2009-06-09 20:25 ` [U-Boot] [PATCH 1/8] Add simple hwconfig infrastructure Anton Vorontsov
2009-07-16 20:26   ` Wolfgang Denk

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090430202223.GA26421@oksana.dev.rtsoft.ru \
    --to=avorontsov@ru.mvista.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.