All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] PM_QOS updates for 2.6.34-rc1
@ 2010-03-14  0:34 640E9920
  2010-03-14  6:26 ` Pavel Machek
  2010-03-14  6:26 ` Pavel Machek
  0 siblings, 2 replies; 12+ messages in thread
From: 640E9920 @ 2010-03-14  0:34 UTC (permalink / raw)
  To: linux-pm, linux-kernel, dwalker, tiwai, bruce.w.allan, aili,
	khilman, pavel, mgross

The following patch series implements to following:
1) pm_qos now uses a handle based implementation.  No more string
compares while walking lists.
2) renames the exports to using more accurate names.
3) updates kernel clients of pm_qos per this change
4) added ascii interface to pmqos recognizing strings formatted in 10
charactor format "0x12345678"
5) added new pm_qos class, "system_bus_throughput"

I would like to see this series make it into 2.6.34 if its not too late. 

I was able to test it on my laptop and comments welcome.

Thank you!

--mgross

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-14  0:34 [PATCH] PM_QOS updates for 2.6.34-rc1 640E9920
  2010-03-14  6:26 ` Pavel Machek
@ 2010-03-14  6:26 ` Pavel Machek
  2010-03-14 20:08   ` Rafael J. Wysocki
                     ` (3 more replies)
  1 sibling, 4 replies; 12+ messages in thread
From: Pavel Machek @ 2010-03-14  6:26 UTC (permalink / raw)
  To: 640E9920
  Cc: linux-pm, linux-kernel, dwalker, tiwai, bruce.w.allan, aili,
	khilman, mgross

On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> The following patch series implements to following:
> 1) pm_qos now uses a handle based implementation.  No more string
> compares while walking lists.
> 2) renames the exports to using more accurate names.
> 3) updates kernel clients of pm_qos per this change
> 4) added ascii interface to pmqos recognizing strings formatted in 10
> charactor format "0x12345678"
> 5) added new pm_qos class, "system_bus_throughput"
> 
> I would like to see this series make it into 2.6.34 if its not too late. 

I believe it is... -rc1 is past us.

Also... the way the patches are structured... that will break bisect,
no?
									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-14  0:34 [PATCH] PM_QOS updates for 2.6.34-rc1 640E9920
@ 2010-03-14  6:26 ` Pavel Machek
  2010-03-14  6:26 ` Pavel Machek
  1 sibling, 0 replies; 12+ messages in thread
From: Pavel Machek @ 2010-03-14  6:26 UTC (permalink / raw)
  To: 640E9920; +Cc: dwalker, tiwai, bruce.w.allan, linux-kernel, linux-pm

On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> The following patch series implements to following:
> 1) pm_qos now uses a handle based implementation.  No more string
> compares while walking lists.
> 2) renames the exports to using more accurate names.
> 3) updates kernel clients of pm_qos per this change
> 4) added ascii interface to pmqos recognizing strings formatted in 10
> charactor format "0x12345678"
> 5) added new pm_qos class, "system_bus_throughput"
> 
> I would like to see this series make it into 2.6.34 if its not too late. 

I believe it is... -rc1 is past us.

Also... the way the patches are structured... that will break bisect,
no?
									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-14  6:26 ` Pavel Machek
  2010-03-14 20:08   ` Rafael J. Wysocki
@ 2010-03-14 20:08   ` Rafael J. Wysocki
  2010-03-19 14:30   ` mark gross
  2010-03-19 14:30   ` mark gross
  3 siblings, 0 replies; 12+ messages in thread
From: Rafael J. Wysocki @ 2010-03-14 20:08 UTC (permalink / raw)
  To: Pavel Machek, Mark Gross
  Cc: linux-pm, linux-kernel, dwalker, tiwai, bruce.w.allan, aili, khilman

On Sunday 14 March 2010, Pavel Machek wrote:
> On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > The following patch series implements to following:
> > 1) pm_qos now uses a handle based implementation.  No more string
> > compares while walking lists.
> > 2) renames the exports to using more accurate names.
> > 3) updates kernel clients of pm_qos per this change
> > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > charactor format "0x12345678"
> > 5) added new pm_qos class, "system_bus_throughput"
> > 
> > I would like to see this series make it into 2.6.34 if its not too late. 
> 
> I believe it is... -rc1 is past us.

It definitely is.

> Also... the way the patches are structured... that will break bisect, no?

Not only that.  Some changelogs would be heartily welcome.  In short, what
change the particular patch is going to make and why it's useful.

Rafael

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-14  6:26 ` Pavel Machek
@ 2010-03-14 20:08   ` Rafael J. Wysocki
  2010-03-14 20:08   ` Rafael J. Wysocki
                     ` (2 subsequent siblings)
  3 siblings, 0 replies; 12+ messages in thread
From: Rafael J. Wysocki @ 2010-03-14 20:08 UTC (permalink / raw)
  To: Pavel Machek, Mark Gross
  Cc: dwalker, tiwai, bruce.w.allan, linux-kernel, linux-pm

On Sunday 14 March 2010, Pavel Machek wrote:
> On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > The following patch series implements to following:
> > 1) pm_qos now uses a handle based implementation.  No more string
> > compares while walking lists.
> > 2) renames the exports to using more accurate names.
> > 3) updates kernel clients of pm_qos per this change
> > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > charactor format "0x12345678"
> > 5) added new pm_qos class, "system_bus_throughput"
> > 
> > I would like to see this series make it into 2.6.34 if its not too late. 
> 
> I believe it is... -rc1 is past us.

It definitely is.

> Also... the way the patches are structured... that will break bisect, no?

Not only that.  Some changelogs would be heartily welcome.  In short, what
change the particular patch is going to make and why it's useful.

Rafael

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-14  6:26 ` Pavel Machek
                     ` (2 preceding siblings ...)
  2010-03-19 14:30   ` mark gross
@ 2010-03-19 14:30   ` mark gross
  2010-03-19 19:49     ` Rafael J. Wysocki
  2010-03-19 19:49     ` Rafael J. Wysocki
  3 siblings, 2 replies; 12+ messages in thread
From: mark gross @ 2010-03-19 14:30 UTC (permalink / raw)
  To: Pavel Machek
  Cc: 640E9920, linux-pm, linux-kernel, dwalker, tiwai, bruce.w.allan,
	aili, khilman

On Sun, Mar 14, 2010 at 07:26:37AM +0100, Pavel Machek wrote:
> On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > The following patch series implements to following:
> > 1) pm_qos now uses a handle based implementation.  No more string
> > compares while walking lists.
> > 2) renames the exports to using more accurate names.
> > 3) updates kernel clients of pm_qos per this change
> > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > charactor format "0x12345678"
> > 5) added new pm_qos class, "system_bus_throughput"
> > 
> > I would like to see this series make it into 2.6.34 if its not too late. 
> 
> I believe it is... -rc1 is past us.

crap.  I'll guess I'll redo them for next then.


 
> Also... the way the patches are structured... that will break bisect,
> no?

Um not sure, how would you recomend I structure them?

--mgross

> 									Pavel
> -- 
> (english) http://www.livejournal.com/~pavelmachek
> (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-14  6:26 ` Pavel Machek
  2010-03-14 20:08   ` Rafael J. Wysocki
  2010-03-14 20:08   ` Rafael J. Wysocki
@ 2010-03-19 14:30   ` mark gross
  2010-03-19 14:30   ` mark gross
  3 siblings, 0 replies; 12+ messages in thread
From: mark gross @ 2010-03-19 14:30 UTC (permalink / raw)
  To: Pavel Machek
  Cc: dwalker, 640E9920, tiwai, bruce.w.allan, linux-kernel, linux-pm

On Sun, Mar 14, 2010 at 07:26:37AM +0100, Pavel Machek wrote:
> On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > The following patch series implements to following:
> > 1) pm_qos now uses a handle based implementation.  No more string
> > compares while walking lists.
> > 2) renames the exports to using more accurate names.
> > 3) updates kernel clients of pm_qos per this change
> > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > charactor format "0x12345678"
> > 5) added new pm_qos class, "system_bus_throughput"
> > 
> > I would like to see this series make it into 2.6.34 if its not too late. 
> 
> I believe it is... -rc1 is past us.

crap.  I'll guess I'll redo them for next then.


 
> Also... the way the patches are structured... that will break bisect,
> no?

Um not sure, how would you recomend I structure them?

--mgross

> 									Pavel
> -- 
> (english) http://www.livejournal.com/~pavelmachek
> (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-19 14:30   ` mark gross
  2010-03-19 19:49     ` Rafael J. Wysocki
@ 2010-03-19 19:49     ` Rafael J. Wysocki
  2010-03-19 19:52       ` Daniel Walker
  2010-03-19 19:52       ` Daniel Walker
  1 sibling, 2 replies; 12+ messages in thread
From: Rafael J. Wysocki @ 2010-03-19 19:49 UTC (permalink / raw)
  To: mgross
  Cc: Pavel Machek, 640E9920, linux-pm, linux-kernel, dwalker, tiwai,
	bruce.w.allan, aili, khilman

On Friday 19 March 2010, mark gross wrote:
> On Sun, Mar 14, 2010 at 07:26:37AM +0100, Pavel Machek wrote:
> > On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > > The following patch series implements to following:
> > > 1) pm_qos now uses a handle based implementation.  No more string
> > > compares while walking lists.
> > > 2) renames the exports to using more accurate names.
> > > 3) updates kernel clients of pm_qos per this change
> > > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > > charactor format "0x12345678"
> > > 5) added new pm_qos class, "system_bus_throughput"
> > > 
> > > I would like to see this series make it into 2.6.34 if its not too late. 
> > 
> > I believe it is... -rc1 is past us.
> 
> crap.  I'll guess I'll redo them for next then.
> 
> 
>  
> > Also... the way the patches are structured... that will break bisect,
> > no?
> 
> Um not sure, how would you recomend I structure them?

Generally speaking, the kernel should build and should work correctly after
applying each consecutive patch in the series.

Rafael

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-19 14:30   ` mark gross
@ 2010-03-19 19:49     ` Rafael J. Wysocki
  2010-03-19 19:49     ` Rafael J. Wysocki
  1 sibling, 0 replies; 12+ messages in thread
From: Rafael J. Wysocki @ 2010-03-19 19:49 UTC (permalink / raw)
  To: mgross; +Cc: dwalker, 640E9920, tiwai, bruce.w.allan, linux-kernel, linux-pm

On Friday 19 March 2010, mark gross wrote:
> On Sun, Mar 14, 2010 at 07:26:37AM +0100, Pavel Machek wrote:
> > On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > > The following patch series implements to following:
> > > 1) pm_qos now uses a handle based implementation.  No more string
> > > compares while walking lists.
> > > 2) renames the exports to using more accurate names.
> > > 3) updates kernel clients of pm_qos per this change
> > > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > > charactor format "0x12345678"
> > > 5) added new pm_qos class, "system_bus_throughput"
> > > 
> > > I would like to see this series make it into 2.6.34 if its not too late. 
> > 
> > I believe it is... -rc1 is past us.
> 
> crap.  I'll guess I'll redo them for next then.
> 
> 
>  
> > Also... the way the patches are structured... that will break bisect,
> > no?
> 
> Um not sure, how would you recomend I structure them?

Generally speaking, the kernel should build and should work correctly after
applying each consecutive patch in the series.

Rafael

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-19 19:49     ` Rafael J. Wysocki
  2010-03-19 19:52       ` Daniel Walker
@ 2010-03-19 19:52       ` Daniel Walker
  1 sibling, 0 replies; 12+ messages in thread
From: Daniel Walker @ 2010-03-19 19:52 UTC (permalink / raw)
  To: Rafael J. Wysocki
  Cc: mgross, Pavel Machek, 640E9920, linux-pm, linux-kernel, tiwai,
	bruce.w.allan, aili, khilman

On Fri, 2010-03-19 at 20:49 +0100, Rafael J. Wysocki wrote:
> On Friday 19 March 2010, mark gross wrote:
> > On Sun, Mar 14, 2010 at 07:26:37AM +0100, Pavel Machek wrote:
> > > On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > > > The following patch series implements to following:
> > > > 1) pm_qos now uses a handle based implementation.  No more string
> > > > compares while walking lists.
> > > > 2) renames the exports to using more accurate names.
> > > > 3) updates kernel clients of pm_qos per this change
> > > > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > > > charactor format "0x12345678"
> > > > 5) added new pm_qos class, "system_bus_throughput"
> > > > 
> > > > I would like to see this series make it into 2.6.34 if its not too late. 
> > > 
> > > I believe it is... -rc1 is past us.
> > 
> > crap.  I'll guess I'll redo them for next then.
> > 
> > 
> >  
> > > Also... the way the patches are structured... that will break bisect,
> > > no?
> > 
> > Um not sure, how would you recomend I structure them?
> 
> Generally speaking, the kernel should build and should work correctly after
> applying each consecutive patch in the series.

I think you would need to have the handle based method along side the
old method until all the kernel clients are converted.. Then remove the
old method ..

Daniel


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PATCH] PM_QOS updates for 2.6.34-rc1
  2010-03-19 19:49     ` Rafael J. Wysocki
@ 2010-03-19 19:52       ` Daniel Walker
  2010-03-19 19:52       ` Daniel Walker
  1 sibling, 0 replies; 12+ messages in thread
From: Daniel Walker @ 2010-03-19 19:52 UTC (permalink / raw)
  To: Rafael J. Wysocki; +Cc: 640E9920, tiwai, bruce.w.allan, linux-kernel, linux-pm

On Fri, 2010-03-19 at 20:49 +0100, Rafael J. Wysocki wrote:
> On Friday 19 March 2010, mark gross wrote:
> > On Sun, Mar 14, 2010 at 07:26:37AM +0100, Pavel Machek wrote:
> > > On Sat 2010-03-13 16:34:25, 640E9920 wrote:
> > > > The following patch series implements to following:
> > > > 1) pm_qos now uses a handle based implementation.  No more string
> > > > compares while walking lists.
> > > > 2) renames the exports to using more accurate names.
> > > > 3) updates kernel clients of pm_qos per this change
> > > > 4) added ascii interface to pmqos recognizing strings formatted in 10
> > > > charactor format "0x12345678"
> > > > 5) added new pm_qos class, "system_bus_throughput"
> > > > 
> > > > I would like to see this series make it into 2.6.34 if its not too late. 
> > > 
> > > I believe it is... -rc1 is past us.
> > 
> > crap.  I'll guess I'll redo them for next then.
> > 
> > 
> >  
> > > Also... the way the patches are structured... that will break bisect,
> > > no?
> > 
> > Um not sure, how would you recomend I structure them?
> 
> Generally speaking, the kernel should build and should work correctly after
> applying each consecutive patch in the series.

I think you would need to have the handle based method along side the
old method until all the kernel clients are converted.. Then remove the
old method ..

Daniel

^ permalink raw reply	[flat|nested] 12+ messages in thread

* [PATCH] PM_QOS updates for 2.6.34-rc1
@ 2010-03-14  0:34 640E9920
  0 siblings, 0 replies; 12+ messages in thread
From: 640E9920 @ 2010-03-14  0:34 UTC (permalink / raw)
  To: linux-pm, linux-kernel, dwalker, tiwai, bruce.w.allan, aili, khilman

The following patch series implements to following:
1) pm_qos now uses a handle based implementation.  No more string
compares while walking lists.
2) renames the exports to using more accurate names.
3) updates kernel clients of pm_qos per this change
4) added ascii interface to pmqos recognizing strings formatted in 10
charactor format "0x12345678"
5) added new pm_qos class, "system_bus_throughput"

I would like to see this series make it into 2.6.34 if its not too late. 

I was able to test it on my laptop and comments welcome.

Thank you!

--mgross

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2010-03-19 19:52 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-03-14  0:34 [PATCH] PM_QOS updates for 2.6.34-rc1 640E9920
2010-03-14  6:26 ` Pavel Machek
2010-03-14  6:26 ` Pavel Machek
2010-03-14 20:08   ` Rafael J. Wysocki
2010-03-14 20:08   ` Rafael J. Wysocki
2010-03-19 14:30   ` mark gross
2010-03-19 14:30   ` mark gross
2010-03-19 19:49     ` Rafael J. Wysocki
2010-03-19 19:49     ` Rafael J. Wysocki
2010-03-19 19:52       ` Daniel Walker
2010-03-19 19:52       ` Daniel Walker
  -- strict thread matches above, loose matches on Subject: below --
2010-03-14  0:34 640E9920

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.