All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@adurom.com>
To: linux-wireless@vger.kernel.org
Subject: [RFC PATCH 00/27] mac80211: create mac80211_ prefix
Date: Sun, 29 May 2011 23:03:55 +0300	[thread overview]
Message-ID: <20110529195022.16479.71762.stgit@localhost6.localdomain6> (raw)

It has always annoyed me that mac80211 uses ieee80211_ prefix. For some time
already I have been planning to try to do something about it and finally I
started it. Here's my first shot at it. 

In this patchset I first fix some issues I found from the drivers, then
create mac80211-compat.h to make the transition as smooth as possible and
then start changing mac80211 itself.

I now changed only parts of mac80211_i.h, I anticipate there will be still
three or four patchsets before mac80211 has been converted. Once that is done
I'm planning to start converting the drivers, one at a time. Unless driver
maintainers beat me to it, of course. I'm hoping that the conversion would be
fast enough so that mac80211-compat.h would not be included in any of the
official linux releases.

But what do people think? Is this worth the effort?

Or have I drank too much coke and totally lost my mind? ;)

---

Kalle Valo (27):
      iwlegacy: fix stop/wake queue hacks
      iwlwifi: fix stop/wake queue hacks
      zd1211rw: include mac80211.h from zd_chip.h
      rtlwifi: include mac80211.h from core.h
      mac80211: switch mac80211.h to use mac80211 prefix
      mac80211: rename ieee80211_i.h to mac80211_i.h
      mac80211: rename ieee80211_local to mac80211_local
      mac80211: rename ieee80211_fragment_entry to mac80211_fragment_entry
      mac80211: rename ieee80211_bss to mac80211_bss
      mac80211: rename ieee80211_tx_data to mac80211_tx_data
      mac80211: rename ieee80211_packet_rx_flags to mac80211_packet_rx_flags
      mac80211: rename ieee80211_rx_flags to mac80211_i_rx_flags
      mac80211: rename ieee80211_rx_data to mac80211_rx_data
      mac80211: rename ieee80211_if_ap to mac80211_if_ap
      mac80211: change ieee80211_if_wds and _vlan to use mac80211 prefix
      mac80211: rename ieee80211_work_type to mac80211_work_type
      mac80211: rename ieee80211_work to mac80211_work
      mac80211: rename ieee80211_sta_flags to mac80211_sta_flags
      mac80211: rename ieee80211_if_managed to mac80211_if_managed
      mac80211: rename ieee80211_if_ibss to mac80211_if_ibss
      mac80211: rename ieee80211_if_mesh to mac80211_if_mesh
      mac80211: rename ieee80211_sub_if_data_flags to mac80211_sub_if_data_flags
      mac80211: rename ieee80211_sdata_state_bits to mac80211_sdata_state_bits
      mac80211: ieee80211_sub_if_data to mac80211_sub_if_data
      mac80211: use mac80211 prefix with rx and tx msg flags
      mac80211: change queue stop reasons to use mac80211 prefix
      mac80211: use mac80211_hw


 drivers/net/wireless/iwlegacy/iwl-helpers.h |    9 
 drivers/net/wireless/iwlwifi/iwl-helpers.h  |    9 
 drivers/net/wireless/rtlwifi/core.h         |    2 
 drivers/net/wireless/zd1211rw/zd_chip.h     |    2 
 include/net/mac80211-compat.h               |  273 +++++
 include/net/mac80211.h                      | 1428 ++++++++++++++-------------
 net/mac80211/agg-rx.c                       |   10 
 net/mac80211/agg-tx.c                       |   60 +
 net/mac80211/cfg.c                          |  176 ++-
 net/mac80211/chan.c                         |   18 
 net/mac80211/debugfs.c                      |   32 -
 net/mac80211/debugfs.h                      |    4 
 net/mac80211/debugfs_key.c                  |    8 
 net/mac80211/debugfs_key.h                  |   12 
 net/mac80211/debugfs_netdev.c               |   56 +
 net/mac80211/debugfs_netdev.h               |   12 
 net/mac80211/debugfs_sta.c                  |    2 
 net/mac80211/driver-ops.h                   |  122 +-
 net/mac80211/driver-trace.h                 |  172 ++-
 net/mac80211/event.c                        |    4 
 net/mac80211/ht.c                           |   18 
 net/mac80211/ibss.c                         |   94 +-
 net/mac80211/ieee80211_i.h                  | 1409 ---------------------------
 net/mac80211/iface.c                        |  106 +-
 net/mac80211/key.c                          |   32 -
 net/mac80211/key.h                          |   22 
 net/mac80211/led.c                          |   44 -
 net/mac80211/led.h                          |   38 -
 net/mac80211/mac80211_i.h                   | 1409 +++++++++++++++++++++++++++
 net/mac80211/main.c                         |   80 +-
 net/mac80211/mesh.c                         |   92 +-
 net/mac80211/mesh.h                         |   86 +-
 net/mac80211/mesh_hwmp.c                    |   48 -
 net/mac80211/mesh_pathtbl.c                 |   34 -
 net/mac80211/mesh_plink.c                   |   32 -
 net/mac80211/mlme.c                         |  426 ++++----
 net/mac80211/offchannel.c                   |   44 -
 net/mac80211/pm.c                           |   12 
 net/mac80211/rate.c                         |   10 
 net/mac80211/rate.h                         |   16 
 net/mac80211/rc80211_minstrel.c             |    8 
 net/mac80211/rc80211_minstrel.h             |    2 
 net/mac80211/rc80211_minstrel_ht.c          |    6 
 net/mac80211/rc80211_pid_algo.c             |    2 
 net/mac80211/rx.c                           |  250 ++---
 net/mac80211/scan.c                         |   86 +-
 net/mac80211/spectmgmt.c                    |    8 
 net/mac80211/sta_info.c                     |   88 +-
 net/mac80211/sta_info.h                     |   28 -
 net/mac80211/status.c                       |   26 
 net/mac80211/tkip.c                         |    4 
 net/mac80211/tx.c                           |  154 +--
 net/mac80211/util.c                         |  172 ++-
 net/mac80211/wep.c                          |   22 
 net/mac80211/wep.h                          |   12 
 net/mac80211/wme.c                          |   10 
 net/mac80211/wme.h                          |    8 
 net/mac80211/work.c                         |  146 +--
 net/mac80211/wpa.c                          |   22 
 net/mac80211/wpa.h                          |   18 
 60 files changed, 3916 insertions(+), 3619 deletions(-)
 create mode 100644 include/net/mac80211-compat.h
 delete mode 100644 net/mac80211/ieee80211_i.h
 create mode 100644 net/mac80211/mac80211_i.h


             reply	other threads:[~2011-05-29 20:04 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-05-29 20:03 Kalle Valo [this message]
2011-05-29 20:04 ` [RFC PATCH 01/27] iwlegacy: fix stop/wake queue hacks Kalle Valo
2011-05-29 20:04 ` [RFC PATCH 02/27] iwlwifi: " Kalle Valo
2011-05-29 20:04 ` [RFC PATCH 03/27] zd1211rw: include mac80211.h from zd_chip.h Kalle Valo
2011-05-31  8:01   ` Walter Goldens
2011-05-31 13:03     ` Jussi Kivilinna
2011-05-31 17:46       ` Walter Goldens
2011-05-31 19:24         ` Jussi Kivilinna
2011-06-04  8:16           ` Walter Goldens
2011-05-29 20:04 ` [RFC PATCH 04/27] rtlwifi: include mac80211.h from core.h Kalle Valo
2011-05-30  4:30   ` Larry Finger
2011-05-29 20:04 ` [RFC PATCH 05/27] mac80211: switch mac80211.h to use mac80211 prefix Kalle Valo
2011-05-29 20:04 ` [RFC PATCH 06/27] mac80211: rename ieee80211_i.h to mac80211_i.h Kalle Valo
2011-05-29 20:04 ` [RFC PATCH 07/27] mac80211: rename ieee80211_local to mac80211_local Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 08/27] mac80211: rename ieee80211_fragment_entry to mac80211_fragment_entry Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 09/27] mac80211: rename ieee80211_bss to mac80211_bss Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 10/27] mac80211: rename ieee80211_tx_data to mac80211_tx_data Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 11/27] mac80211: rename ieee80211_packet_rx_flags to mac80211_packet_rx_flags Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 12/27] mac80211: rename ieee80211_rx_flags to mac80211_i_rx_flags Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 13/27] mac80211: rename ieee80211_rx_data to mac80211_rx_data Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 14/27] mac80211: rename ieee80211_if_ap to mac80211_if_ap Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 15/27] mac80211: change ieee80211_if_wds and _vlan to use mac80211 prefix Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 16/27] mac80211: rename ieee80211_work_type to mac80211_work_type Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 17/27] mac80211: rename ieee80211_work to mac80211_work Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 18/27] mac80211: rename ieee80211_sta_flags to mac80211_sta_flags Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 19/27] mac80211: rename ieee80211_if_managed to mac80211_if_managed Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 20/27] mac80211: rename ieee80211_if_ibss to mac80211_if_ibss Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 21/27] mac80211: rename ieee80211_if_mesh to mac80211_if_mesh Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 22/27] mac80211: rename ieee80211_sub_if_data_flags to mac80211_sub_if_data_flags Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 23/27] mac80211: rename ieee80211_sdata_state_bits to mac80211_sdata_state_bits Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 24/27] mac80211: ieee80211_sub_if_data to mac80211_sub_if_data Kalle Valo
2011-05-29 20:07 ` [RFC PATCH 25/27] mac80211: use mac80211 prefix with rx and tx msg flags Kalle Valo
2011-05-29 20:07 ` [RFC PATCH 26/27] mac80211: change queue stop reasons to use mac80211 prefix Kalle Valo
2011-05-29 20:07 ` [RFC PATCH 27/27] mac80211: use mac80211_hw Kalle Valo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110529195022.16479.71762.stgit@localhost6.localdomain6 \
    --to=kvalo@adurom.com \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.