All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@adurom.com>
To: linux-wireless@vger.kernel.org
Subject: [RFC PATCH 01/27] iwlegacy: fix stop/wake queue hacks
Date: Sun, 29 May 2011 23:04:03 +0300	[thread overview]
Message-ID: <20110529200403.16479.9443.stgit@localhost6.localdomain6> (raw)
In-Reply-To: <20110529195022.16479.71762.stgit@localhost6.localdomain6>

The hacks break once mac80211-compat.h is taken into use. Fix it by adding
an ifdef check.

Signed-off-by: Kalle Valo <kvalo@adurom.com>
---
 drivers/net/wireless/iwlegacy/iwl-helpers.h |    9 +++++++++
 1 files changed, 9 insertions(+), 0 deletions(-)

diff --git a/drivers/net/wireless/iwlegacy/iwl-helpers.h b/drivers/net/wireless/iwlegacy/iwl-helpers.h
index a6effda..5cf23ea 100644
--- a/drivers/net/wireless/iwlegacy/iwl-helpers.h
+++ b/drivers/net/wireless/iwlegacy/iwl-helpers.h
@@ -132,7 +132,16 @@ static inline void iwl_legacy_stop_queue(struct iwl_priv *priv,
 			ieee80211_stop_queue(priv->hw, ac);
 }
 
+#ifdef ieee80211_stop_queue
+#undef ieee80211_stop_queue
+#endif
+
 #define ieee80211_stop_queue DO_NOT_USE_ieee80211_stop_queue
+
+#ifdef ieee80211_wake_queue
+#undef ieee80211_wake_queue
+#endif
+
 #define ieee80211_wake_queue DO_NOT_USE_ieee80211_wake_queue
 
 static inline void iwl_legacy_disable_interrupts(struct iwl_priv *priv)


  reply	other threads:[~2011-05-29 20:04 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-05-29 20:03 [RFC PATCH 00/27] mac80211: create mac80211_ prefix Kalle Valo
2011-05-29 20:04 ` Kalle Valo [this message]
2011-05-29 20:04 ` [RFC PATCH 02/27] iwlwifi: fix stop/wake queue hacks Kalle Valo
2011-05-29 20:04 ` [RFC PATCH 03/27] zd1211rw: include mac80211.h from zd_chip.h Kalle Valo
2011-05-31  8:01   ` Walter Goldens
2011-05-31 13:03     ` Jussi Kivilinna
2011-05-31 17:46       ` Walter Goldens
2011-05-31 19:24         ` Jussi Kivilinna
2011-06-04  8:16           ` Walter Goldens
2011-05-29 20:04 ` [RFC PATCH 04/27] rtlwifi: include mac80211.h from core.h Kalle Valo
2011-05-30  4:30   ` Larry Finger
2011-05-29 20:04 ` [RFC PATCH 05/27] mac80211: switch mac80211.h to use mac80211 prefix Kalle Valo
2011-05-29 20:04 ` [RFC PATCH 06/27] mac80211: rename ieee80211_i.h to mac80211_i.h Kalle Valo
2011-05-29 20:04 ` [RFC PATCH 07/27] mac80211: rename ieee80211_local to mac80211_local Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 08/27] mac80211: rename ieee80211_fragment_entry to mac80211_fragment_entry Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 09/27] mac80211: rename ieee80211_bss to mac80211_bss Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 10/27] mac80211: rename ieee80211_tx_data to mac80211_tx_data Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 11/27] mac80211: rename ieee80211_packet_rx_flags to mac80211_packet_rx_flags Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 12/27] mac80211: rename ieee80211_rx_flags to mac80211_i_rx_flags Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 13/27] mac80211: rename ieee80211_rx_data to mac80211_rx_data Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 14/27] mac80211: rename ieee80211_if_ap to mac80211_if_ap Kalle Valo
2011-05-29 20:05 ` [RFC PATCH 15/27] mac80211: change ieee80211_if_wds and _vlan to use mac80211 prefix Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 16/27] mac80211: rename ieee80211_work_type to mac80211_work_type Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 17/27] mac80211: rename ieee80211_work to mac80211_work Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 18/27] mac80211: rename ieee80211_sta_flags to mac80211_sta_flags Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 19/27] mac80211: rename ieee80211_if_managed to mac80211_if_managed Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 20/27] mac80211: rename ieee80211_if_ibss to mac80211_if_ibss Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 21/27] mac80211: rename ieee80211_if_mesh to mac80211_if_mesh Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 22/27] mac80211: rename ieee80211_sub_if_data_flags to mac80211_sub_if_data_flags Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 23/27] mac80211: rename ieee80211_sdata_state_bits to mac80211_sdata_state_bits Kalle Valo
2011-05-29 20:06 ` [RFC PATCH 24/27] mac80211: ieee80211_sub_if_data to mac80211_sub_if_data Kalle Valo
2011-05-29 20:07 ` [RFC PATCH 25/27] mac80211: use mac80211 prefix with rx and tx msg flags Kalle Valo
2011-05-29 20:07 ` [RFC PATCH 26/27] mac80211: change queue stop reasons to use mac80211 prefix Kalle Valo
2011-05-29 20:07 ` [RFC PATCH 27/27] mac80211: use mac80211_hw Kalle Valo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110529200403.16479.9443.stgit@localhost6.localdomain6 \
    --to=kvalo@adurom.com \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.