All of lore.kernel.org
 help / color / mirror / Atom feed
From: Tony Lindgren <tony@atomide.com>
To: Peter Ujfalusi <peter.ujfalusi@ti.com>
Cc: Liam Girdwood <lrg@ti.com>,
	Mark Brown <broonie@opensource.wolfsonmicro.com>,
	Samuel Ortiz <sameo@linux.intel.com>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	linux-input@vger.kernel.org, linux-omap@vger.kernel.org,
	linux-kernel@vger.kernel.org, alsa-devel@alsa-project.org
Subject: Re: [PATCH v2 03/12] OMAP3: Move common pmic configuration to pmic-common
Date: Tue, 7 Jun 2011 17:45:35 +0300	[thread overview]
Message-ID: <20110607144534.GA27477@atomide.com> (raw)
In-Reply-To: <1307456297-15010-4-git-send-email-peter.ujfalusi@ti.com>

* Peter Ujfalusi <peter.ujfalusi@ti.com> [110607 17:14]:
> Reduce the amount of duplicated code by moving the common
> configuration for twl4030/5030/tpsxx to the pmic-common file.
> Use the omap3_pmic_config function from board files to
> properly configure the PMIC with the common fields.
...

> --- a/arch/arm/mach-omap2/pmic-common.h
> +++ b/arch/arm/mach-omap2/pmic-common.h
> @@ -2,6 +2,9 @@
>  #define __OMAP_PMIC_COMMON__
>  
>  #define TWL_COMMON_PDATA_USB		(1 << 0)
> +#define TWL_COMMON_PDATA_BCI		(1 << 1)
> +#define TWL_COMMON_PDATA_MADC		(1 << 2)
> +#define TWL_COMMON_PDATA_CODEC		(1 << 3)

This is looking good, thanks for cleaning up the twl bloat in
board-*.c files :)

Maybe already define TWL_COMMON_PDATA_AUDIO here so you can
drop most of patch 7/12?

If you need both then you can temporarily have:

#define TWL_COMMON_PDATA_CODEC	TWL_COMMON_PDATA_AUDIO

Regards,

Tony

WARNING: multiple messages have this Message-ID (diff)
From: Tony Lindgren <tony@atomide.com>
To: Peter Ujfalusi <peter.ujfalusi@ti.com>
Cc: alsa-devel@alsa-project.org,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Samuel Ortiz <sameo@linux.intel.com>,
	Mark Brown <broonie@opensource.wolfsonmicro.com>,
	linux-kernel@vger.kernel.org, linux-input@vger.kernel.org,
	linux-omap@vger.kernel.org, Liam Girdwood <lrg@ti.com>
Subject: Re: [PATCH v2 03/12] OMAP3: Move common pmic configuration to pmic-common
Date: Tue, 7 Jun 2011 17:45:35 +0300	[thread overview]
Message-ID: <20110607144534.GA27477@atomide.com> (raw)
In-Reply-To: <1307456297-15010-4-git-send-email-peter.ujfalusi@ti.com>

* Peter Ujfalusi <peter.ujfalusi@ti.com> [110607 17:14]:
> Reduce the amount of duplicated code by moving the common
> configuration for twl4030/5030/tpsxx to the pmic-common file.
> Use the omap3_pmic_config function from board files to
> properly configure the PMIC with the common fields.
...

> --- a/arch/arm/mach-omap2/pmic-common.h
> +++ b/arch/arm/mach-omap2/pmic-common.h
> @@ -2,6 +2,9 @@
>  #define __OMAP_PMIC_COMMON__
>  
>  #define TWL_COMMON_PDATA_USB		(1 << 0)
> +#define TWL_COMMON_PDATA_BCI		(1 << 1)
> +#define TWL_COMMON_PDATA_MADC		(1 << 2)
> +#define TWL_COMMON_PDATA_CODEC		(1 << 3)

This is looking good, thanks for cleaning up the twl bloat in
board-*.c files :)

Maybe already define TWL_COMMON_PDATA_AUDIO here so you can
drop most of patch 7/12?

If you need both then you can temporarily have:

#define TWL_COMMON_PDATA_CODEC	TWL_COMMON_PDATA_AUDIO

Regards,

Tony

  reply	other threads:[~2011-06-07 14:45 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-06-07 14:18 [PATCH v2 00/12] MFD/ASoC/Input: TWL4030/TWL60X0 changes Peter Ujfalusi
2011-06-07 14:18 ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 01/12] OMAP: New pmic-common for common TWL configuration Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 02/12] OMAP4: Move common twl6030 configuration to pmic-common Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 03/12] OMAP3: Move common pmic " Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:45   ` Tony Lindgren [this message]
2011-06-07 14:45     ` Tony Lindgren
2011-06-08  6:51     ` Peter Ujfalusi
2011-06-08  6:51       ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 04/12] OMAP3: Move common regulator " Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 05/12] MFD: twl4030-codec: Rename internals from codec to audio Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 06/12] MFD: twl4030-codec -> twl4030-audio: Rename the driver Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 07/12] MFD: twl4030-audio: Rename platform data Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 08/12] mfd: twl6040: Add initial support Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 09/12] ASoC: twl6040: Convert into TWL6040 MFD child Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 10/12] MFD: twl6040: Change platform data for soc codec driver Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 11/12] input: Add initial support for TWL6040 vibrator Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi
2011-06-07 14:18 ` [PATCH v2 12/12] OMAP4: SDP4430: Add twl6040 vibrator platform support Peter Ujfalusi
2011-06-07 14:18   ` Peter Ujfalusi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110607144534.GA27477@atomide.com \
    --to=tony@atomide.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@opensource.wolfsonmicro.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=lrg@ti.com \
    --cc=peter.ujfalusi@ti.com \
    --cc=sameo@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.