All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v5 00/18] Sequencer for inclusion
@ 2011-08-01 18:06 Ramkumar Ramachandra
  2011-08-01 18:06 ` [PATCH 01/18] advice: Introduce error_resolve_conflict Ramkumar Ramachandra
                   ` (17 more replies)
  0 siblings, 18 replies; 44+ messages in thread
From: Ramkumar Ramachandra @ 2011-08-01 18:06 UTC (permalink / raw)
  To: Junio C Hamano
  Cc: Git List, Jonathan Nieder, Christian Couder, Daniel Barkalow, Jeff King

Hi,

This is yet another iteration, with few improvements since last time.
Some minor nits pointed out by Jonathan and Christian are now fixed.

One additional detail: while playing with my generalized sequencer, I
noticed a couple of embarrassing bugs in the tests -- "malformed
instruction sheet 1" and "malformed instruction sheet 2" were picking
"base..picked" instead of "base..anotherpick".  Fixed now.

Thanks.

-- Ram

Ramkumar Ramachandra (18):
  advice: Introduce error_resolve_conflict
  config: Introduce functions to write non-standard file
  revert: Simplify and inline add_message_to_msg
  revert: Don't check lone argument in get_encoding
  revert: Rename no_replay to record_origin
  revert: Eliminate global "commit" variable
  revert: Introduce struct to keep command-line options
  revert: Separate cmdline parsing from functional code
  revert: Don't create invalid replay_opts in parse_args
  revert: Save data for continuing after conflict resolution
  revert: Save command-line options for continuing operation
  revert: Make pick_commits functionally act on a commit list
  revert: Introduce --reset to remove sequencer state
  reset: Make reset remove the sequencer state
  revert: Remove sequencer state when no commits are pending
  revert: Don't implicitly stomp pending sequencer operation
  revert: Introduce --continue to continue the operation
  revert: Propagate errors upwards from do_pick_commit

 Documentation/git-cherry-pick.txt |    6 +
 Documentation/git-revert.txt      |    6 +
 Documentation/sequencer.txt       |    9 +
 Makefile                          |    2 +
 advice.c                          |   31 ++-
 advice.h                          |    3 +-
 branch.c                          |    2 +
 builtin/revert.c                  |  735 +++++++++++++++++++++++++++++--------
 cache.h                           |    2 +
 config.c                          |   36 ++-
 sequencer.c                       |   19 +
 sequencer.h                       |   20 +
 t/7106-reset-sequence.sh          |   44 +++
 t/t3510-cherry-pick-sequence.sh   |  214 +++++++++++
 14 files changed, 958 insertions(+), 171 deletions(-)
 create mode 100644 Documentation/sequencer.txt
 create mode 100644 sequencer.c
 create mode 100644 sequencer.h
 create mode 100755 t/7106-reset-sequence.sh
 create mode 100755 t/t3510-cherry-pick-sequence.sh

-- 
1.7.4.rc1.7.g2cf08.dirty

^ permalink raw reply	[flat|nested] 44+ messages in thread
* [PATCH 00/18] Sequencer for inclusion v6
@ 2011-08-04 10:38 Ramkumar Ramachandra
  2011-08-04 10:39 ` [PATCH 17/18] revert: Introduce --continue to continue the operation Ramkumar Ramachandra
  0 siblings, 1 reply; 44+ messages in thread
From: Ramkumar Ramachandra @ 2011-08-04 10:38 UTC (permalink / raw)
  To: Junio C Hamano
  Cc: Git List, Jonathan Nieder, Christian Couder, Daniel Barkalow, Jeff King

Hi,

Apart from the minor style changes, there are two big hilights in this
iteration of the series:
1. The "--continue complains when there are unresolved conflicts" test
is fixed.  I'd written "base..picked" instead of "base..anotherpick"
earlier.
2. Special handling for the last line in the instruction sheet (when
it is not terminated by a newline).  See [1] for an especially
convincing explanation from Junio.

All the changes made in this iteration are a direct result of
Christian's reviews -- a big thanks.

Thanks for reading.

-- Ram

[1]: http://mid.gmane.org/7v4o1ycsi4.fsf@alter.siamese.dyndns.org

Ramkumar Ramachandra (18):
  advice: Introduce error_resolve_conflict
  config: Introduce functions to write non-standard file
  revert: Simplify and inline add_message_to_msg
  revert: Don't check lone argument in get_encoding
  revert: Rename no_replay to record_origin
  revert: Eliminate global "commit" variable
  revert: Introduce struct to keep command-line options
  revert: Separate cmdline parsing from functional code
  revert: Don't create invalid replay_opts in parse_args
  revert: Save data for continuing after conflict resolution
  revert: Save command-line options for continuing operation
  revert: Make pick_commits functionally act on a commit list
  revert: Introduce --reset to remove sequencer state
  reset: Make reset remove the sequencer state
  revert: Remove sequencer state when no commits are pending
  revert: Don't implicitly stomp pending sequencer operation
  revert: Introduce --continue to continue the operation
  revert: Propagate errors upwards from do_pick_commit

 Documentation/git-cherry-pick.txt |    6 +
 Documentation/git-revert.txt      |    6 +
 Documentation/sequencer.txt       |    9 +
 Makefile                          |    2 +
 advice.c                          |   31 ++-
 advice.h                          |    3 +-
 branch.c                          |    2 +
 builtin/revert.c                  |  737 +++++++++++++++++++++++++++++--------
 cache.h                           |    2 +
 config.c                          |   36 ++-
 sequencer.c                       |   19 +
 sequencer.h                       |   20 +
 t/7106-reset-sequence.sh          |   44 +++
 t/t3510-cherry-pick-sequence.sh   |  214 +++++++++++
 14 files changed, 960 insertions(+), 171 deletions(-)
 create mode 100644 Documentation/sequencer.txt
 create mode 100644 sequencer.c
 create mode 100644 sequencer.h
 create mode 100755 t/7106-reset-sequence.sh
 create mode 100755 t/t3510-cherry-pick-sequence.sh

-- 
1.7.6.351.gb35ac.dirty

^ permalink raw reply	[flat|nested] 44+ messages in thread
* [PATCH 00/18] Sequencer for inclusion v4
@ 2011-07-28 16:52 Ramkumar Ramachandra
  2011-07-28 16:52 ` [PATCH 17/18] revert: Introduce --continue to continue the operation Ramkumar Ramachandra
  0 siblings, 1 reply; 44+ messages in thread
From: Ramkumar Ramachandra @ 2011-07-28 16:52 UTC (permalink / raw)
  To: Junio C Hamano
  Cc: Git List, Jonathan Nieder, Christian Couder, Daniel Barkalow, Jeff King

Hi,

There were more style nits pointed out in v3: I learnt my lesson and
ran checkpatch.pl this time.  Apart these minor stylistic changes, the
other changes are:
1. Minor improvements to commit messages.
2. Tests now cleanup first, so one failing test doesn't take
everything else down.
3. A rebase that moves "revert: Propogate errors upwards from
do_pick_commit" to the end of the series.  A big thanks to Jonathan
for performing the rebase for me.

Thanks for reading.

-- Ram

Ramkumar Ramachandra (18):
  advice: Introduce error_resolve_conflict
  config: Introduce functions to write non-standard file
  revert: Simplify and inline add_message_to_msg
  revert: Don't check lone argument in get_encoding
  revert: Rename no_replay to record_origin
  revert: Eliminate global "commit" variable
  revert: Introduce struct to keep command-line options
  revert: Separate cmdline parsing from functional code
  revert: Don't create invalid replay_opts in parse_args
  revert: Save data for continuing after conflict resolution
  revert: Save command-line options for continuing operation
  revert: Make pick_commits functionally act on a commit list
  revert: Introduce --reset to remove sequencer state
  reset: Make reset remove the sequencer state
  revert: Remove sequencer state when no commits are pending
  revert: Don't implictly stomp pending sequencer operation
  revert: Introduce --continue to continue the operation
  revert: Propogate errors upwards from do_pick_commit

 Documentation/git-cherry-pick.txt |    6 +
 Documentation/git-revert.txt      |    6 +
 Documentation/sequencer.txt       |    9 +
 Makefile                          |    2 +
 advice.c                          |   31 ++-
 advice.h                          |    3 +-
 branch.c                          |    2 +
 builtin/revert.c                  |  736 +++++++++++++++++++++++++++++--------
 cache.h                           |    2 +
 config.c                          |   36 ++-
 sequencer.c                       |   19 +
 sequencer.h                       |   20 +
 t/7106-reset-sequence.sh          |   43 +++
 t/t3510-cherry-pick-sequence.sh   |  225 +++++++++++
 14 files changed, 969 insertions(+), 171 deletions(-)
 create mode 100644 Documentation/sequencer.txt
 create mode 100644 sequencer.c
 create mode 100644 sequencer.h
 create mode 100755 t/7106-reset-sequence.sh
 create mode 100755 t/t3510-cherry-pick-sequence.sh

-- 
1.7.4.rc1.7.g2cf08.dirty

^ permalink raw reply	[flat|nested] 44+ messages in thread

end of thread, other threads:[~2011-08-09  5:27 UTC | newest]

Thread overview: 44+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-08-01 18:06 [PATCH v5 00/18] Sequencer for inclusion Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 01/18] advice: Introduce error_resolve_conflict Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 02/18] config: Introduce functions to write non-standard file Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 03/18] revert: Simplify and inline add_message_to_msg Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 04/18] revert: Don't check lone argument in get_encoding Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 05/18] revert: Rename no_replay to record_origin Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 06/18] revert: Eliminate global "commit" variable Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 07/18] revert: Introduce struct to keep command-line options Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 08/18] revert: Separate cmdline parsing from functional code Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 09/18] revert: Don't create invalid replay_opts in parse_args Ramkumar Ramachandra
2011-08-02  6:28   ` Christian Couder
2011-08-02  6:41     ` Christian Couder
2011-08-04  9:34       ` Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 10/18] revert: Save data for continuing after conflict resolution Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 11/18] revert: Save command-line options for continuing operation Ramkumar Ramachandra
2011-08-04  4:05   ` Christian Couder
2011-08-04  9:25     ` Ramkumar Ramachandra
2011-08-01 18:06 ` [PATCH 12/18] revert: Make pick_commits functionally act on a commit list Ramkumar Ramachandra
2011-08-01 18:07 ` [PATCH 13/18] revert: Introduce --reset to remove sequencer state Ramkumar Ramachandra
2011-08-01 18:07 ` [PATCH 14/18] reset: Make reset remove the " Ramkumar Ramachandra
2011-08-01 18:07 ` [PATCH 15/18] revert: Remove sequencer state when no commits are pending Ramkumar Ramachandra
2011-08-01 18:07 ` [PATCH 16/18] revert: Don't implicitly stomp pending sequencer operation Ramkumar Ramachandra
2011-08-01 18:07 ` [PATCH 17/18] revert: Introduce --continue to continue the operation Ramkumar Ramachandra
2011-08-01 18:31   ` Ramkumar Ramachandra
2011-08-02  2:36   ` Christian Couder
2011-08-02  2:47     ` Christian Couder
2011-08-02  2:51       ` Christian Couder
2011-08-02  4:41         ` Ramkumar Ramachandra
2011-08-04 10:02         ` Ramkumar Ramachandra
2011-08-02  6:24   ` Christian Couder
2011-08-04  4:57   ` Christian Couder
2011-08-04  9:22     ` Ramkumar Ramachandra
2011-08-01 18:07 ` [PATCH 18/18] revert: Propagate errors upwards from do_pick_commit Ramkumar Ramachandra
  -- strict thread matches above, loose matches on Subject: below --
2011-08-04 10:38 [PATCH 00/18] Sequencer for inclusion v6 Ramkumar Ramachandra
2011-08-04 10:39 ` [PATCH 17/18] revert: Introduce --continue to continue the operation Ramkumar Ramachandra
2011-08-08  7:31   ` Christian Couder
2011-08-08  8:24     ` Ramkumar Ramachandra
2011-08-08 16:28       ` Junio C Hamano
2011-08-09  5:26         ` Ramkumar Ramachandra
2011-07-28 16:52 [PATCH 00/18] Sequencer for inclusion v4 Ramkumar Ramachandra
2011-07-28 16:52 ` [PATCH 17/18] revert: Introduce --continue to continue the operation Ramkumar Ramachandra
2011-07-31 15:51   ` Christian Couder
2011-08-01 17:48     ` Ramkumar Ramachandra
2011-08-03 13:34       ` Jonathan Nieder
2011-08-03 17:30       ` Junio C Hamano
2011-08-03 17:59         ` Ramkumar Ramachandra

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.