All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 00/17] Some work on quickstart driver in staging
@ 2012-01-11 22:22 Szymon Janc
  2012-01-11 22:27 ` Szymon Janc
                   ` (7 more replies)
  0 siblings, 8 replies; 9+ messages in thread
From: Szymon Janc @ 2012-01-11 22:22 UTC (permalink / raw)
  To: kernel-janitors

Changes since v1:
 - use pr_{err,info} instead of custom macros for logs
 - fixed quickstart_buttons_show issue pointed out by Dan
 - Use scnprintf in quickstart_pressed_button_show

Thx for comments.

Szymon Janc (17):
  Staging: quickstart: Some style, whitespaces and typos fixes
  Staging: quickstart: Prefix remaining functions names with
    quickstart_
  Staging: quickstart: Move some code to avoid forward declarations
  Staging: quickstart: Make quickstart_input static
  Staging: quickstart: Cleanup quickstart_acpi_ghid
  Staging: quickstart: Cleanup quickstart_acpi_remove
  Staging: quickstart: Cleanup quickstart_acpi_add
  Staging: quickstart: Cleanup quickstart_acpi_config
  Staging: quickstart: Use switch-case in quickstart_acpi_notify
  Staging: quickstart: Remove unused defines
  Staging: quickstart: Get rid of quickstart_data struct
  Staging: quickstart: Use list.h API for buttons list
  Staging: quickstart: Use %u for printing button id
  Staging: quickstart: Rename quickstart_btn to quickstart_button
  Staging: quickstart: Use pr_err and pr_info for logs
  Staging: quickstart: Use scnprintf in quickstart_pressed_button_show
  Staging: quickstart: Bump driver version to 1.04

 drivers/staging/quickstart/quickstart.c |  369 +++++++++++++++----------------
 1 files changed, 177 insertions(+), 192 deletions(-)

-- 
1.7.8.3



^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
@ 2012-01-11 22:27 ` Szymon Janc
  2012-02-06 18:21 ` Szymon Janc
                   ` (6 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: Szymon Janc @ 2012-01-11 22:27 UTC (permalink / raw)
  To: kernel-janitors

On Wednesday 11 January 2012 23:22:35 Szymon Janc wrote:
> Changes since v1:
>  - use pr_{err,info} instead of custom macros for logs
>  - fixed quickstart_buttons_show issue pointed out by Dan
>  - Use scnprintf in quickstart_pressed_button_show
> 
> Thx for comments.

Opps.  Please ignore
[PATCH 15/16] Staging: quickstart: Add QS_INFO and QS_ERR macros for logs
[PATCH 16/16] Staging: quickstart: Bump driver version to 1.04
in this series...

-- 
Szymon K. Janc
szymon@janc.net.pl


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
  2012-01-11 22:27 ` Szymon Janc
@ 2012-02-06 18:21 ` Szymon Janc
  2012-02-06 21:32 ` Greg Kroah-Hartman
                   ` (5 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: Szymon Janc @ 2012-02-06 18:21 UTC (permalink / raw)
  To: kernel-janitors

Hi Greg,

> Changes since v1:
>  - use pr_{err,info} instead of custom macros for logs
>  - fixed quickstart_buttons_show issue pointed out by Dan
>  - Use scnprintf in quickstart_pressed_button_show

Should I resent those patches to your new email address?
Or they are just waiting in queue?

-- 
Szymon K. Janc
szymon@janc.net.pl


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
  2012-01-11 22:27 ` Szymon Janc
  2012-02-06 18:21 ` Szymon Janc
@ 2012-02-06 21:32 ` Greg Kroah-Hartman
  2012-02-09  1:17 ` Greg KH
                   ` (4 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: Greg Kroah-Hartman @ 2012-02-06 21:32 UTC (permalink / raw)
  To: kernel-janitors

On Mon, Feb 06, 2012 at 07:21:51PM +0100, Szymon Janc wrote:
> Hi Greg,
> 
> > Changes since v1:
> >  - use pr_{err,info} instead of custom macros for logs
> >  - fixed quickstart_buttons_show issue pointed out by Dan
> >  - Use scnprintf in quickstart_pressed_button_show
> 
> Should I resent those patches to your new email address?
> Or they are just waiting in queue?

They are in my to-apply queue, don't worry, they are not lost.

greg k-h

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
                   ` (2 preceding siblings ...)
  2012-02-06 21:32 ` Greg Kroah-Hartman
@ 2012-02-09  1:17 ` Greg KH
  2012-02-09 20:14 ` Szymon Janc
                   ` (3 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: Greg KH @ 2012-02-09  1:17 UTC (permalink / raw)
  To: kernel-janitors

On Wed, Jan 11, 2012 at 11:27:33PM +0100, Szymon Janc wrote:
> On Wednesday 11 January 2012 23:22:35 Szymon Janc wrote:
> > Changes since v1:
> >  - use pr_{err,info} instead of custom macros for logs
> >  - fixed quickstart_buttons_show issue pointed out by Dan
> >  - Use scnprintf in quickstart_pressed_button_show
> > 
> > Thx for comments.
> 
> Opps.  Please ignore
> [PATCH 15/16] Staging: quickstart: Add QS_INFO and QS_ERR macros for logs
> [PATCH 16/16] Staging: quickstart: Bump driver version to 1.04
> in this series...

Ok, I think I got the right ones, please check that I did.

Also, you just created the following build warning, please send me a
patch fixing it up:

drivers/staging/quickstart/quickstart.c: In function ‘quickstart_acpi_ghid’:
drivers/staging/quickstart/quickstart.c:212:5: warning: format ‘%u’ expects argument of type ‘unsigned int’, but argument 3 has type ‘acpi_size’ [-Wformat]

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
                   ` (3 preceding siblings ...)
  2012-02-09  1:17 ` Greg KH
@ 2012-02-09 20:14 ` Szymon Janc
  2012-02-09 20:23 ` Greg KH
                   ` (2 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: Szymon Janc @ 2012-02-09 20:14 UTC (permalink / raw)
  To: kernel-janitors

Hi,

> Ok, I think I got the right ones, please check that I did.

Those 2 (minor) are still not applied

Staging: quickstart: Use scnprintf in quickstart_pressed_button_show
Staging: quickstart: Bump driver version to 1.04

> Also, you just created the following build warning, please send me a
> patch fixing it up:
> 
> drivers/staging/quickstart/quickstart.c: In function
> ‘quickstart_acpi_ghid’: drivers/staging/quickstart/quickstart.c:212:5:
> warning: format ‘%u’ expects argument of type ‘unsigned int’, but argument
> 3 has type ‘acpi_size’ [-Wformat]

acpi_size is u32 or u64 depending on arch, is it ok to just cast it to 
unsigned int for printing?

-- 
Szymon K. Janc
szymon@janc.net.pl


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
                   ` (4 preceding siblings ...)
  2012-02-09 20:14 ` Szymon Janc
@ 2012-02-09 20:23 ` Greg KH
  2012-02-10  6:59 ` Dan Carpenter
  2012-02-10 19:21 ` Szymon Janc
  7 siblings, 0 replies; 9+ messages in thread
From: Greg KH @ 2012-02-09 20:23 UTC (permalink / raw)
  To: kernel-janitors

On Thu, Feb 09, 2012 at 09:14:18PM +0100, Szymon Janc wrote:
> Hi,
> 
> > Ok, I think I got the right ones, please check that I did.
> 
> Those 2 (minor) are still not applied
> 
> Staging: quickstart: Use scnprintf in quickstart_pressed_button_show
> Staging: quickstart: Bump driver version to 1.04

I thought you told me not to apply them?

Anyway, care to resend them so I know exactly what to apply?

> > Also, you just created the following build warning, please send me a
> > patch fixing it up:
> > 
> > drivers/staging/quickstart/quickstart.c: In function
> > ‘quickstart_acpi_ghid’: drivers/staging/quickstart/quickstart.c:212:5:
> > warning: format ‘%u’ expects argument of type ‘unsigned int’, but argument
> > 3 has type ‘acpi_size’ [-Wformat]
> 
> acpi_size is u32 or u64 depending on arch, is it ok to just cast it to 
> unsigned int for printing?

There should be some native type for this, size_t?  Or if it's not
really important, just cast it.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
                   ` (5 preceding siblings ...)
  2012-02-09 20:23 ` Greg KH
@ 2012-02-10  6:59 ` Dan Carpenter
  2012-02-10 19:21 ` Szymon Janc
  7 siblings, 0 replies; 9+ messages in thread
From: Dan Carpenter @ 2012-02-10  6:59 UTC (permalink / raw)
  To: kernel-janitors

[-- Attachment #1: Type: text/plain, Size: 696 bytes --]

On Thu, Feb 09, 2012 at 09:14:18PM +0100, Szymon Janc wrote:
> > Also, you just created the following build warning, please send me a
> > patch fixing it up:
> > 
> > drivers/staging/quickstart/quickstart.c: In function
> > ‘quickstart_acpi_ghid’: drivers/staging/quickstart/quickstart.c:212:5:
> > warning: format ‘%u’ expects argument of type ‘unsigned int’, but argument
> > 3 has type ‘acpi_size’ [-Wformat]
> 
> acpi_size is u32 or u64 depending on arch, is it ok to just cast it to 
> unsigned int for printing?

I don't get this warning on linux-next so I haven't looked at the
code, but unsigned long would be more normal I think.

regards,
dan carpenter

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 836 bytes --]

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH v2 00/17] Some work on quickstart driver in staging
  2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
                   ` (6 preceding siblings ...)
  2012-02-10  6:59 ` Dan Carpenter
@ 2012-02-10 19:21 ` Szymon Janc
  7 siblings, 0 replies; 9+ messages in thread
From: Szymon Janc @ 2012-02-10 19:21 UTC (permalink / raw)
  To: kernel-janitors

On Thursday 09 February 2012 21:23:02 Greg KH wrote:

> > Those 2 (minor) are still not applied
> > 
> > Staging: quickstart: Use scnprintf in quickstart_pressed_button_show
> > Staging: quickstart: Bump driver version to 1.04
> 
> I thought you told me not to apply them?
> 
> Anyway, care to resend them so I know exactly what to apply?

I've accidentally mixed V1 and V2 patches in V2 series and was referring to 
those V1 sent with V2,  but I'll resent them for clarity.

> 
> > > Also, you just created the following build warning, please send me a
> > > patch fixing it up:
> > > 
> > > drivers/staging/quickstart/quickstart.c: In function
> > > ‘quickstart_acpi_ghid’: drivers/staging/quickstart/quickstart.c:212:5:
> > > warning: format ‘%u’ expects argument of type ‘unsigned int’, but
> > > argument 3 has type ‘acpi_size’ [-Wformat]
> > 
> > acpi_size is u32 or u64 depending on arch, is it ok to just cast it to
> > unsigned int for printing?
> 
> There should be some native type for this, size_t?  Or if it's not
> really important, just cast it.

This is how is it defined in <acpi/actypes.h>. I'll just cast it to unsigned 
long for pritning.



One more thing:
there is no TODO for quickstart in staging so I fixed what I 
felt should be fixed (I'm quite a newbie). If you have some comments on what 
still needs to be done to get this driver from staging I'm all ears.

-- 
Szymon K. Janc
szymon@janc.net.pl


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2012-02-10 19:21 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-01-11 22:22 [PATCH v2 00/17] Some work on quickstart driver in staging Szymon Janc
2012-01-11 22:27 ` Szymon Janc
2012-02-06 18:21 ` Szymon Janc
2012-02-06 21:32 ` Greg Kroah-Hartman
2012-02-09  1:17 ` Greg KH
2012-02-09 20:14 ` Szymon Janc
2012-02-09 20:23 ` Greg KH
2012-02-10  6:59 ` Dan Carpenter
2012-02-10 19:21 ` Szymon Janc

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.