All of lore.kernel.org
 help / color / mirror / Atom feed
From: Borislav Petkov <bp@alien8.de>
To: Ingo Molnar <mingo@kernel.org>
Cc: "Luck, Tony" <tony.luck@intel.com>,
	linux-kernel@vger.kernel.org,
	the arch/x86 maintainers <x86@kernel.org>
Subject: Re: [GIT PULL] x86/mce fix (ready for 3.6 merge window)
Date: Wed, 11 Jul 2012 10:31:01 +0200	[thread overview]
Message-ID: <20120711083101.GA23206@liondog.tnic> (raw)
In-Reply-To: <20120711080446.GA17713@gmail.com>

On Wed, Jul 11, 2012 at 10:04:46AM +0200, Ingo Molnar wrote:
> A couple of commit log details:
> 
>  - If it's for v3.6 then the Cc: stable backport is not 
>    justified. Either it's for tip:x86/urgent and then we'll 
>    merge it straight away, or for tip:x86/mce for v3.6 and then 
>    there's no Cc: stable tag.

This could be part of checkpatch - whenever a stable tag is added to a
patch commit msg, it should at least warn the patch author to check with
<Documentation/stable_kernel_rules.txt> first.

>  - This reference to a commit is a bit unusual:
> 
> In commit dad1743e5993f19b3d7e7bd0fb35dc45b5326626
> x86/mce: Only restart instruction after machine check recovery if it is safe
> 
>    the canonical format is something like:
> 
>   In commit dad1743e5993f1 ("x86/mce: Only restart instruction 
>   after machine check recovery if it is safe") ...

Commit referencing in commit messages doesn't come up for the first time
so can we get this as a rule into checkpatch so that we can have unified
commit reference format?

The regex would be probably hairy and generate a couple of false
positives but sure it will help in a lot of other situations.

Also, how many chars of the commit id we keep? The first 12, 14, 15? I'm
thinking of commit id uniqueness sometime far in the future.

>  - We tend to use such an ordering of tags:
> 
>   Signed-off-by: Tony Luck <tony.luck@intel.com>
>   Acked-by: Borislav Petkov <borislav.petkov@amd.com>
>   Cc: stable@kernel.org    # 3.4+
> 
>   I.e. Tested-by and Reported-by tags first (if any), then 
>   author SOB, then SOB chain (if any), then Reviewed-by
>   and Acked-by, then stable tags, then Cc:s.

patch tags order could be checked for in checkpatch too?

[ … ]

>  - Style nit, this:
> 
>        if (mi->restartable == 0)
> 
>    is better written as:
> 
>        if (!mi->restartable)
> 
>    because mi->restartable's role here is not really an integer 
>    value, but a boolean in essence.

Yes, we talked about this but having a bool as a u8 there would add
padding to the struct so it's the same thing, space-wise. It could be
converted to a bitfield if more flags are added/needed.

>  - The 'doit' flag was significantly misnamed when kill_procs() 
>    was written and now it spreads further, it's a totally opaque 
>    name that tells nothing about the role of the flag.
> 
>    How about 'force'?

Even better, make it even more descriptive: 'force_kill' or 'do_kill' or
'really_kill' - this way one knows exactly what one is looking at.

Thanks.

-- 
Regards/Gruss,
    Boris.

  reply	other threads:[~2012-07-11  8:31 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-10 17:50 [GIT PULL] x86/mce fix (ready for 3.6 merge window) Luck, Tony
2012-07-11  8:04 ` Ingo Molnar
2012-07-11  8:31   ` Borislav Petkov [this message]
2012-07-11 16:26   ` Tony Luck
2012-07-11 17:45     ` [GIT PULL v2] " Luck, Tony
2012-07-11 20:53       ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120711083101.GA23206@liondog.tnic \
    --to=bp@alien8.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.