All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lukasz Majewski <l.majewski@samsung.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH v3 00/24] pmic: Redesign PMIC framework to support multiple instances of devices
Date: Fri, 26 Oct 2012 09:29:43 +0200	[thread overview]
Message-ID: <20121026092943.2e498aa6@amdc308.digital.local> (raw)
In-Reply-To: <1350661451-1273-1-git-send-email-l.majewski@samsung.com>

Hi Stefano, Tom,

Any thoughts or ideas for this patch series?

> PMIC framework has been redesigned to support multiple instances of
> power related devices (e.g. fuel gauge, PMICs, chargers, micro USB
> IC, battery).
> 
> Due to that, code at other architectures and boards have been
> adjusted properly.
> 
> New power_init_board() method at ./lib/board.c file has been
> introduced. It is meant to be an architecture dependent function to
> support advanced power management. Since PMIC framework uses lists
> internally to link different devices, its initialization must be done
> just after malloc initialization.
> 
> Please consider commits from this patch set as the example of
> advanced power management for a particular HW (Trats board in this
> case).
> 
> In the new approach PMICs are selected with their names (e.g. 'pmic
> dump MAX8997_PMIC') Presented patch set is a first step to change
> 'pmic' command to more generic (i.e. power) to provide control for
> multiple devices.
> 
> Moreover device's battery is treated as an oridinary "power" device
> (like PMIC). Due to that, framework unification is possible. 
> For even more versalite design, each power device instance can
> specify its parent.
> 
> For trats one can build a following scheme (it can de different for
> other boards): -----------------
> 		--------| BAT		|------------
> 		|	|		|	    |
> 		|	-----------------	    |
> 		|		|		    |
> 	       \|/	       \|/		   \|/
> 	-----------	-----------------	---------
> 	|FG
> |	|MUIC		|	|CHRG	| |
> |	|		| 	|	|
> -----------	-----------------	---------
> 
> Finally, this patch series also comprises of a "namespace" cleanup -
> an attempt to rename "pmic" to "power" to better reflect generality
> of this framework.
> 
> 
> 
> Test HW:
>  - Exynos4210 Trats development board
> 
> 



-- 
Best regards,

Lukasz Majewski

Samsung Poland R&D Center | Linux Platform Group

  parent reply	other threads:[~2012-10-26  7:29 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-10-19 15:43 [U-Boot] [PATCH v3 00/24] pmic: Redesign PMIC framework to support multiple instances of devices Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 01/24] pmic:i2c: Handle PMIC I2C transmission comprising of two bytes Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 02/24] pmic:i2c: Add I2C sensor byte order (big/little) to PMIC framework Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 03/24] pmic:max8997: Switch the MAX8997 PMIC to be used with multibus I2C Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 04/24] pmic: Extend PMIC framework to support multiple instances of PMIC devices Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 05/24] pmic: Introduce power_init_board() method at ./lib/board.c file Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 06/24] pmic: Enable power_board_init() support at TRATS Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 07/24] pmic:chrg: Common information about charger and battery (power_chrg.h) Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 08/24] pmic: Move pmic related code to ./drivers/power directory Lukasz Majewski
2012-10-26 21:25   ` Tom Rini
2012-10-27 21:01     ` Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 09/24] pmic: Extend struct pmic to support battery and charger related operations Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 10/24] pmic:battery: Support for Trats Battery at PMIC framework Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 11/24] pmic:muic: Support for MUIC built into MAX8997 device Lukasz Majewski
2012-10-19 15:43 ` [U-Boot] [PATCH v3 12/24] pmic:fuel-gauge: Support for MAX17042 fuel-gauge Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 13/24] pmic:max8997: Function for calculating LDO internal register value Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 14/24] arm:trats:pmic: Default PMIC(MAX8997) initialization for Samsung's TRATS board Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 15/24] arm:trats:pmic: Enable MUIC (MAX8997) at " Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 16/24] arm:trats:pmic: Enable fuel-gauge (MAX17042) " Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 17/24] arm:trats:pmic: Enable battery support " Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 18/24] pmic:max8997: Support for MAX8997 internal charger control Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 19/24] arm:trats:pmic: Power consumption reduction state for Samsung's TRATS board Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 20/24] arm:trats:pmic: Support for charging battery at " Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 21/24] pmic: Extend PMIC framework to support battery related commands Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 22/24] power:pmic: Rename ./drivers/power/pmic_* to ./drivers/power/power_* files Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 23/24] power:pmic: Rename CONFIG_PMIC* defines to CONFIG_POWER Lukasz Majewski
2012-10-19 15:44 ` [U-Boot] [PATCH v3 24/24] power:pmic: Rename CONFIG_DIALOG_PMIC defines to CONFIG_DIALOG_POWER Lukasz Majewski
2012-10-26  7:29 ` Lukasz Majewski [this message]
2012-10-26 10:34   ` [U-Boot] [PATCH v3 00/24] pmic: Redesign PMIC framework to support multiple instances of devices Stefano Babic
2012-10-26 10:43     ` Lukasz Majewski
2012-10-26 17:32       ` Tom Rini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20121026092943.2e498aa6@amdc308.digital.local \
    --to=l.majewski@samsung.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.