All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/3] mm: rename confusing function names
@ 2013-02-05 17:09 ` Zhang Yanfei
  0 siblings, 0 replies; 22+ messages in thread
From: Zhang Yanfei @ 2013-02-05 17:09 UTC (permalink / raw)
  To: akpm, Linux MM, mgorman, minchan, kamezawa.hiroyu, m.szyprowski
  Cc: linux-kernel

Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages
are horribly badly named, they count present_pages - pages_high within zones
instead of free pages, so why not rename them to reasonable names, not cofusing
people.

patch2 and patch3 are based on patch1. So please apply patch1 first.

Zhang Yanfei (3):
  mm: rename nr_free_zone_pages to nr_free_zone_high_pages
  mm: rename nr_free_buffer_pages to nr_free_buffer_high_pages
  mm: rename nr_free_pagecache_pages to nr_free_pagecache_high_pages

 arch/ia64/mm/contig.c          |    3 ++-
 arch/ia64/mm/discontig.c       |    3 ++-
 drivers/mmc/card/mmc_test.c    |    4 ++--
 fs/buffer.c                    |    2 +-
 fs/nfsd/nfs4state.c            |    2 +-
 fs/nfsd/nfssvc.c               |    2 +-
 include/linux/swap.h           |    4 ++--
 mm/huge_memory.c               |    2 +-
 mm/memory_hotplug.c            |    4 ++--
 mm/page-writeback.c            |    2 +-
 mm/page_alloc.c                |   22 ++++++++++++----------
 net/9p/trans_virtio.c          |    2 +-
 net/ipv4/tcp.c                 |    4 ++--
 net/ipv4/udp.c                 |    2 +-
 net/netfilter/ipvs/ip_vs_ctl.c |    2 +-
 net/sctp/protocol.c            |    2 +-
 16 files changed, 33 insertions(+), 29 deletions(-)

^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2013-02-08 13:35 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-02-05 17:09 [PATCH 0/3] mm: rename confusing function names Zhang Yanfei
2013-02-05 17:09 ` Zhang Yanfei
2013-02-05 17:11 ` [PATCH 1/3] mm: rename nr_free_zone_pages to nr_free_zone_high_pages Zhang Yanfei
2013-02-05 17:11   ` Zhang Yanfei
2013-02-05 17:13 ` [PATCH 2/3] mm: rename nr_free_buffer_pages to nr_free_buffer_high_pages Zhang Yanfei
2013-02-05 17:13   ` Zhang Yanfei
2013-02-05 17:14 ` [PATCH 3/3] mm: rename nr_free_pagecache_pages to nr_free_pagecache_high_pages Zhang Yanfei
2013-02-05 17:14   ` Zhang Yanfei
2013-02-05 19:26 ` [PATCH 0/3] mm: rename confusing function names Johannes Weiner
2013-02-05 19:26   ` Johannes Weiner
2013-02-05 22:13   ` Andrew Morton
2013-02-05 22:13     ` Andrew Morton
2013-02-06  1:06     ` Zhang Yanfei
2013-02-06  1:06       ` Zhang Yanfei
2013-02-06  1:20       ` Andrew Morton
2013-02-06  1:20         ` Andrew Morton
2013-02-06  1:34         ` Zhang Yanfei
2013-02-06  1:34           ` Zhang Yanfei
2013-02-06  1:58           ` Andrew Morton
2013-02-06  1:58             ` Andrew Morton
2013-02-08 13:34           ` Robin Holt
2013-02-08 13:34             ` Robin Holt

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.