All of lore.kernel.org
 help / color / mirror / Atom feed
From: Steffen Trumtrar <s.trumtrar@pengutronix.de>
To: Tomi Valkeinen <tomi.valkeinen@ti.com>
Cc: devicetree-discuss@lists.ozlabs.org,
	Dave Airlie <airlied@linux.ie>,
	Rob Herring <robherring2@gmail.com>,
	linux-fbdev@vger.kernel.org, dri-devel@lists.freedesktop.org,
	Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
	Thierry Reding <thierry.reding@avionic-design.de>,
	Guennady Liakhovetski <g.liakhovetski@gmx.de>,
	linux-media@vger.kernel.org,
	Stephen Warren <swarren@wwwdotorg.org>,
	Florian Tobias Schandinat <FlorianSchandinat@gmx.de>,
	Rob Clark <robdclark@gmail.com>,
	Leela Krishna Amudala <leelakrishna.a@gmail.com>,
	"Mohammed, Afzal" <afzal@ti.com>,
	kernel@pengutronix.de
Subject: Re: [PATCH v17 2/7] video: add display_timing and videomode
Date: Wed, 27 Feb 2013 17:05:40 +0100	[thread overview]
Message-ID: <20130227160540.GA10491@pengutronix.de> (raw)
In-Reply-To: <512E2A1B.6040704@ti.com>

Ah, sorry. Forgot to answer this.

On Wed, Feb 27, 2013 at 05:45:31PM +0200, Tomi Valkeinen wrote:
> Ping.
> 
> On 2013-02-18 16:09, Tomi Valkeinen wrote:
> > Hi Steffen,
> > 
> > On 2013-01-25 11:01, Steffen Trumtrar wrote:
> > 
> >> +/* VESA display monitor timing parameters */
> >> +#define VESA_DMT_HSYNC_LOW		BIT(0)
> >> +#define VESA_DMT_HSYNC_HIGH		BIT(1)
> >> +#define VESA_DMT_VSYNC_LOW		BIT(2)
> >> +#define VESA_DMT_VSYNC_HIGH		BIT(3)
> >> +
> >> +/* display specific flags */
> >> +#define DISPLAY_FLAGS_DE_LOW		BIT(0)	/* data enable flag */
> >> +#define DISPLAY_FLAGS_DE_HIGH		BIT(1)
> >> +#define DISPLAY_FLAGS_PIXDATA_POSEDGE	BIT(2)	/* drive data on pos. edge */
> >> +#define DISPLAY_FLAGS_PIXDATA_NEGEDGE	BIT(3)	/* drive data on neg. edge */
> >> +#define DISPLAY_FLAGS_INTERLACED	BIT(4)
> >> +#define DISPLAY_FLAGS_DOUBLESCAN	BIT(5)
> > 
> > <snip>
> > 
> >> +	unsigned int dmt_flags;	/* VESA DMT flags */
> >> +	unsigned int data_flags; /* video data flags */
> > 
> > Why did you go for this approach? To be able to represent
> > true/false/not-specified?
> > 

We decided somewhere between v3 and v8 (I think), that those flags can be
high/low/ignored.

> > Would it be simpler to just have "flags" field? What does it give us to
> > have those two separately?
> > 

I decided to split them, so it is clear that some flags are VESA defined and
the others are "invented" for the display-timings framework and may be
extended.

> > Should the above say raising edge/falling edge instead of positive
> > edge/negative edge?
> > 

Hm, I used posedge/negedge because it is shorter (and because of my Verilog past
pretty natural to me :-) ). I don't know what others are thinking though.

Regards,
Steffen

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

WARNING: multiple messages have this Message-ID (diff)
From: Steffen Trumtrar <s.trumtrar@pengutronix.de>
To: Tomi Valkeinen <tomi.valkeinen@ti.com>
Cc: devicetree-discuss@lists.ozlabs.org,
	Dave Airlie <airlied@linux.ie>,
	Rob Herring <robherring2@gmail.com>,
	linux-fbdev@vger.kernel.org, dri-devel@lists.freedesktop.org,
	Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
	Thierry Reding <thierry.reding@avionic-design.de>,
	Guennady Liakhovetski <g.liakhovetski@gmx.de>,
	linux-media@vger.kernel.org,
	Stephen Warren <swarren@wwwdotorg.org>,
	Florian Tobias Schandinat <FlorianSchandinat@gmx.de>,
	Rob Clark <robdclark@gmail.com>,
	Leela Krishna Amudala <leelakrishna.a@gmail.com>,
	"Mohammed, Afzal" <afzal@ti.com>,
	kernel@pengutronix.de
Subject: Re: [PATCH v17 2/7] video: add display_timing and videomode
Date: Wed, 27 Feb 2013 16:05:40 +0000	[thread overview]
Message-ID: <20130227160540.GA10491@pengutronix.de> (raw)
In-Reply-To: <512E2A1B.6040704@ti.com>

Ah, sorry. Forgot to answer this.

On Wed, Feb 27, 2013 at 05:45:31PM +0200, Tomi Valkeinen wrote:
> Ping.
> 
> On 2013-02-18 16:09, Tomi Valkeinen wrote:
> > Hi Steffen,
> > 
> > On 2013-01-25 11:01, Steffen Trumtrar wrote:
> > 
> >> +/* VESA display monitor timing parameters */
> >> +#define VESA_DMT_HSYNC_LOW		BIT(0)
> >> +#define VESA_DMT_HSYNC_HIGH		BIT(1)
> >> +#define VESA_DMT_VSYNC_LOW		BIT(2)
> >> +#define VESA_DMT_VSYNC_HIGH		BIT(3)
> >> +
> >> +/* display specific flags */
> >> +#define DISPLAY_FLAGS_DE_LOW		BIT(0)	/* data enable flag */
> >> +#define DISPLAY_FLAGS_DE_HIGH		BIT(1)
> >> +#define DISPLAY_FLAGS_PIXDATA_POSEDGE	BIT(2)	/* drive data on pos. edge */
> >> +#define DISPLAY_FLAGS_PIXDATA_NEGEDGE	BIT(3)	/* drive data on neg. edge */
> >> +#define DISPLAY_FLAGS_INTERLACED	BIT(4)
> >> +#define DISPLAY_FLAGS_DOUBLESCAN	BIT(5)
> > 
> > <snip>
> > 
> >> +	unsigned int dmt_flags;	/* VESA DMT flags */
> >> +	unsigned int data_flags; /* video data flags */
> > 
> > Why did you go for this approach? To be able to represent
> > true/false/not-specified?
> > 

We decided somewhere between v3 and v8 (I think), that those flags can be
high/low/ignored.

> > Would it be simpler to just have "flags" field? What does it give us to
> > have those two separately?
> > 

I decided to split them, so it is clear that some flags are VESA defined and
the others are "invented" for the display-timings framework and may be
extended.

> > Should the above say raising edge/falling edge instead of positive
> > edge/negative edge?
> > 

Hm, I used posedge/negedge because it is shorter (and because of my Verilog past
pretty natural to me :-) ). I don't know what others are thinking though.

Regards,
Steffen

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

  reply	other threads:[~2013-02-27 16:05 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-01-25  9:01 [PATCH v17 0/7] of: add display helper Steffen Trumtrar
2013-01-25  9:01 ` Steffen Trumtrar
2013-01-25  9:01 ` [PATCH v17 1/7] viafb: rename display_timing to via_display_timing Steffen Trumtrar
2013-01-25  9:01   ` Steffen Trumtrar
2013-01-25  9:01 ` [PATCH v17 2/7] video: add display_timing and videomode Steffen Trumtrar
2013-01-25  9:01   ` Steffen Trumtrar
2013-02-18 14:09   ` Tomi Valkeinen
2013-02-18 14:09     ` Tomi Valkeinen
     [not found]     ` <51223615.4090709-X3B1VOXEql0@public.gmane.org>
2013-02-27 15:45       ` Tomi Valkeinen
2013-02-27 15:45         ` Tomi Valkeinen
2013-02-27 15:45         ` Tomi Valkeinen
2013-02-27 16:05         ` Steffen Trumtrar [this message]
2013-02-27 16:05           ` Steffen Trumtrar
     [not found]           ` <20130227160540.GA10491-bIcnvbaLZ9MEGnE8C9+IrQ@public.gmane.org>
2013-02-27 16:13             ` Tomi Valkeinen
2013-02-27 16:13               ` Tomi Valkeinen
2013-02-27 16:13               ` Tomi Valkeinen
     [not found]               ` <512E30BD.7010603-l0cyMroinI0@public.gmane.org>
2013-03-05  9:24                 ` Steffen Trumtrar
2013-03-05  9:24                   ` Steffen Trumtrar
2013-03-05  9:24                   ` Steffen Trumtrar
2013-01-25  9:01 ` [PATCH v17 3/7] video: add of helper for display timings/videomode Steffen Trumtrar
2013-01-25  9:01   ` =?UTF-8?q?=5BPATCH=20v17=203/7=5D=20video=3A=20add=20of=20helper=20for=20display=20timings/videomode Steffen Trumtrar
2013-01-25  9:01 ` [PATCH v17 4/7] fbmon: add videomode helpers Steffen Trumtrar
2013-01-25  9:01   ` Steffen Trumtrar
2013-02-01  9:29   ` Jingoo Han
2013-02-01  9:29     ` Jingoo Han
2013-02-01  9:29     ` Jingoo Han
     [not found]     ` <003401ce005e$af665c50$0e3314f0$%han-Sze3O3UU22JBDgjK7y7TUQ@public.gmane.org>
2013-02-05 18:29       ` Steffen Trumtrar
2013-02-05 18:29         ` Steffen Trumtrar
2013-02-05 18:29         ` Steffen Trumtrar
2013-01-25  9:01 ` [PATCH v17 5/7] fbmon: add of_videomode helpers Steffen Trumtrar
2013-01-25  9:01   ` Steffen Trumtrar
2013-01-25  9:01 ` [PATCH v17 6/7] drm_modes: add videomode helpers Steffen Trumtrar
2013-01-25  9:01   ` Steffen Trumtrar
2013-01-25  9:01 ` [PATCH v17 7/7] drm_modes: add of_videomode helpers Steffen Trumtrar
2013-01-25  9:01   ` Steffen Trumtrar
2013-02-01  9:33 [PATCH v17 4/7] fbmon: add videomode helpers Jingoo Han
2013-02-01  9:33 ` Jingoo Han
2013-02-01  9:33 ` Jingoo Han

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130227160540.GA10491@pengutronix.de \
    --to=s.trumtrar@pengutronix.de \
    --cc=FlorianSchandinat@gmx.de \
    --cc=afzal@ti.com \
    --cc=airlied@linux.ie \
    --cc=devicetree-discuss@lists.ozlabs.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=g.liakhovetski@gmx.de \
    --cc=kernel@pengutronix.de \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=leelakrishna.a@gmail.com \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=robdclark@gmail.com \
    --cc=robherring2@gmail.com \
    --cc=swarren@wwwdotorg.org \
    --cc=thierry.reding@avionic-design.de \
    --cc=tomi.valkeinen@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.