All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2] md/raid5: fix typo
@ 2015-04-30  7:01 Yuanhan Liu
  2015-04-30  7:01 ` [PATCH 2/2] md/raid5: trivial coding style fix Yuanhan Liu
  2015-04-30  7:14 ` [PATCH 1/2] md/raid5: fix typo NeilBrown
  0 siblings, 2 replies; 6+ messages in thread
From: Yuanhan Liu @ 2015-04-30  7:01 UTC (permalink / raw)
  To: neilb; +Cc: linux-raid, linux-kernel, Yuanhan Liu

bion -> bios

Signed-off-by: Yuanhan Liu <yuanhan.liu@linux.intel.com>
---
 drivers/md/raid5.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
index 697d77a..2651bda 100644
--- a/drivers/md/raid5.c
+++ b/drivers/md/raid5.c
@@ -2919,7 +2919,7 @@ schedule_reconstruction(struct stripe_head *sh, struct stripe_head_state *s,
 }
 
 /*
- * Each stripe/dev can have one or more bion attached.
+ * Each stripe/dev can have one or more bios attached.
  * toread/towrite point to the first in a chain.
  * The bi_next chain must be in order.
  */
-- 
1.9.0


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 2/2] md/raid5: trivial coding style fix
  2015-04-30  7:01 [PATCH 1/2] md/raid5: fix typo Yuanhan Liu
@ 2015-04-30  7:01 ` Yuanhan Liu
  2015-04-30  7:16   ` NeilBrown
  2015-04-30  7:14 ` [PATCH 1/2] md/raid5: fix typo NeilBrown
  1 sibling, 1 reply; 6+ messages in thread
From: Yuanhan Liu @ 2015-04-30  7:01 UTC (permalink / raw)
  To: neilb; +Cc: linux-raid, linux-kernel, Yuanhan Liu

Signed-off-by: Yuanhan Liu <yuanhan.liu@linux.intel.com>
---
 drivers/md/raid5.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
index 2651bda..bae3e2c 100644
--- a/drivers/md/raid5.c
+++ b/drivers/md/raid5.c
@@ -5789,8 +5789,7 @@ static void raid5d(struct md_thread *thread)
 		if (released)
 			clear_bit(R5_DID_ALLOC, &conf->cache_state);
 
-		if (
-		    !list_empty(&conf->bitmap_list)) {
+		if (!list_empty(&conf->bitmap_list)) {
 			/* Now is a good time to flush some bitmap updates */
 			conf->seq_flush++;
 			spin_unlock_irq(&conf->device_lock);
-- 
1.9.0

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/2] md/raid5: fix typo
  2015-04-30  7:01 [PATCH 1/2] md/raid5: fix typo Yuanhan Liu
  2015-04-30  7:01 ` [PATCH 2/2] md/raid5: trivial coding style fix Yuanhan Liu
@ 2015-04-30  7:14 ` NeilBrown
  2015-04-30  7:22   ` Yuanhan Liu
  1 sibling, 1 reply; 6+ messages in thread
From: NeilBrown @ 2015-04-30  7:14 UTC (permalink / raw)
  To: Yuanhan Liu; +Cc: linux-raid, linux-kernel

[-- Attachment #1: Type: text/plain, Size: 999 bytes --]

On Thu, 30 Apr 2015 15:01:16 +0800 Yuanhan Liu <yuanhan.liu@linux.intel.com>
wrote:

> bion -> bios
> 
> Signed-off-by: Yuanhan Liu <yuanhan.liu@linux.intel.com>
> ---
>  drivers/md/raid5.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
> index 697d77a..2651bda 100644
> --- a/drivers/md/raid5.c
> +++ b/drivers/md/raid5.c
> @@ -2919,7 +2919,7 @@ schedule_reconstruction(struct stripe_head *sh, struct stripe_head_state *s,
>  }
>  
>  /*
> - * Each stripe/dev can have one or more bion attached.
> + * Each stripe/dev can have one or more bios attached.
>   * toread/towrite point to the first in a chain.
>   * The bi_next chain must be in order.
>   */

That was intentional.  "bios" as a plural looks too much like "BIOS" which is
in the ROM of computers.

Children and oxen are plurals with an 'n' at the end.  So I used 'bion'.
Private joke?

I'd rather leave it as it is.

Thanks,
NeilBrown

[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 811 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 2/2] md/raid5: trivial coding style fix
  2015-04-30  7:01 ` [PATCH 2/2] md/raid5: trivial coding style fix Yuanhan Liu
@ 2015-04-30  7:16   ` NeilBrown
  2015-04-30  7:23     ` Yuanhan Liu
  0 siblings, 1 reply; 6+ messages in thread
From: NeilBrown @ 2015-04-30  7:16 UTC (permalink / raw)
  To: Yuanhan Liu; +Cc: linux-raid, linux-kernel

[-- Attachment #1: Type: text/plain, Size: 989 bytes --]

On Thu, 30 Apr 2015 15:01:17 +0800 Yuanhan Liu <yuanhan.liu@linux.intel.com>
wrote:

> Signed-off-by: Yuanhan Liu <yuanhan.liu@linux.intel.com>
> ---
>  drivers/md/raid5.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
> index 2651bda..bae3e2c 100644
> --- a/drivers/md/raid5.c
> +++ b/drivers/md/raid5.c
> @@ -5789,8 +5789,7 @@ static void raid5d(struct md_thread *thread)
>  		if (released)
>  			clear_bit(R5_DID_ALLOC, &conf->cache_state);
>  
> -		if (
> -		    !list_empty(&conf->bitmap_list)) {
> +		if (!list_empty(&conf->bitmap_list)) {
>  			/* Now is a good time to flush some bitmap updates */
>  			conf->seq_flush++;
>  			spin_unlock_irq(&conf->device_lock);


I'm happy for these sorts of changes when you are fixing up nearby code, or
if the change significantly improves readability.
But I'd rather not bother is one-off trivial fixes like this.

Thanks anyway,
NeilBrown

[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 811 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/2] md/raid5: fix typo
  2015-04-30  7:14 ` [PATCH 1/2] md/raid5: fix typo NeilBrown
@ 2015-04-30  7:22   ` Yuanhan Liu
  0 siblings, 0 replies; 6+ messages in thread
From: Yuanhan Liu @ 2015-04-30  7:22 UTC (permalink / raw)
  To: NeilBrown; +Cc: linux-raid, linux-kernel

On Thu, Apr 30, 2015 at 05:14:26PM +1000, NeilBrown wrote:
> On Thu, 30 Apr 2015 15:01:16 +0800 Yuanhan Liu <yuanhan.liu@linux.intel.com>
> wrote:
> 
> > bion -> bios
> > 
> > Signed-off-by: Yuanhan Liu <yuanhan.liu@linux.intel.com>
> > ---
> >  drivers/md/raid5.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
> > index 697d77a..2651bda 100644
> > --- a/drivers/md/raid5.c
> > +++ b/drivers/md/raid5.c
> > @@ -2919,7 +2919,7 @@ schedule_reconstruction(struct stripe_head *sh, struct stripe_head_state *s,
> >  }
> >  
> >  /*
> > - * Each stripe/dev can have one or more bion attached.
> > + * Each stripe/dev can have one or more bios attached.
> >   * toread/towrite point to the first in a chain.
> >   * The bi_next chain must be in order.
> >   */
> 
> That was intentional.  "bios" as a plural looks too much like "BIOS" which is
> in the ROM of computers.
> 
> Children and oxen are plurals with an 'n' at the end.  So I used 'bion'.
> Private joke?

Interesting.

> 
> I'd rather leave it as it is.

Okay, and sorry for the noise.

	--yliu

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 2/2] md/raid5: trivial coding style fix
  2015-04-30  7:16   ` NeilBrown
@ 2015-04-30  7:23     ` Yuanhan Liu
  0 siblings, 0 replies; 6+ messages in thread
From: Yuanhan Liu @ 2015-04-30  7:23 UTC (permalink / raw)
  To: NeilBrown; +Cc: linux-raid, linux-kernel

On Thu, Apr 30, 2015 at 05:16:50PM +1000, NeilBrown wrote:
> On Thu, 30 Apr 2015 15:01:17 +0800 Yuanhan Liu <yuanhan.liu@linux.intel.com>
> wrote:
> 
> > Signed-off-by: Yuanhan Liu <yuanhan.liu@linux.intel.com>
> > ---
> >  drivers/md/raid5.c | 3 +--
> >  1 file changed, 1 insertion(+), 2 deletions(-)
> > 
> > diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
> > index 2651bda..bae3e2c 100644
> > --- a/drivers/md/raid5.c
> > +++ b/drivers/md/raid5.c
> > @@ -5789,8 +5789,7 @@ static void raid5d(struct md_thread *thread)
> >  		if (released)
> >  			clear_bit(R5_DID_ALLOC, &conf->cache_state);
> >  
> > -		if (
> > -		    !list_empty(&conf->bitmap_list)) {
> > +		if (!list_empty(&conf->bitmap_list)) {
> >  			/* Now is a good time to flush some bitmap updates */
> >  			conf->seq_flush++;
> >  			spin_unlock_irq(&conf->device_lock);
> 
> 
> I'm happy for these sorts of changes when you are fixing up nearby code, or
> if the change significantly improves readability.
> But I'd rather not bother is one-off trivial fixes like this.

Got it.

	--yliu

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2015-04-30  7:23 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-04-30  7:01 [PATCH 1/2] md/raid5: fix typo Yuanhan Liu
2015-04-30  7:01 ` [PATCH 2/2] md/raid5: trivial coding style fix Yuanhan Liu
2015-04-30  7:16   ` NeilBrown
2015-04-30  7:23     ` Yuanhan Liu
2015-04-30  7:14 ` [PATCH 1/2] md/raid5: fix typo NeilBrown
2015-04-30  7:22   ` Yuanhan Liu

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.