All of lore.kernel.org
 help / color / mirror / Atom feed
* [RFC][PATCH 00/19] tracing: Remove "ftrace" from TRACE_EVENT files
@ 2015-05-14 15:13 Steven Rostedt
  2015-05-14 15:13 ` [RFC][PATCH 01/19] tracing: Rename trace/ftrace.h to trace/trace_events.h Steven Rostedt
                   ` (19 more replies)
  0 siblings, 20 replies; 22+ messages in thread
From: Steven Rostedt @ 2015-05-14 15:13 UTC (permalink / raw)
  To: linux-kernel
  Cc: Ingo Molnar, Andrew Morton, Peter Zijlstra, Namhyung Kim,
	Masami Hiramatsu, Arnaldo Carvalho de Melo, Jiri Olsa,
	Daniel Wagner

Although the name "ftrace" is used to describe the kernel tracing
infrastructure, in actuality it is really just the function hook
infrastructure. The TRACE_EVENT system is more generic and is used
by tracing, perf and lttng as well as others.

This gets confusing at times, as it is not consistent in the naming.
The kernel should only use "ftrace" when describing the function hook
infrastructure. For trace_events and recording, it really should just
use "trace".

This only changes the internal infrastructure code and to make sure
such a large change has no impact, I tested it by merging this branch
into linux-next and building an allmodconfig. There were no build
failures or warnings due to this change set.

I plan on doing further testing and hopefully get this ready for 4.2.
When my testing is complete, I'll be pushing this into linux-next.

-- Steve

  git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/linux-trace.git
ftrace/rename-ftrace

Head SHA1: d0ee8f4a1f5f3df933cdc9a80f5dea13e2fb5022


Steven Rostedt (Red Hat) (19):
      tracing: Rename trace/ftrace.h to trace/trace_events.h
      tracing: Move the perf code out of trace_event.h
      tracing: Rename ftrace_event.h to trace_events.h
      tracing: Rename ftrace_print_*() functions ta trace_print_*()
      tracing: Rename (un)register_ftrace_event() to (un)register_trace_event()
      tracing: Rename ftrace_event_file to trace_event_file
      tracing: Rename ftrace_event_{call,class} to trace_event_{call,class}
      tracing: Rename ftrace_event_buffer to trace_event_buffer.
      tracing: Rename ftrace_output functions to trace_output
      tracing: Rename FTRACE_MAX_EVENT to TRACE_EVENT_TYPE_MAX
      tracing: Rename ftrace_event_name() to trace_event_name()
      tracing: Rename struct ftrace_subsystem_dir to trace_subsystem_dir
      tracing: Rename FTRACE_EVENT_FL_* flags to EVENT_FILE_FL_*
      tracing: Rename ftrace_trigger_soft_disabled() to trace_trigger_soft_disabled()
      tracing: Rename ftrace_raw_##call event structures to trace_event_raw_##call
      tracing: Rename ftrace_data_offset_##call to trace_event_data_offset_##call
      tracing: Rename ftrace_event_type_funcs_##call to trace_event_type_funcs_##call
      tracing: Rename ftrace_define_fields_##call() to trace_event_define_fields_##call()
      tracing: Rename ftrace_get_offsets_##call() to trace_event_get_offsets_##call()

----
 arch/x86/kvm/mmutrace.h                            |   2 +-
 arch/x86/kvm/svm.c                                 |   2 +-
 arch/x86/kvm/vmx.c                                 |   2 +-
 include/linux/ftrace_event.h                       | 616 ---------------
 include/linux/module.h                             |   2 +-
 include/linux/perf_event.h                         |   2 +-
 include/linux/syscalls.h                           |  12 +-
 include/linux/trace_events.h                       | 616 +++++++++++++++
 include/trace/define_trace.h                       |   3 +-
 include/trace/events/power.h                       |   2 +-
 include/trace/ftrace.h                             | 859 ---------------------
 include/trace/perf.h                               | 350 +++++++++
 include/trace/syscall.h                            |   6 +-
 include/trace/trace_events.h                       | 508 ++++++++++++
 kernel/events/core.c                               |   2 +-
 kernel/module.c                                    |   2 +-
 kernel/rcu/tiny.c                                  |   2 +-
 kernel/rcu/tree.c                                  |   2 +-
 kernel/trace/blktrace.c                            |   4 +-
 kernel/trace/ring_buffer.c                         |   2 +-
 kernel/trace/trace.c                               |  22 +-
 kernel/trace/trace.h                               |  42 +-
 kernel/trace/trace_branch.c                        |   4 +-
 kernel/trace/trace_event_perf.c                    |  20 +-
 kernel/trace/trace_events.c                        | 304 ++++----
 kernel/trace/trace_events_filter.c                 |  86 +--
 kernel/trace/trace_events_trigger.c                |  70 +-
 kernel/trace/trace_export.c                        |  10 +-
 kernel/trace/trace_functions_graph.c               |   8 +-
 kernel/trace/trace_kprobe.c                        |  70 +-
 kernel/trace/trace_mmiotrace.c                     |   4 +-
 kernel/trace/trace_output.c                        |  78 +-
 kernel/trace/trace_output.h                        |   2 +-
 kernel/trace/trace_probe.h                         |   8 +-
 kernel/trace/trace_sched_wakeup.c                  |   4 +-
 kernel/trace/trace_syscalls.c                      |  72 +-
 kernel/trace/trace_uprobe.c                        |  46 +-
 mm/debug.c                                         |   2 +-
 .../perf/util/scripting-engines/trace-event-perl.c |   4 +-
 .../util/scripting-engines/trace-event-python.c    |   4 +-
 40 files changed, 1928 insertions(+), 1928 deletions(-)


^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2015-05-22 12:46 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-05-14 15:13 [RFC][PATCH 00/19] tracing: Remove "ftrace" from TRACE_EVENT files Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 01/19] tracing: Rename trace/ftrace.h to trace/trace_events.h Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 02/19] tracing: Move the perf code out of trace_event.h Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 03/19] tracing: Rename ftrace_event.h to trace_events.h Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 04/19] tracing: Rename ftrace_print_*() functions ta trace_print_*() Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 05/19] tracing: Rename (un)register_ftrace_event() to (un)register_trace_event() Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 06/19] tracing: Rename ftrace_event_file to trace_event_file Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 07/19] tracing: Rename ftrace_event_{call,class} to trace_event_{call,class} Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 08/19] tracing: Rename ftrace_event_buffer to trace_event_buffer Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 09/19] tracing: Rename ftrace_output functions to trace_output Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 10/19] tracing: Rename FTRACE_MAX_EVENT to TRACE_EVENT_TYPE_MAX Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 11/19] tracing: Rename ftrace_event_name() to trace_event_name() Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 12/19] tracing: Rename struct ftrace_subsystem_dir to trace_subsystem_dir Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 13/19] tracing: Rename FTRACE_EVENT_FL_* flags to EVENT_FILE_FL_* Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 14/19] tracing: Rename ftrace_trigger_soft_disabled() to trace_trigger_soft_disabled() Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 15/19] tracing: Rename ftrace_raw_##call event structures to trace_event_raw_##call Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 16/19] tracing: Rename ftrace_data_offset_##call to trace_event_data_offset_##call Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 17/19] tracing: Rename ftrace_event_type_funcs_##call to trace_event_type_funcs_##call Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 18/19] tracing: Rename ftrace_define_fields_##call() to trace_event_define_fields_##call() Steven Rostedt
2015-05-14 15:13 ` [RFC][PATCH 19/19] tracing: Rename ftrace_get_offsets_##call() to trace_event_get_offsets_##call() Steven Rostedt
2015-05-22 12:28 ` [RFC][PATCH 00/19] tracing: Remove "ftrace" from TRACE_EVENT files Daniel Wagner
2015-05-22 12:46   ` Steven Rostedt

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.