All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD
@ 2015-05-14  4:17 roopa
  2015-05-15  2:45 ` David Miller
  0 siblings, 1 reply; 6+ messages in thread
From: roopa @ 2015-05-14  4:17 UTC (permalink / raw)
  To: davem, sfeldma, jiri, gospo; +Cc: netdev

From: Roopa Prabhu <roopa@cumulusnetworks.com>

RTNH_F_EXTERNAL today is printed as "offload" in iproute2 output.

This patch renames the flag to be consistent with what the user sees.

Signed-off-by: Roopa Prabhu <roopa@cumulusnetworks.com>
---
RTNH_F_EXTERNAL was introduced in 4.1 and is not out in 4.0 kernel.

 include/uapi/linux/rtnetlink.h |    2 +-
 net/ipv4/fib_trie.c            |    2 +-
 net/switchdev/switchdev.c      |    6 +++---
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/include/uapi/linux/rtnetlink.h b/include/uapi/linux/rtnetlink.h
index 974db03..17fb02f 100644
--- a/include/uapi/linux/rtnetlink.h
+++ b/include/uapi/linux/rtnetlink.h
@@ -337,7 +337,7 @@ struct rtnexthop {
 #define RTNH_F_DEAD		1	/* Nexthop is dead (used by multipath)	*/
 #define RTNH_F_PERVASIVE	2	/* Do recursive gateway lookup	*/
 #define RTNH_F_ONLINK		4	/* Gateway is forced on link	*/
-#define RTNH_F_EXTERNAL		8	/* Route installed externally	*/
+#define RTNH_F_OFFLOAD		8	/* offloaded route */
 
 /* Macros to handle hexthops */
 
diff --git a/net/ipv4/fib_trie.c b/net/ipv4/fib_trie.c
index e13fcc6..64c2076 100644
--- a/net/ipv4/fib_trie.c
+++ b/net/ipv4/fib_trie.c
@@ -1764,7 +1764,7 @@ void fib_table_flush_external(struct fib_table *tb)
 			/* record local slen */
 			slen = fa->fa_slen;
 
-			if (!fi || !(fi->fib_flags & RTNH_F_EXTERNAL))
+			if (!fi || !(fi->fib_flags & RTNH_F_OFFLOAD))
 				continue;
 
 			netdev_switch_fib_ipv4_del(n->key,
diff --git a/net/switchdev/switchdev.c b/net/switchdev/switchdev.c
index 46568b8..055453d 100644
--- a/net/switchdev/switchdev.c
+++ b/net/switchdev/switchdev.c
@@ -338,7 +338,7 @@ int netdev_switch_fib_ipv4_add(u32 dst, int dst_len, struct fib_info *fi,
 					      fi, tos, type, nlflags,
 					      tb_id);
 		if (!err)
-			fi->fib_flags |= RTNH_F_EXTERNAL;
+			fi->fib_flags |= RTNH_F_OFFLOAD;
 	}
 
 	return err;
@@ -364,7 +364,7 @@ int netdev_switch_fib_ipv4_del(u32 dst, int dst_len, struct fib_info *fi,
 	const struct swdev_ops *ops;
 	int err = 0;
 
-	if (!(fi->fib_flags & RTNH_F_EXTERNAL))
+	if (!(fi->fib_flags & RTNH_F_OFFLOAD))
 		return 0;
 
 	dev = netdev_switch_get_dev_by_nhs(fi);
@@ -376,7 +376,7 @@ int netdev_switch_fib_ipv4_del(u32 dst, int dst_len, struct fib_info *fi,
 		err = ops->swdev_fib_ipv4_del(dev, htonl(dst), dst_len,
 					      fi, tos, type, tb_id);
 		if (!err)
-			fi->fib_flags &= ~RTNH_F_EXTERNAL;
+			fi->fib_flags &= ~RTNH_F_OFFLOAD;
 	}
 
 	return err;
-- 
1.7.10.4

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD
  2015-05-14  4:17 [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD roopa
@ 2015-05-15  2:45 ` David Miller
  2015-05-21 22:16   ` Stephen Hemminger
  0 siblings, 1 reply; 6+ messages in thread
From: David Miller @ 2015-05-15  2:45 UTC (permalink / raw)
  To: roopa; +Cc: sfeldma, jiri, gospo, netdev

From: roopa@cumulusnetworks.com
Date: Wed, 13 May 2015 21:17:41 -0700

> From: Roopa Prabhu <roopa@cumulusnetworks.com>
> 
> RTNH_F_EXTERNAL today is printed as "offload" in iproute2 output.
> 
> This patch renames the flag to be consistent with what the user sees.
> 
> Signed-off-by: Roopa Prabhu <roopa@cumulusnetworks.com>

Applied, thanks.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD
  2015-05-15  2:45 ` David Miller
@ 2015-05-21 22:16   ` Stephen Hemminger
  2015-05-21 22:40     ` David Miller
  0 siblings, 1 reply; 6+ messages in thread
From: Stephen Hemminger @ 2015-05-21 22:16 UTC (permalink / raw)
  To: David Miller; +Cc: roopa, sfeldma, jiri, gospo, netdev

On Thu, 14 May 2015 22:45:54 -0400 (EDT)
David Miller <davem@davemloft.net> wrote:

> From: roopa@cumulusnetworks.com
> Date: Wed, 13 May 2015 21:17:41 -0700
> 
> > From: Roopa Prabhu <roopa@cumulusnetworks.com>
> > 
> > RTNH_F_EXTERNAL today is printed as "offload" in iproute2 output.
> > 
> > This patch renames the flag to be consistent with what the user sees.
> > 
> > Signed-off-by: Roopa Prabhu <roopa@cumulusnetworks.com>
> 
> Applied, thanks.

I don't see this merge in current net-next tree?
Did it not really happen or was it not pushed?

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD
  2015-05-21 22:16   ` Stephen Hemminger
@ 2015-05-21 22:40     ` David Miller
  2015-05-21 23:46       ` Stephen Hemminger
  0 siblings, 1 reply; 6+ messages in thread
From: David Miller @ 2015-05-21 22:40 UTC (permalink / raw)
  To: stephen; +Cc: roopa, sfeldma, jiri, gospo, netdev

From: Stephen Hemminger <stephen@networkplumber.org>
Date: Thu, 21 May 2015 15:16:18 -0700

> On Thu, 14 May 2015 22:45:54 -0400 (EDT)
> David Miller <davem@davemloft.net> wrote:
> 
>> From: roopa@cumulusnetworks.com
>> Date: Wed, 13 May 2015 21:17:41 -0700
>> 
>> > From: Roopa Prabhu <roopa@cumulusnetworks.com>
>> > 
>> > RTNH_F_EXTERNAL today is printed as "offload" in iproute2 output.
>> > 
>> > This patch renames the flag to be consistent with what the user sees.
>> > 
>> > Signed-off-by: Roopa Prabhu <roopa@cumulusnetworks.com>
>> 
>> Applied, thanks.
> 
> I don't see this merge in current net-next tree?
> Did it not really happen or was it not pushed?

It went to the 'net' tree and I haven't done a merge in a while.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD
  2015-05-21 22:40     ` David Miller
@ 2015-05-21 23:46       ` Stephen Hemminger
  2015-05-22  3:19         ` David Miller
  0 siblings, 1 reply; 6+ messages in thread
From: Stephen Hemminger @ 2015-05-21 23:46 UTC (permalink / raw)
  To: David Miller; +Cc: roopa, sfeldma, jiri, gospo, netdev

On Thu, 21 May 2015 18:40:10 -0400 (EDT)
David Miller <davem@davemloft.net> wrote:

> From: Stephen Hemminger <stephen@networkplumber.org>
> Date: Thu, 21 May 2015 15:16:18 -0700
> 
> > On Thu, 14 May 2015 22:45:54 -0400 (EDT)
> > David Miller <davem@davemloft.net> wrote:
> > 
> >> From: roopa@cumulusnetworks.com
> >> Date: Wed, 13 May 2015 21:17:41 -0700
> >> 
> >> > From: Roopa Prabhu <roopa@cumulusnetworks.com>
> >> > 
> >> > RTNH_F_EXTERNAL today is printed as "offload" in iproute2 output.
> >> > 
> >> > This patch renames the flag to be consistent with what the user sees.
> >> > 
> >> > Signed-off-by: Roopa Prabhu <roopa@cumulusnetworks.com>
> >> 
> >> Applied, thanks.
> > 
> > I don't see this merge in current net-next tree?
> > Did it not really happen or was it not pushed?
> 
> It went to the 'net' tree and I haven't done a merge in a while.

Ok, that will go to Linus, right.
Trying to coordinate the iproute2 changes related to this.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD
  2015-05-21 23:46       ` Stephen Hemminger
@ 2015-05-22  3:19         ` David Miller
  0 siblings, 0 replies; 6+ messages in thread
From: David Miller @ 2015-05-22  3:19 UTC (permalink / raw)
  To: stephen; +Cc: roopa, sfeldma, jiri, gospo, netdev

From: Stephen Hemminger <stephen@networkplumber.org>
Date: Thu, 21 May 2015 16:46:30 -0700

> On Thu, 21 May 2015 18:40:10 -0400 (EDT)
> David Miller <davem@davemloft.net> wrote:
> 
>> From: Stephen Hemminger <stephen@networkplumber.org>
>> Date: Thu, 21 May 2015 15:16:18 -0700
>> 
>> > On Thu, 14 May 2015 22:45:54 -0400 (EDT)
>> > David Miller <davem@davemloft.net> wrote:
>> > 
>> >> From: roopa@cumulusnetworks.com
>> >> Date: Wed, 13 May 2015 21:17:41 -0700
>> >> 
>> >> > From: Roopa Prabhu <roopa@cumulusnetworks.com>
>> >> > 
>> >> > RTNH_F_EXTERNAL today is printed as "offload" in iproute2 output.
>> >> > 
>> >> > This patch renames the flag to be consistent with what the user sees.
>> >> > 
>> >> > Signed-off-by: Roopa Prabhu <roopa@cumulusnetworks.com>
>> >> 
>> >> Applied, thanks.
>> > 
>> > I don't see this merge in current net-next tree?
>> > Did it not really happen or was it not pushed?
>> 
>> It went to the 'net' tree and I haven't done a merge in a while.
> 
> Ok, that will go to Linus, right.
> Trying to coordinate the iproute2 changes related to this.

Yes, probably I will send him a pull request tomorrow.

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2015-05-22  3:19 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-05-14  4:17 [PATCH net] rename RTNH_F_EXTERNAL to RTNH_F_OFFLOAD roopa
2015-05-15  2:45 ` David Miller
2015-05-21 22:16   ` Stephen Hemminger
2015-05-21 22:40     ` David Miller
2015-05-21 23:46       ` Stephen Hemminger
2015-05-22  3:19         ` David Miller

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.