All of lore.kernel.org
 help / color / mirror / Atom feed
From: Rob Herring <robh@kernel.org>
To: Andy Yan <andy.yan@rock-chips.com>
Cc: heiko@sntech.de, arnd@arndb.de, john.stultz@linaro.org,
	sjg@chromium.org, alexandre.belloni@free-electrons.com,
	treding@nvidia.com, galak@codeaurora.org,
	ijc+devicetree@hellion.org.uk, wxt@rock-chips.com,
	catalin.marinas@arm.com, olof@lixom.net, geert+renesas@glider.be,
	linux-rockchip@lists.infradead.org, dbaryshkov@gmail.com,
	sre@kernel.org, jun.nie@linaro.org, pawel.moll@arm.com,
	will.deacon@arm.com, akpm@linux-foundation.org,
	devicetree@vger.kernel.org, linux@arm.linux.org.uk,
	gregkh@linuxfoundation.org, joel@jms.id.au,
	linux-arm-kernel@lists.infradead.org, lorenzo.pieralisi@arm.com,
	khilman@linaro.org, moritz.fischer@ettus.com,
	linux-kernel@vger.kernel.org, mark.rutland@arm.com
Subject: Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver
Date: Tue, 22 Dec 2015 18:32:17 -0600	[thread overview]
Message-ID: <20151223003217.GA18700@rob-hp-laptop> (raw)
In-Reply-To: <1450775124-23966-1-git-send-email-andy.yan@rock-chips.com>

On Tue, Dec 22, 2015 at 05:05:24PM +0800, Andy Yan wrote:
> add device tree bindings document for reboot-mode driver
> 
> Signed-off-by: Andy Yan <andy.yan@rock-chips.com>
> 
> ---
> 
> Changes in v1: None
> 
>  .../devicetree/bindings/misc/reboot-mode.txt       | 41 ++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/misc/reboot-mode.txt
> 
> diff --git a/Documentation/devicetree/bindings/misc/reboot-mode.txt b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> new file mode 100644
> index 0000000..082bc0c
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> @@ -0,0 +1,41 @@
> +Generic reboot mode communication driver

You're not describing a driver. It is a mapping of boot modes to values.
> +
> +This driver get reboot mode arguments from userspace

Coming from userspace is a Linuxism.

> +and stores it in special register or ram . Then the
> +bootloader will read it and take different action
> +according the argument stored.
> +
> +Required properties:
> +        - compatible = "reboot-mode" or other vendor compatible string;
> +
> +Each mode is represented as a sub-node of reboot_mode:
> +
> +Subnode required properties:
> +        - linux,mode: reboot mode command,such as "loader","recovery", "fastboot".
> +        - linux,magic: magic number for the mode, this is vendor specific.
> +
> +example:
> +	reboot_mode {
> +		compatible = "rockchip,reboot-mode";
> +		rockchip,regmap = <&pmu>;
> +		offset = <0x40>;
> +		loader {
> +			linux,mode = "loader";
> +			linux,magic = <0x5242C301>;
> +		};

These can be much more simply expressed as:

loader = <0x5242c301>;

I would like to see the property names here standardized as much as
possible. I'm not sure if we can define the properties as a u32 or need
some flexibility here.

Rob

WARNING: multiple messages have this Message-ID (diff)
From: Rob Herring <robh-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org>
To: Andy Yan <andy.yan-TNX95d0MmH7DzftRWevZcw@public.gmane.org>
Cc: mark.rutland-5wv7dgnIgG8@public.gmane.org,
	heiko-4mtYJXux2i+zQB+pC5nmwQ@public.gmane.org,
	geert+renesas-gXvu3+zWzMSzQB+pC5nmwQ@public.gmane.org,
	catalin.marinas-5wv7dgnIgG8@public.gmane.org,
	will.deacon-5wv7dgnIgG8@public.gmane.org,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	alexandre.belloni-wi1+55ScJUtKEb57/3fJTNBPR1lH4CV8@public.gmane.org,
	lorenzo.pieralisi-5wv7dgnIgG8@public.gmane.org,
	linux-lFZ/pmaqli7XmaaqVzeoHQ@public.gmane.org,
	arnd-r2nGTMty4D4@public.gmane.org,
	dbaryshkov-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org,
	linux-rockchip-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org,
	joel-U3u1mxZcP9KHXe+LvDLADg@public.gmane.org,
	treding-DDmLM1+adcrQT0dZR+AlfA@public.gmane.org,
	wxt-TNX95d0MmH7DzftRWevZcw@public.gmane.org,
	devicetree-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	khilman-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	pawel.moll-5wv7dgnIgG8@public.gmane.org,
	ijc+devicetree-KcIKpvwj1kUDXYZnReoRVg@public.gmane.org,
	john.stultz-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	jun.nie-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org,
	moritz.fischer-+aYTwkv1SeIAvxtiuMwx3w@public.gmane.org,
	gregkh-hQyY1W1yCW8ekmWlsbkhG0B+6BGkLq7r@public.gmane.org,
	sjg-F7+t8E8rja9g9hUCZPvPmw@public.gmane.org,
	sre-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org,
	galak-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org,
	olof-nZhT3qVonbNeoWH0uzbU5w@public.gmane.org,
	akpm-de/tnXTf+JLsfHDXvbKv3WD2FQJk+8+b@public.gmane.org
Subject: Re: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver
Date: Tue, 22 Dec 2015 18:32:17 -0600	[thread overview]
Message-ID: <20151223003217.GA18700@rob-hp-laptop> (raw)
In-Reply-To: <1450775124-23966-1-git-send-email-andy.yan-TNX95d0MmH7DzftRWevZcw@public.gmane.org>

On Tue, Dec 22, 2015 at 05:05:24PM +0800, Andy Yan wrote:
> add device tree bindings document for reboot-mode driver
> 
> Signed-off-by: Andy Yan <andy.yan-TNX95d0MmH7DzftRWevZcw@public.gmane.org>
> 
> ---
> 
> Changes in v1: None
> 
>  .../devicetree/bindings/misc/reboot-mode.txt       | 41 ++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/misc/reboot-mode.txt
> 
> diff --git a/Documentation/devicetree/bindings/misc/reboot-mode.txt b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> new file mode 100644
> index 0000000..082bc0c
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> @@ -0,0 +1,41 @@
> +Generic reboot mode communication driver

You're not describing a driver. It is a mapping of boot modes to values.
> +
> +This driver get reboot mode arguments from userspace

Coming from userspace is a Linuxism.

> +and stores it in special register or ram . Then the
> +bootloader will read it and take different action
> +according the argument stored.
> +
> +Required properties:
> +        - compatible = "reboot-mode" or other vendor compatible string;
> +
> +Each mode is represented as a sub-node of reboot_mode:
> +
> +Subnode required properties:
> +        - linux,mode: reboot mode command,such as "loader","recovery", "fastboot".
> +        - linux,magic: magic number for the mode, this is vendor specific.
> +
> +example:
> +	reboot_mode {
> +		compatible = "rockchip,reboot-mode";
> +		rockchip,regmap = <&pmu>;
> +		offset = <0x40>;
> +		loader {
> +			linux,mode = "loader";
> +			linux,magic = <0x5242C301>;
> +		};

These can be much more simply expressed as:

loader = <0x5242c301>;

I would like to see the property names here standardized as much as
possible. I'm not sure if we can define the properties as a u32 or need
some flexibility here.

Rob

WARNING: multiple messages have this Message-ID (diff)
From: robh@kernel.org (Rob Herring)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver
Date: Tue, 22 Dec 2015 18:32:17 -0600	[thread overview]
Message-ID: <20151223003217.GA18700@rob-hp-laptop> (raw)
In-Reply-To: <1450775124-23966-1-git-send-email-andy.yan@rock-chips.com>

On Tue, Dec 22, 2015 at 05:05:24PM +0800, Andy Yan wrote:
> add device tree bindings document for reboot-mode driver
> 
> Signed-off-by: Andy Yan <andy.yan@rock-chips.com>
> 
> ---
> 
> Changes in v1: None
> 
>  .../devicetree/bindings/misc/reboot-mode.txt       | 41 ++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/misc/reboot-mode.txt
> 
> diff --git a/Documentation/devicetree/bindings/misc/reboot-mode.txt b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> new file mode 100644
> index 0000000..082bc0c
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/misc/reboot-mode.txt
> @@ -0,0 +1,41 @@
> +Generic reboot mode communication driver

You're not describing a driver. It is a mapping of boot modes to values.
> +
> +This driver get reboot mode arguments from userspace

Coming from userspace is a Linuxism.

> +and stores it in special register or ram . Then the
> +bootloader will read it and take different action
> +according the argument stored.
> +
> +Required properties:
> +        - compatible = "reboot-mode" or other vendor compatible string;
> +
> +Each mode is represented as a sub-node of reboot_mode:
> +
> +Subnode required properties:
> +        - linux,mode: reboot mode command,such as "loader","recovery", "fastboot".
> +        - linux,magic: magic number for the mode, this is vendor specific.
> +
> +example:
> +	reboot_mode {
> +		compatible = "rockchip,reboot-mode";
> +		rockchip,regmap = <&pmu>;
> +		offset = <0x40>;
> +		loader {
> +			linux,mode = "loader";
> +			linux,magic = <0x5242C301>;
> +		};

These can be much more simply expressed as:

loader = <0x5242c301>;

I would like to see the property names here standardized as much as
possible. I'm not sure if we can define the properties as a u32 or need
some flexibility here.

Rob

  reply	other threads:[~2015-12-23  0:32 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-12-22  9:02 [PATCH v1 0/6] misc: add reboot mode driver Andy Yan
2015-12-22  9:02 ` Andy Yan
2015-12-22  9:05 ` [PATCH v1 1/6] dt-bindings: misc: add document for reboot-mode driver Andy Yan
2015-12-22  9:05   ` Andy Yan
2015-12-23  0:32   ` Rob Herring [this message]
2015-12-23  0:32     ` Rob Herring
2015-12-23  0:32     ` Rob Herring
2015-12-23  8:37     ` Moritz Fischer
2015-12-23  8:37       ` Moritz Fischer
2015-12-23  8:37       ` Moritz Fischer
2015-12-23  9:01     ` Andy Yan
2015-12-23  9:01       ` Andy Yan
2015-12-23  9:01       ` Andy Yan
2015-12-22  9:08 ` [PATCH v1 2/6] dt-bindings: soc: add document for rockchip " Andy Yan
2015-12-22  9:08   ` Andy Yan
2015-12-22  9:10 ` [PATCH v1 3/6] misc: add reboot mode driver Andy Yan
2015-12-22  9:10   ` Andy Yan
2015-12-22  9:13 ` [PATCH v1 4/6] soc: rockchip: " Andy Yan
2015-12-22  9:13   ` Andy Yan
2015-12-22  9:16 ` [PATCH v1 5/6] ARM: dts: rockchip: add reboot-mode node Andy Yan
2015-12-22  9:16   ` Andy Yan
2015-12-22 11:23   ` Heiko Stübner
2015-12-22 11:23     ` Heiko Stübner
2015-12-22 11:23     ` Heiko Stübner
2015-12-22 13:37     ` Andy Yan
2015-12-22  9:19 ` [PATCH v1 6/6] ARM64: " Andy Yan
2015-12-22  9:19   ` Andy Yan
2015-12-22 16:47 ` [PATCH v1 0/6] misc: add reboot mode driver Alexandre Belloni
2015-12-22 16:47   ` Alexandre Belloni
2015-12-22 16:47   ` Alexandre Belloni
2015-12-23  9:31   ` Andy Yan
2015-12-23  9:31     ` Andy Yan
2015-12-23  9:31     ` Andy Yan
2015-12-28 15:28     ` Arnd Bergmann
2015-12-28 15:28       ` Arnd Bergmann
2015-12-28 15:28       ` Arnd Bergmann
2015-12-28 15:56       ` Heiko Stübner
2015-12-28 15:56         ` Heiko Stübner
2015-12-28 16:09         ` Arnd Bergmann
2015-12-28 16:09           ` Arnd Bergmann
2015-12-28 16:09           ` Arnd Bergmann
2015-12-29  7:55       ` Andy Yan
2015-12-29  7:55         ` Andy Yan
2015-12-29  7:55         ` Andy Yan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20151223003217.GA18700@rob-hp-laptop \
    --to=robh@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=alexandre.belloni@free-electrons.com \
    --cc=andy.yan@rock-chips.com \
    --cc=arnd@arndb.de \
    --cc=catalin.marinas@arm.com \
    --cc=dbaryshkov@gmail.com \
    --cc=devicetree@vger.kernel.org \
    --cc=galak@codeaurora.org \
    --cc=geert+renesas@glider.be \
    --cc=gregkh@linuxfoundation.org \
    --cc=heiko@sntech.de \
    --cc=ijc+devicetree@hellion.org.uk \
    --cc=joel@jms.id.au \
    --cc=john.stultz@linaro.org \
    --cc=jun.nie@linaro.org \
    --cc=khilman@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=linux@arm.linux.org.uk \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=mark.rutland@arm.com \
    --cc=moritz.fischer@ettus.com \
    --cc=olof@lixom.net \
    --cc=pawel.moll@arm.com \
    --cc=sjg@chromium.org \
    --cc=sre@kernel.org \
    --cc=treding@nvidia.com \
    --cc=will.deacon@arm.com \
    --cc=wxt@rock-chips.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.