All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change
@ 2016-01-10 15:10 Guenter Roeck
  2016-01-10 15:10 ` [PATCH -next v2 2/2] net: tc35815: Drop unused variable Guenter Roeck
                   ` (2 more replies)
  0 siblings, 3 replies; 5+ messages in thread
From: Guenter Roeck @ 2016-01-10 15:10 UTC (permalink / raw)
  To: David S. Miller; +Cc: netdev, linux-kernel, Guenter Roeck, Andrew Lunn

Commit 7f854420fbfe ("phy: Add API for {un}registering an mdio device to
a bus") introduces an API to access mii_bus structures, but missed to
update the tc35815 driver. This results in the following error message.

drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_probe':
drivers/net/ethernet/toshiba/tc35815.c:617:18: error:
	'struct mii_bus' has no member named 'phy_map'
drivers/net/ethernet/toshiba/tc35815.c:623:24: error:
	'struct mii_bus' has no member named 'phy_map'

Instead of looping over the list of phy addresses to find a phy chip,
use phy_find_first(). While the intent of the original code was to return
an error if more than one phy was specified, this code path was never
executed because the loop aborted after finding the first phy. The
original code is therefore semantically identical to phy_find_first(),
thus it is simpler and more straightforward to use phy_find_first()
directly.

Fixes: 7f854420fbfe ("phy: Add API for {un}registering an mdio device to a bus")
Cc: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
v2: Use phy_find_first() instead of open-coding it.

 drivers/net/ethernet/toshiba/tc35815.c | 17 ++---------------
 1 file changed, 2 insertions(+), 15 deletions(-)

diff --git a/drivers/net/ethernet/toshiba/tc35815.c b/drivers/net/ethernet/toshiba/tc35815.c
index fed5e3dfbc8f..71efe0092bec 100644
--- a/drivers/net/ethernet/toshiba/tc35815.c
+++ b/drivers/net/ethernet/toshiba/tc35815.c
@@ -608,23 +608,10 @@ static void tc_handle_link_change(struct net_device *dev)
 static int tc_mii_probe(struct net_device *dev)
 {
 	struct tc35815_local *lp = netdev_priv(dev);
-	struct phy_device *phydev = NULL;
-	int phy_addr;
+	struct phy_device *phydev;
 	u32 dropmask;
 
-	/* find the first phy */
-	for (phy_addr = 0; phy_addr < PHY_MAX_ADDR; phy_addr++) {
-		if (lp->mii_bus->phy_map[phy_addr]) {
-			if (phydev) {
-				printk(KERN_ERR "%s: multiple PHYs found\n",
-				       dev->name);
-				return -EINVAL;
-			}
-			phydev = lp->mii_bus->phy_map[phy_addr];
-			break;
-		}
-	}
-
+	phydev = phy_find_first(lp->mii_bus);
 	if (!phydev) {
 		printk(KERN_ERR "%s: no PHY found\n", dev->name);
 		return -ENODEV;
-- 
2.1.4

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH -next v2 2/2] net: tc35815: Drop unused variable
  2016-01-10 15:10 [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Guenter Roeck
@ 2016-01-10 15:10 ` Guenter Roeck
  2016-01-11  4:31   ` David Miller
  2016-01-10 15:46 ` [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Andrew Lunn
  2016-01-11  4:31 ` David Miller
  2 siblings, 1 reply; 5+ messages in thread
From: Guenter Roeck @ 2016-01-10 15:10 UTC (permalink / raw)
  To: David S. Miller; +Cc: netdev, linux-kernel, Guenter Roeck, Andrew Lunn

Commit e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
removes some code from tc_mii_init(), but does not remove a now unused
variable. This results in the following build warning.

drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_init':
drivers/net/ethernet/toshiba/tc35815.c:670:6: warning: unused variable 'i'

Fixes: e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
Cc: Andrew Lunn <andrew@lunn.ch>
Acked-by: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
v2: Added Acked-by:

 drivers/net/ethernet/toshiba/tc35815.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/drivers/net/ethernet/toshiba/tc35815.c b/drivers/net/ethernet/toshiba/tc35815.c
index 71efe0092bec..54874783476a 100644
--- a/drivers/net/ethernet/toshiba/tc35815.c
+++ b/drivers/net/ethernet/toshiba/tc35815.c
@@ -654,7 +654,6 @@ static int tc_mii_init(struct net_device *dev)
 {
 	struct tc35815_local *lp = netdev_priv(dev);
 	int err;
-	int i;
 
 	lp->mii_bus = mdiobus_alloc();
 	if (lp->mii_bus == NULL) {
-- 
2.1.4

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change
  2016-01-10 15:10 [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Guenter Roeck
  2016-01-10 15:10 ` [PATCH -next v2 2/2] net: tc35815: Drop unused variable Guenter Roeck
@ 2016-01-10 15:46 ` Andrew Lunn
  2016-01-11  4:31 ` David Miller
  2 siblings, 0 replies; 5+ messages in thread
From: Andrew Lunn @ 2016-01-10 15:46 UTC (permalink / raw)
  To: Guenter Roeck; +Cc: David S. Miller, netdev, linux-kernel

On Sun, Jan 10, 2016 at 07:10:44AM -0800, Guenter Roeck wrote:
> Commit 7f854420fbfe ("phy: Add API for {un}registering an mdio device to
> a bus") introduces an API to access mii_bus structures, but missed to
> update the tc35815 driver. This results in the following error message.
> 
> drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_probe':
> drivers/net/ethernet/toshiba/tc35815.c:617:18: error:
> 	'struct mii_bus' has no member named 'phy_map'
> drivers/net/ethernet/toshiba/tc35815.c:623:24: error:
> 	'struct mii_bus' has no member named 'phy_map'
> 
> Instead of looping over the list of phy addresses to find a phy chip,
> use phy_find_first(). While the intent of the original code was to return
> an error if more than one phy was specified, this code path was never
> executed because the loop aborted after finding the first phy. The
> original code is therefore semantically identical to phy_find_first(),
> thus it is simpler and more straightforward to use phy_find_first()
> directly.
> 
> Fixes: 7f854420fbfe ("phy: Add API for {un}registering an mdio device to a bus")
> Cc: Andrew Lunn <andrew@lunn.ch>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

Acked-by: Andrew Lunn <andrew@lunn.ch>

Thanks
	Andrew

> ---
> v2: Use phy_find_first() instead of open-coding it.
> 
>  drivers/net/ethernet/toshiba/tc35815.c | 17 ++---------------
>  1 file changed, 2 insertions(+), 15 deletions(-)
> 
> diff --git a/drivers/net/ethernet/toshiba/tc35815.c b/drivers/net/ethernet/toshiba/tc35815.c
> index fed5e3dfbc8f..71efe0092bec 100644
> --- a/drivers/net/ethernet/toshiba/tc35815.c
> +++ b/drivers/net/ethernet/toshiba/tc35815.c
> @@ -608,23 +608,10 @@ static void tc_handle_link_change(struct net_device *dev)
>  static int tc_mii_probe(struct net_device *dev)
>  {
>  	struct tc35815_local *lp = netdev_priv(dev);
> -	struct phy_device *phydev = NULL;
> -	int phy_addr;
> +	struct phy_device *phydev;
>  	u32 dropmask;
>  
> -	/* find the first phy */
> -	for (phy_addr = 0; phy_addr < PHY_MAX_ADDR; phy_addr++) {
> -		if (lp->mii_bus->phy_map[phy_addr]) {
> -			if (phydev) {
> -				printk(KERN_ERR "%s: multiple PHYs found\n",
> -				       dev->name);
> -				return -EINVAL;
> -			}
> -			phydev = lp->mii_bus->phy_map[phy_addr];
> -			break;
> -		}
> -	}
> -
> +	phydev = phy_find_first(lp->mii_bus);
>  	if (!phydev) {
>  		printk(KERN_ERR "%s: no PHY found\n", dev->name);
>  		return -ENODEV;
> -- 
> 2.1.4
> 

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change
  2016-01-10 15:10 [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Guenter Roeck
  2016-01-10 15:10 ` [PATCH -next v2 2/2] net: tc35815: Drop unused variable Guenter Roeck
  2016-01-10 15:46 ` [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Andrew Lunn
@ 2016-01-11  4:31 ` David Miller
  2 siblings, 0 replies; 5+ messages in thread
From: David Miller @ 2016-01-11  4:31 UTC (permalink / raw)
  To: linux; +Cc: netdev, linux-kernel, andrew

From: Guenter Roeck <linux@roeck-us.net>
Date: Sun, 10 Jan 2016 07:10:44 -0800

> Commit 7f854420fbfe ("phy: Add API for {un}registering an mdio device to
> a bus") introduces an API to access mii_bus structures, but missed to
> update the tc35815 driver. This results in the following error message.
> 
> drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_probe':
> drivers/net/ethernet/toshiba/tc35815.c:617:18: error:
> 	'struct mii_bus' has no member named 'phy_map'
> drivers/net/ethernet/toshiba/tc35815.c:623:24: error:
> 	'struct mii_bus' has no member named 'phy_map'
> 
> Instead of looping over the list of phy addresses to find a phy chip,
> use phy_find_first(). While the intent of the original code was to return
> an error if more than one phy was specified, this code path was never
> executed because the loop aborted after finding the first phy. The
> original code is therefore semantically identical to phy_find_first(),
> thus it is simpler and more straightforward to use phy_find_first()
> directly.
> 
> Fixes: 7f854420fbfe ("phy: Add API for {un}registering an mdio device to a bus")
> Cc: Andrew Lunn <andrew@lunn.ch>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

Applied.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH -next v2 2/2] net: tc35815: Drop unused variable
  2016-01-10 15:10 ` [PATCH -next v2 2/2] net: tc35815: Drop unused variable Guenter Roeck
@ 2016-01-11  4:31   ` David Miller
  0 siblings, 0 replies; 5+ messages in thread
From: David Miller @ 2016-01-11  4:31 UTC (permalink / raw)
  To: linux; +Cc: netdev, linux-kernel, andrew

From: Guenter Roeck <linux@roeck-us.net>
Date: Sun, 10 Jan 2016 07:10:45 -0800

> Commit e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
> removes some code from tc_mii_init(), but does not remove a now unused
> variable. This results in the following build warning.
> 
> drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_init':
> drivers/net/ethernet/toshiba/tc35815.c:670:6: warning: unused variable 'i'
> 
> Fixes: e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
> Cc: Andrew Lunn <andrew@lunn.ch>
> Acked-by: Andrew Lunn <andrew@lunn.ch>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

Applied.

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2016-01-11  4:31 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-01-10 15:10 [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Guenter Roeck
2016-01-10 15:10 ` [PATCH -next v2 2/2] net: tc35815: Drop unused variable Guenter Roeck
2016-01-11  4:31   ` David Miller
2016-01-10 15:46 ` [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Andrew Lunn
2016-01-11  4:31 ` David Miller

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.