All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] staging: wilc1000: Move Macro definition
@ 2016-01-18 13:42 Gujulan Elango, Hari Prasath (H.)
  2016-02-03 23:19 ` gregkh
  0 siblings, 1 reply; 3+ messages in thread
From: Gujulan Elango, Hari Prasath (H.) @ 2016-01-18 13:42 UTC (permalink / raw)
  To: gregkh, johnny.kim, austin.shin, chris.park, tony.cho, glen.lee, leo.kim
  Cc: devel, linux-kernel, linux-wireless

From: Hari Prasath Gujulan Elango <hgujulan@visteon.com>

This patch move's a macro defined in the middle of a structure
definition to make it more readable.

Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
---
 drivers/staging/wilc1000/wilc_sdio.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c
index e961b50..875ea68 100644
--- a/drivers/staging/wilc1000/wilc_sdio.c
+++ b/drivers/staging/wilc1000/wilc_sdio.c
@@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = {
 };
 
 #define WILC_SDIO_BLOCK_SIZE 512
+#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
 
 typedef struct {
 	bool irq_gpio;
 	u32 block_size;
 	int nint;
-#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
 	int has_thrpt_enh3;
 } wilc_sdio_t;
 
-- 
1.9.1

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] staging: wilc1000: Move Macro definition
  2016-01-18 13:42 [PATCH] staging: wilc1000: Move Macro definition Gujulan Elango, Hari Prasath (H.)
@ 2016-02-03 23:19 ` gregkh
  2016-02-04  5:00   ` Gujulan Elango, Hari Prasath (H.)
  0 siblings, 1 reply; 3+ messages in thread
From: gregkh @ 2016-02-03 23:19 UTC (permalink / raw)
  To: Gujulan Elango, Hari Prasath (H.)
  Cc: johnny.kim, austin.shin, chris.park, tony.cho, glen.lee, leo.kim,
	devel, linux-wireless, linux-kernel

On Mon, Jan 18, 2016 at 01:42:35PM +0000, Gujulan Elango, Hari Prasath (H.) wrote:
> From: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> 
> This patch move's a macro defined in the middle of a structure
> definition to make it more readable.
> 
> Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> ---
>  drivers/staging/wilc1000/wilc_sdio.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c
> index e961b50..875ea68 100644
> --- a/drivers/staging/wilc1000/wilc_sdio.c
> +++ b/drivers/staging/wilc1000/wilc_sdio.c
> @@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = {
>  };
>  
>  #define WILC_SDIO_BLOCK_SIZE 512
> +#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
>  
>  typedef struct {
>  	bool irq_gpio;
>  	u32 block_size;
>  	int nint;
> -#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */

No, this is a very common way to show that this define is for this field
in the structure, please don't change that.

sorry,

greg k-h

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] staging: wilc1000: Move Macro definition
  2016-02-03 23:19 ` gregkh
@ 2016-02-04  5:00   ` Gujulan Elango, Hari Prasath (H.)
  0 siblings, 0 replies; 3+ messages in thread
From: Gujulan Elango, Hari Prasath (H.) @ 2016-02-04  5:00 UTC (permalink / raw)
  To: gregkh
  Cc: johnny.kim, austin.shin, chris.park, tony.cho, glen.lee, leo.kim,
	devel, linux-wireless, linux-kernel

On Wed, Feb 03, 2016 at 03:19:50PM -0800, gregkh@linuxfoundation.org wrote:
> On Mon, Jan 18, 2016 at 01:42:35PM +0000, Gujulan Elango, Hari Prasath (H.) wrote:
> > From: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> > 
> > This patch move's a macro defined in the middle of a structure
> > definition to make it more readable.
> > 
> > Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@visteon.com>
> > ---
> >  drivers/staging/wilc1000/wilc_sdio.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c
> > index e961b50..875ea68 100644
> > --- a/drivers/staging/wilc1000/wilc_sdio.c
> > +++ b/drivers/staging/wilc1000/wilc_sdio.c
> > @@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = {
> >  };
> >  
> >  #define WILC_SDIO_BLOCK_SIZE 512
> > +#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
> >  
> >  typedef struct {
> >  	bool irq_gpio;
> >  	u32 block_size;
> >  	int nint;
> > -#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
> 
> No, this is a very common way to show that this define is for this field
> in the structure, please don't change that.
> 
> sorry,
> 
> greg k-h

Thanks Greg,I got the message clear.Please discard this patch.
Regards,
Hari

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2016-02-04  5:15 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-01-18 13:42 [PATCH] staging: wilc1000: Move Macro definition Gujulan Elango, Hari Prasath (H.)
2016-02-03 23:19 ` gregkh
2016-02-04  5:00   ` Gujulan Elango, Hari Prasath (H.)

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.